Wired Intelligent Edge (Campus Switching and Routing)

Reply
New Contributor

Smart Link configuration on Aruba-VSF-2930F to Cisco

I am looking to create a smart-link group on our DMZ switch to create an active/passive connection to a clients network for quick failover.

 

I am a bit confused if this will work when our device is an Aruba-VSF-2930F, and the clients use Cisco switches.

 

The goal is to create a smart-link group on my switch stack, which has a master port going to to one of their switches, and the slave going to another.  In the event our of ours (or theirs) dies, the slave can take over and operations can continue. 

 

As of right now, they have port 22 shut down on Client Switch 2 and will only activate it in the event of CLient switch 1 going down.  SO it's a manual process which is not ideal failover.

 

This would be my configuration on My Switch 1/2

 

smart-link group 1 master 1/14 slave 2/14 preemption-mode role protected-vlans 54

 

Ports 1/14 and 2/14 are untagged on vlan54

 

From the documentation I have read, it's not necesary that I configure anything on the client switches (they wont be able to process Flush messages, so convergence may take a bit longer?)  

 

Does anyone have any experiance using SMart-Link from HP/Aruba devices to Cisco Devices?  My concern is with us untagging those uplinks with VLAN54, and the Client devices using vlan 499.

 

 

Here is the current configuration on the CIsco (Client) device ports:

 

Client Switch 1#

interface FastEthernet0/22

description *primary link*

switchport access vlan 499

switchport mode access

no keepalive

no cdp enable

spanning-tree portfast

spanning-tree bpdufilter enable

end

!

 

Client Switch 2#

interface FastEthernet0/22

description *Backup Link - Manually enable in DR*

switchport access vlan 499

switchport mode access

shutdown

no keepalive

no cdp enable

spanning-tree portfast

spanning-tree bpdufilter enable

end

 

 

 

Occasional Contributor II

Re: Smart Link configuration on Aruba-VSF-2930F to Cisco

Hi,

 

So as i understand correctly you have on your side vlan 54 which is untagged on your ports. On the Cisco side the customer has vlan 499 untagged on their ports.

 

You are right that you only need to protect vlan 54. You do not have to configure anything on the client side as the flush messages only provide you with a faster failover (When a HP / Aruba switch receives a flush message it will remove the learned mac adresses from the ports)

 

So as long as you only have untagged ports this will work. You also can test this with H3C cloud lab. These are comware switches that also can do smart-link. It create to test different scenarios.

Frequent Contributor II

Re: Smart Link configuration on Aruba-VSF-2930F to Cisco

From the Aruba documentation (advanced traffic management guide):

 

"Only the master interface forwards traffic for a group of VLANs (referred to as protected VLAN group)"

 

So you need to add all the vlans to that group, and then tag them on both switches, otherwise traffic will never flow. A correct configuration of the smart-link will then forward traffic for the configured vlan's over the master interface and failover to the slave interface when the master is down.

 

 

----------Aruba ACCX #748, ACDX #758, ACMP, ACEAP | HPE Master ASE----------
Feel free to give kudos or accept as a solution!
Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: