Wired Intelligent Edge (Campus Switching and Routing)

Reply
New Contributor

Swapping out a Cisco 3750 for a HP 2930

Hi,

We are replacing a cisco 3750 which provides the fibre back to our school purely because we have upgraded to gigabit fibre and the 3750 only has 100mbit on it's ports 

 

in front of this switch is a smoothwall appliance which is gigabit

 

the 3750 only has one copper ethernet port 1 connected which is connected to the smoothwall appliance (which sits on the IP 10.11.90.254)

 

the other connection is an SX trunked fibre link back to the school's core switch its on a native vlan of 90 (also management) and it is using 802.1Q 

I have tried to put in a HP 2530 gigabit switch to enable gigabit over the lan with a HP fibre gbic and tagged all the vlans on the ports in question and left vlan 90 untagged on all ports but it doesn't pass traffic 

 

the ports light up and show traffic but internet traffic is dead  

 

I'm cisco myself and Aruba is very new to me

 

can anyone help after looking at the cisco config below of the switch that needs to be replaced and give me pointers as to what config I need in the HP switch to plug and play?

 

Cisco being replaced is a stack member not the master the master provides some POE for some voip phones, but I'm not concerned about those at the moment the important thing is to get the gigabit working back to the school from the smoothwall appliance

 

any whizzes at cisco ----> hp configs ?

 

Building configuration...

Current configuration : 12157 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log datetime
service password-encryption
service sequence-numbers
!
hostname LEISURE_CENTRE_GND_FLR
!
boot-start-marker
boot-end-marker
!
enable secret 5 ==redacted===
username admin privilege 15 secret 5 ==redacted==
username ==redacted== privilege 15 secret 5 ==redacted==
!
!
aaa new-model
!
!
aaa authentication login default local
!
!
!
aaa session-id common
clock timezone GMT 0
clock summer-time GMT recurring last Sun Mar 1:00 last Sun Oct 2:00
switch 1 provision ws-c3750-24ts
switch 2 provision ws-c3750-24p
system mtu routing 1500
!
!
!
mls qos map cos-dscp 0 8 16 26 32 46 48 56
mls qos
!
crypto pki trustpoint HTTPS_SS_CERT_KEYPAIR
enrollment selfsigned
serial-number
revocation-check none
rsakeypair HTTPS_SS_CERT_KEYPAIR
!
!
crypto pki certificate chain HTTPS_SS_CERT_KEYPAIR
certificate self-signed 01
==redacted==
quit
!
!
!
diagnostic schedule Switch 1 test 1 weekly Monday 5:00 cardindex 1 jobindex 1
diagnostic schedule Switch 2 test 1 weekly Monday 5:00 cardindex 1 jobindex 1
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
interface Port-channel12
switchport trunk encapsulation dot1q
switchport trunk native vlan 90
switchport mode trunk
!
interface FastEthernet1/0/1
description WAN router
switchport access vlan 90
spanning-tree portfast trunk
!
interface FastEthernet1/0/2
description FSO LINK
switchport access vlan 90
!
interface FastEthernet1/0/3
switchport access vlan 210
!
interface FastEthernet1/0/4
switchport access vlan 210
!
interface FastEthernet1/0/5
switchport access vlan 210
!
interface FastEthernet1/0/6
switchport access vlan 210
!
interface FastEthernet1/0/7
switchport access vlan 210
!
interface FastEthernet1/0/8
switchport access vlan 210
!
interface FastEthernet1/0/9
switchport access vlan 210
!
interface FastEthernet1/0/10
switchport access vlan 210
!
interface FastEthernet1/0/11
switchport access vlan 210
!
interface FastEthernet1/0/12
switchport access vlan 120
!
interface FastEthernet1/0/13
switchport access vlan 210
!
interface FastEthernet1/0/14
switchport access vlan 210
!
interface FastEthernet1/0/15
switchport access vlan 210
!
interface FastEthernet1/0/16
switchport access vlan 210
!
interface FastEthernet1/0/17
switchport access vlan 210
!
interface FastEthernet1/0/18
switchport access vlan 210
!
interface FastEthernet1/0/19
switchport access vlan 210
!
interface FastEthernet1/0/20
switchport access vlan 210
!
interface FastEthernet1/0/21
switchport access vlan 210
!
interface FastEthernet1/0/22
switchport access vlan 210
!
interface FastEthernet1/0/23
switchport access vlan 210
!
interface FastEthernet1/0/24
description management
switchport access vlan 90
!
interface GigabitEthernet1/0/1
switchport trunk encapsulation dot1q
switchport trunk native vlan 90
switchport mode trunk
!
interface GigabitEthernet1/0/2
switchport trunk encapsulation dot1q
switchport trunk native vlan 90
switchport mode trunk
channel-group 12 mode on
!
interface FastEthernet2/0/1
description "Connection for Mitel IP Phone"
switchport access vlan 210
switchport mode access
switchport voice vlan 80
priority-queue out
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet2/0/2
description "Connection for Mitel IP Phone"
switchport access vlan 210
switchport mode access
switchport voice vlan 80
priority-queue out
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet2/0/3
description "Connection for Mitel IP Phone"
switchport access vlan 110
switchport mode access
switchport voice vlan 80
priority-queue out
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet2/0/4
description "Connection for Mitel IP Phone"
switchport access vlan 210
switchport mode access
switchport voice vlan 80
priority-queue out
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet2/0/5
description "Connection for Mitel IP Phone"
switchport access vlan 210
switchport mode access
switchport voice vlan 80
priority-queue out
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet2/0/6
description "Connection for Mitel IP Phone"
switchport access vlan 210
switchport mode access
switchport voice vlan 80
priority-queue out
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet2/0/7
description "Connection for Mitel IP Phone"
switchport access vlan 210
switchport mode access
switchport voice vlan 80
priority-queue out
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet2/0/8
description "Connection for Mitel IP Phone"
switchport access vlan 210
switchport mode access
switchport voice vlan 80
priority-queue out
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet2/0/9
description "Connection for Mitel IP Phone"
switchport access vlan 110
switchport mode access
switchport voice vlan 80
priority-queue out
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet2/0/10
description "Connection for Mitel IP Phone"
switchport access vlan 210
switchport mode access
switchport voice vlan 80
priority-queue out
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet2/0/11
description "Connection for Mitel IP Phone"
switchport access vlan 210
switchport mode access
switchport voice vlan 80
priority-queue out
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet2/0/12
description "Connection for Mitel IP Phone"
switchport access vlan 210
switchport mode access
switchport voice vlan 80
priority-queue out
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet2/0/13
description "Connection for Mitel IP Phone"
switchport access vlan 210
switchport mode access
switchport voice vlan 80
priority-queue out
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet2/0/14
description "Connection for Mitel IP Phone"
switchport access vlan 210
switchport mode access
switchport voice vlan 80
priority-queue out
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet2/0/15
description "Connection for Mitel IP Phone"
switchport access vlan 210
switchport mode access
switchport voice vlan 80
priority-queue out
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet2/0/16
description "Connection for Mitel IP Phone"
switchport access vlan 210
switchport mode access
switchport voice vlan 80
priority-queue out
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet2/0/17
description "Connection for Mitel IP Phone"
switchport access vlan 210
switchport mode access
switchport voice vlan 80
priority-queue out
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet2/0/18
description "Connection for Mitel IP Phone"
switchport access vlan 210
switchport mode access
switchport voice vlan 80
priority-queue out
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet2/0/19
description "Connection for Mitel IP Phone"
switchport access vlan 210
switchport mode access
switchport voice vlan 80
priority-queue out
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet2/0/20
description "Connection for Mitel IP Phone"
switchport access vlan 210
switchport mode access
switchport voice vlan 80
priority-queue out
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet2/0/21
description "Connection for Mitel IP Phone"
switchport access vlan 210
switchport mode access
switchport voice vlan 80
priority-queue out
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet2/0/22
description "Connection for Mitel IP Phone"
switchport access vlan 210
switchport mode access
switchport voice vlan 80
priority-queue out
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet2/0/23
description "Connection for Mitel IP Phone"
switchport access vlan 210
switchport mode access
switchport voice vlan 80
priority-queue out
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet2/0/24
description LC Changing IN AP
switchport access vlan 60
switchport trunk encapsulation dot1q
switchport trunk native vlan 60
switchport mode trunk
spanning-tree portfast
spanning-tree bpduguard enable
!
interface GigabitEthernet2/0/1
switchport trunk encapsulation dot1q
switchport trunk native vlan 90
switchport mode trunk
!
interface GigabitEthernet2/0/2
switchport trunk encapsulation dot1q
switchport trunk native vlan 90
switchport mode trunk
channel-group 12 mode on
!
interface Vlan1
no ip address
no ip route-cache
no ip mroute-cache
shutdown
!
interface Vlan90
description **** Management ****
ip address 10.11.90.12 255.255.255.0
no ip route-cache
no ip mroute-cache
!
ip default-gateway 10.11.90.1
ip classless
ip http server
ip http authentication local
ip http secure-server
!
!
!
line con 0
line vty 0 4
password 7 ==redacted==
length 0
line vty 5 15
!
ntp clock-period 36026822
ntp server 10.11.50.254
end

Contributor I

Re: Swapping out a Cisco 3750 for a HP 2930

If i'm understanding your question correctly, you should be able to do this...

 

**port to sonicwall**

vlan 90 untagged 12 (or whatever interface you are using)

 

**port to core switch**

 

trunk "interface to core" trk1 trunk

vlan 90 untagged trk1

vlan yy tagged trk1

vlan xx tagged trk1

 

It might help if you can share a santized config of what you have on the HP/Aruba side

 

Chris Wickline | Network Engineer | York College of Pennsylvania
New Contributor

Re: Swapping out a Cisco 3750 for a HP 2930

Hi,

Unfortunately I cleared the config of the HP switch and put back in the old switch after half an hour of scratching my head

 

So what you're saying is create a (HP style trunk which means something completely diffferent to a cisco trunk) trunk on the HP and add all the vlans present on the core switch to that trunk and tag them except the vlan 90 which would need to be untagged.

 

So I'm basically assigning the vlans I want to trk1 then assigning that to the port the cisco trunk is coming in on via the fibre link, and the 802.1Q via the tagging in the HP will seperate out the vlans (in effect)

 

then assign that trunk to the fibre port on the HP and all should spring to life?

 

I'll no doubt get used to Aruba but when you've been using cisco for decades it's a minefield of errors and misinterpretation 

Highlighted
MVP Expert

Re: Swapping out a Cisco 3750 for a HP 2930

Cheers,

 

One thing to mention in your current Cisco 3750 deployment is that, as you already pointed out at very beginning, you're dealing with a Cisco Stack...this means that both Cisco 3750 are interconnected through a StackWise Cable on the back (do a show switch on Cisco CLI and post the sanitized output)...so they act a single logical switch from the uplinked/downlinked peers standpoint (note the interface numbering x/0/n where x is the Switch Stack id number and n is the port of that Switch member).

 

Why I write that?

 

Because you initially also wrote "Cisco being replaced is a stack member not the master" and this, to me, means you're planning to split the actual stack in two fragments and then just replace one of its Stack ex-members. If so let me consider the actual Cisco's Port-channel 12 definition you posted:

 

!
interface Port-channel12
switchport trunk encapsulation dot1q
switchport trunk native vlan 90
switchport mode trunk
!

The above is used to define a new logical interface (the Port-Channel) bundled to which there are - in your scenario - two physical Gigabit Ethernet interfaces, respectively, on Stack Switch 1:

 

!
interface GigabitEthernet1/0/2
switchport trunk encapsulation dot1q
switchport trunk native vlan 90
switchport mode trunk
channel-group 12 mode on
!

and on Stack Switch 2:

 

!
interface GigabitEthernet2/0/2
switchport trunk encapsulation dot1q
switchport trunk native vlan 90
switchport mode trunk
channel-group 12 mode on
!

The configuration above is quite important.

 

Why?

 

Because it tells us that two Gigabit Ethernet Interfaces (numbered 1/0/2 and 2/0/2) are bundled - aggregated - together in a Cisco STATIC port channel group...(sorry, no LACP here...and just for reference, have a read here).

 

What this means?

 

It means that that link (physical and logical) connected to this Port Channel Group should have a peer (your Core!) with the very same configuration (Port Channel Group id could be different, ports involved too but the attributes of those ports and VLAN tagging can't).

 

This Port Channel is untagged, in HP/HPE-Aruba jargon, on VLAN id 90.

 

That long preamble to say that IF you're going to replace the whole Stack then the Aruba 2930 (2930M? 2930F? in standalone mode or not?) needs to have a configuration that is like the one suggested above, from what I read on Cisco side it is enough:

 

trunk N,M trk1 trunk
vlan 90 untagged trk1

where N and M are two Gigabit Ethernet physical interfaces...and, since you wrote about Fiber Link to Core...I presume you will need to populate two SFP slots with SFP Tranceivers and aggregate (trunk in HP jargon) them together. The aggregation - trk1 - will be then untagged in VLAN 90.

 

If - instead - you are dealing with a Stack split operation: re-standalone both Cisco Switches...and then exchange one of them with an Aruba 2930M/F...then things to change are much more (trunk will be necessary too?) because you're going to break the Port Channel you're actively using to your Core Switch...but I don't think this would really be your desired approach (keeping one Cisco and replacing the other one with an Aruba).

 

Sorry if I misunderstood your statements...worth to specify scenarios to avoid issues in the migration...cleared this point will leave us free to speak about other migration minor aspects (Voice VLAN, VLAN access ports, port-fast mode, etc.)

 

New Contributor

Re: Swapping out a Cisco 3750 for a HP 2930

I was aware it was a split stack, but on looking at the config I didn't notice the link was aggregated, thank you for pointing that out.

 

in my defence I was in a very dark pokey walk in storage cupboard with the switches in blistering heat as their air con had packed up with sweat dripping into my eyes using a mobile phone light to see :(

 

My (now wrong) assumption at the time was we had two cisco trunks coming in from the core switch split across the stack relying on STP to shut one down for redundancy, because there is another fibre link in the 3750 which is dead but connected, I'd assumed the other fibre link went into our PE department where we have another stack (how wrong you can be when sweating to death)

 

However what you've pointed out does complicate things

 

Seeing as the core switch is seen as one switch is it possible to configure the HP switch to take the existing configured port channel in standalone mode as a single switch ? 

 

ie/ bring the other fibre link into the single HP switch ?

 

 

and would I have to reconfigure the core switch to LACP ?

 

Smoothwall side of internet connection etherchannel

Port-channel12 is up, line protocol is up (connected)
Hardware is EtherChannel, address is 001e.f6dc.aa02 (bia 001e.f6dc.aa02)
MTU 1500 bytes, BW 2000000 Kbit, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, 1000Mb/s, link type is auto, media type is unknown
input flow-control is off, output flow-control is unsupported
Members in this channel: Gi1/0/2 Gi2/0/2
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:03:59, output 00:00:00, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 2051000 bits/sec, 555 packets/sec
5 minute output rate 865000 bits/sec, 405 packets/sec
1924445647 packets input, 787428244684 bytes, 0 no buffer
Received 168898654 broadcasts (135649217 multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 135649217 multicast, 0 pause input
0 input packets with dribble condition detected
2273622492 packets output, 2127411055358 bytes, 0 underruns
0 output errors, 0 collisions, 1 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 PAUSE output
0 output buffer failures, 0 output buffers swapped out

 

Corresponding Port Channel on core switch

Port-channel10 is up, line protocol is up (connected)
Hardware is EtherChannel, address is 001f.9dba.360c (bia 001f.9dba.360c)
Description: ****LC_GND_FLR****
MTU 1500 bytes, BW 2000000 Kbit, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, 1000Mb/s, link type is auto, media type is unknown
Media-type configured as connector
input flow-control is off, output flow-control is unsupported
Members in this channel: Gi1/0/12 Gi2/0/12
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:00, output 00:05:25, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 896000 bits/sec, 410 packets/sec
5 minute output rate 2024000 bits/sec, 548 packets/sec
2273659041 packets input, 2127421403480 bytes, 0 no buffer
Received 32081202 broadcasts (31287959 multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 31287959 multicast, 0 pause input
0 input packets with dribble condition detected
1924496499 packets output, 787450331464 bytes, 0 underruns
0 output errors, 0 collisions, 4 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 PAUSE output
0 output buffer failures, 0 output buffers swapped out

 

 

 

 

MVP Guru

Re: Swapping out a Cisco 3750 for a HP 2930

Sidely related: there is a free book from HPE Press: ArubaOS-Switch, Comware and Cisco IOS CLI Reference Guide, that lists Cisco and ArubaOS-Switch command equivalents.

 

And you learned already that ArubaOS switch is configured around the VLAN vs configuration around interfaces, and PortChannels are called Trunks on ArubaOS switches.

--
If you have urgent issues, please contact your Aruba partner or Aruba TAC (click for contact details).
MVP Expert

Re: Swapping out a Cisco 3750 for a HP 2930

Yeah, the very latest is the CLI Reference Guide for ArubaOS-CX, ArubaOS-Switch and Cisco IOS (published January 2019, revision 5) and its evolution was briefly discussed some moths ago here (Comware was removed).

 

Side note: also this Aruba VLAN and Link-Aggregation interoperability between ArubaOS-Switches and Cisco ISO devices would be of help.

 

With regard to the OP scenario...I'm loosing myself...I need a topology map of the actual status and eventually of the desired one to make an idea of possible scenarios (please draw me a basic map on a piece of paper... :-) to understand who is who and where uplinks are going).

 

Is port group 10 defined on Core connected to port group 12 defined into Cisco 3750 Stack? are you meaning that?

New Contributor

Re: Swapping out a Cisco 3750 for a HP 2930

The gigabit internet feed comes into the Leisure Centre and is connected to a Smoothwall filtering appliance, that in turn is fed to a two switch 3750 stack (currently on a 100mbit link) which we want to replace with a gigabit link on our new HP 2530 

 

There are two long range fibre runs from the leisure centre where the internet feed comes in which go into the school core switch

 

 

port channel 10 (core switch) is an aggregate of G1/1/12 and G2/2/12
which is on the core switch carrying all 32 vlans

 

show etherchannel 10 detail
Group state = L2
Ports: 2 Maxports = 8
Port-channels: 1 Max Port-channels = 1
Protocol: -
Minimum Links: 0
Ports in the group:
-------------------
Port: Gi1/0/12
------------

Port state = Up Mstr In-Bndl
Channel group = 10 Mode = On Gcchange = -
Port-channel = Po10 GC = - Pseudo port-channel = Po10
Port index = 0 Load = 0x00 Protocol = -

Age of the port in the current state: 3d:09h:19m:48s

Port: Gi2/0/12
------------

Port state = Up Mstr In-Bndl
Channel group = 10 Mode = On Gcchange = -
Port-channel = Po10 GC = - Pseudo port-channel = Po10
Port index = 0 Load = 0x00 Protocol = -

Age of the port in the current state: 3d:09h:02m:28s

Port-channels in the group:
---------------------------

Port-channel: Po10
------------

Age of the Port-channel = 23d:08h:49m:14s
Logical slot/port = 10/10 Number of ports = 2
GC = 0x00000000 HotStandBy port = null
Port state = Port-channel Ag-Inuse
Protocol = -
Port security = Disabled

Ports in the Port-channel:

Index Load Port EC state No of bits
------+------+------+------------------+-----------
0 00 Gi1/0/12 On 0
0 00 Gi2/0/12 On 0

Time since last port bundled: 3d:09h:02m:32s Gi2/0/12
Time since last port Un-bundled: 3d:09h:20m:51s Gi1/0/12

 

port channel 12 (leisure centre) is an aggregate of G1/0/2 and G2/0/2
which is on the Leisure Centre switch stack 3750 carrying all 32 vlans

show etherchannel 12 detail
Group state = L2
Ports: 2 Maxports = 8
Port-channels: 1 Max Port-channels = 1
Protocol: -
Minimum Links: 0
Ports in the group:
-------------------
Port: Gi1/0/2
------------

Port state = Up Mstr In-Bndl
Channel group = 12 Mode = On Gcchange = -
Port-channel = Po12 GC = - Pseudo port-channel = Po12
Port index = 0 Load = 0x00 Protocol = -

Age of the port in the current state: 3d:09h:04m:05s

Port: Gi2/0/2
------------

Port state = Up Mstr In-Bndl
Channel group = 12 Mode = On Gcchange = -
Port-channel = Po12 GC = - Pseudo port-channel = Po12
Port index = 0 Load = 0x00 Protocol = -

Age of the port in the current state: 3d:09h:21m:26s

Port-channels in the group:
---------------------------

Port-channel: Po12
------------

Age of the Port-channel = 23d:08h:51m:34s
Logical slot/port = 10/12 Number of ports = 2
GC = 0x00000000 HotStandBy port = null
Port state = Port-channel Ag-Inuse
Protocol = -
Port security = Disabled

Ports in the Port-channel:

Index Load Port EC state No of bits
------+------+------+------------------+-----------
0 00 Gi1/0/2 On 0
0 00 Gi2/0/2 On 0

Time since last port bundled: 3d:09h:04m:08s Gi1/0/2
Time since last port Un-bundled: 3d:09h:22m:28s Gi2/0/2

 

hope that helps ?

 

We want to use the new HP 2530 to replace the aging 3750 stack 

but would prefer not to alter the config on the core switch and would rather mould the 2530 to fit the existing configuration 

 

 

MVP Expert

Re: Swapping out a Cisco 3750 for a HP 2930

OK, so if your plan is to replace the entire Cisco 3750 Stack with just one Aruba 2530 then on the latter one you just need to:

  • replicate VLANs (with IPs, where defined)
  • set the Voice dedicated VLAN of type voice in related VLAN id context.
  • tag relevant access ports with Voice VLAN Id for any port that will be connected to a VoIP Phone.
  • untag (native) relevant access ports with correct VLAN Id (this depend how you will migrate from Stack to standalone...aka ports usage)
  • create a trunk port (a logical port with physical member ports aggregated together) of type non-protocol (so NO LACP) since this is what you actually have between your Cisco Switches (2 FO links aggregated together in a static EtherChannel).
  • Set correct untagged/tagged membership to the port used to uplink to the Smoothwall Appliance (replicate what you already have on the Cisco Stack). 
  • Set correct untagged VLAN membership (native VLAN) for the above trunk port (forget about its member interfaces, all happens at logical level of trunk trkX interface).
  • Sec correct tagged VLANs membership (permitted VLAN other than the native one).
  • Do the swap and check.
  • Other refinements can be done consequently (STP should be configured correctly to speak flawlessly with your Core <-- it depends on your Core configuration, if any; access ports portfast and bpdu-protection, etc.).

Since you now have a clear vision of what you have in terms of assets and about the way those assets are interconnected and since VLAN mapping is a matter of writing down which port is tagged/untagged on what VLANs...it should be relatively simple to test for a successful swap (and, remember, you now have also a good documentation about a like-for-like features/commands comparison between ArubaOS-Switch and Cisco IOS).

 

Do not forget to update your ArubaOS-Switch to latest 16.09.0001 so you can start already updated.

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: