Wired Intelligent Edge (Campus Switching and Routing)

Reply
Occasional Contributor I

Switchport config

Hi there,

 

I'm migrating from Cisco switch to Aruba switch 3810. How can I configure the interface in Aruba switch for this config in cisco :

 

interface GigabitEthernet1/1
switchport access vlan 64
switchport trunk native vlan 64
switchport trunk allowed vlan 64
switchport mode access

MVP Expert

Re: Switchport config

Greetings!

 

Most VLAN configuration on ArubaOS-Switch is performed in the VLAN context rather than at the interface context. For example, to create VLAN 64 and assign it to interface 1 as an access (or "untagged") VLAN:

 

switch(config)# vlan 64
switch(vlan-64)# untagged 1

Once a VLAN has been created, you also have the option of performing VLAN assignments from the interface context, as in the following examples:

 

switch(config)# interface 2-8 untagged vlan 64
switch(config)# interface 24 tagged vlan 64

 



Matthew Fern
Technical Marketing Engineer, Wired Intelligent Edge

Aruba, a Hewlett Packard Enterprise company

8000 FOOTHILLS BLVD  |  ROSEVILLE, CA 95747
T: 916.540.1759  |  E: mfern@hpe.com
Occasional Contributor I

Re: Switchport config

Thank you so much for your reply; if you could help which exactly the config I should use in Aruba-OS switch for Cisco the example as I'm still confused!
interface GigabitEthernet1/1
switchport access vlan 64
switchport trunk native vlan 64
switchport trunk allowed vlan 64
switchport mode access

Will VLAN 64 be tagged or untagged, what about native VLAN 64? Allowed VLAN64?
MVP Expert

Re: Switchport config

Maybe I'm wrong but

 

interface GigabitEthernet1/1
  switchport access vlan 64
  switchport trunk native vlan 64
  switchport trunk allowed vlan 64
  switchport mode access

is a pretty strange interface configuration (read, as example, here).

 

Is the Interface 1/1 set in Access mode (in Cisco jargon) or is it set with Trunk mode (again, in Cisco jargon)?

 

You shouldn't have both, Access and Trunk...it is Access or Trunk.

 

If the Interface 1/1 is set in Access mode (so the switchport mode access is valid) then this would translate into what @Matthew wrote first above:

 

switch(config)# vlan 64
switch(vlan-64)# untagged 1

or, from the interface 1 standpoint, just the very same:

 

switch(config)# interface 1 untagged vlan 64

If, instead, your Interface 1/1 is set in Trunk mode (switchport mode trunk) then this translates into:

 

switch(config)# interface 1 tagged vlan 64

implying that Interface 1 is STILL untagged member of VLAN 1 (Default) but is now tagged member of VLAN 64...so this means it can transport VLAN 64 tagged packets.

 

Cisco side:

 

Potentially...you config would be - if interconnecting to Switches and passing JUST one VLAN (your VLAN 64):

 

interface 1/1
switchport encapsulation dot1q
switchport mode trunk
switchport trunk native vlan 64
switchport trunk allowed vlan 64

With this configuration VLAN 64 will be untagged on Interface 1/1 (note the native) and will also be the only one VLAN allowed to be transported through it (note the allowed) ...but, generally, the Trunk mode is often used when you want a switch interface - logical of physical - to carry MULTIPLE concurrent VLANs between two peer Switches (or between a Switch and a Host capable of VLAN tagging), not just simply one...still that is totally possible.

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: