Wired Intelligent Edge (Campus Switching and Routing)

Reply
Highlighted
Frequent Contributor II

Time incorrect / 1hr ahead on Aruba 2930F - Using NTP

Hi all,

 

I'm using NTP on an Aruba 2930F, running the latest firmware. The thing is, my clock is an hour off and I can't understand why. I'm using us.pool.ntp.org which has always been accurate for me.

 

NTP configuration is as follows:

timesync ntp
ntp unicast
ntp server-name "us.pool.ntp.org" iburst
ntp enable
time daylight-time-rule user-defined begin-date 03/10 end-date 11/03
time timezone -420

At the time of this post UTC/GMT is 19:48. I'm in PST so the switch should be 12:48. Yet I'm getting 13:48 from the switch, indicating it's 1hr off/ahead.

 

Aruba-Lab-SW1# show time
Sun Aug  4 13:48:11 2019

NTP associations look good:

 

Aruba-Lab-SW1# show ntp associations

                            NTP Associations Entries


 Remote          St   T    When   Poll  Reach    Delay    Offset   Dispersion
 --------------- ---- ---- ------ ----- -------- -------- -------- ----------
 50.205.244.111  2    u    408    8     3        0.000    0.000    15.87941

And NTP status:

 

Aruba-Lab-SW1# show ntp status

 NTP Status Information

  NTP Status             : Enabled         NTP Mode        : Unicast
  Synchronization Status : Synchronized    Peer Dispersion : 0.00000 sec
  Stratum Number         : 3               Leap Direction  : 0
  Reference Assoc ID     : 0               Clock Offset    : -0.00021 sec
  Reference ID           : 50.205.244.111  Root Delay      : 0.05642 sec
  Precision              : 2**-18          Root Dispersion : 0.04622 sec
  NTP Up Time            : 0d 0h 8m        Time Resolution : 819 nsec
  Drift                  : 0.00000 sec/sec

  System Time            : Sun Aug  4 13:50:38 2019
  Reference Time         : Sun Aug  4 13:38:11 2019

Aruba-Lab-SW1#

I'm at a loss. Does anyone have any ideas here? I'm temporarily setting the timezone to -480 as a temporary fix but that doesn't seem right.

 

Thanks in advance!


Accepted Solutions
Highlighted
Frequent Contributor II

Re: Time incorrect / 1hr ahead on Aruba 2930F - Using NTP

Ah! - So I realized my mistake. I think what's actually needed (for this to happen automatically) is for me to set the timezone to PST and then set the daylight-time-rule to continental-us-and-canada.

 

The correct configuration should be:

 

time timezone -480
time daylight-time-rule continental-us-and-canada

Since I'm technically in the PST time zone, the switch now uses its internal calendar to set the time zone to PDT which is UCT -7 currently, even though I specified -480 in the config!

View solution in original post


All Replies
Highlighted
New Contributor

Re: Time incorrect / 1hr ahead on Aruba 2930F - Using NTP

Hi,

 

I redid the configuration you posted without the time daylight settings and the time is what you want, but when we do the time daylight setting, we are automatically within the time frame you entered in your setting (March 10th and ending November 3rd) and with that we have this difference reported.

 

Aruba-2930F-24G-PoEP-4SFPP(config)# show ntp status

 NTP Status Information

  NTP Status             : Enabled         NTP Mode        : Unicast         
  Synchronization Status : Synchronized    Peer Dispersion : 0.00000 sec     
  Stratum Number         : 3               Leap Direction  : 0               
  Reference Assoc ID     : 0               Clock Offset    : 0.00221 sec     
  Reference ID           : 64.22.253.155   Root Delay      : 0.19228 sec     
  Precision              : 2**-18          Root Dispersion : 0.07641 sec     
  NTP Up Time            : 0d 0h 23m       Time Resolution : 819 nsec        
  Drift                  : 0.00001 sec/sec 

  System Time            : Sun Aug  4 13:20:53 2019                
  Reference Time         : Sun Aug  4 12:45:29 2019                

Aruba-2930F-24G-PoEP-4SFPP(config)# show time
Sun Aug  4 13:20:58 2019
Aruba-2930F-24G-PoEP-4SFPP(config)# show run

Running configuration:

; JL255A Configuration Editor; Created on release #WC.16.08.0001
; Ver #14:07.6f.f8.1d.9b.3f.bf.bb.ef.7c.59.fc.6b.fb.9f.fc.ff.ff.37.ef:24
hostname "Aruba-2930F-24G-PoEP-4SFPP"
module 1 type jl255a
timesync ntp
ntp unicast
ntp server-name "us.pool.ntp.org" iburst
ntp enable
time timezone -420
snmp-server community "public" unrestricted
vlan 1
   name "DEFAULT_VLAN"
   untagged 1-28
   ip address dhcp-bootp
   ipv6 enable
   ipv6 address dhcp full
   exit

Aruba-2930F-24G-PoEP-4SFPP(config)# 

Configuration with daylight

 

 

Aruba-2930F-24G-PoEP-4SFPP(config)# show ntp status

 NTP Status Information

  NTP Status             : Enabled         NTP Mode        : Unicast         
  Synchronization Status : Synchronized    Peer Dispersion : 0.00000 sec     
  Stratum Number         : 3               Leap Direction  : 0               
  Reference Assoc ID     : 0               Clock Offset    : 0.00221 sec     
  Reference ID           : 64.22.253.155   Root Delay      : 0.19228 sec     
  Precision              : 2**-18          Root Dispersion : 0.07773 sec     
  NTP Up Time            : 0d 0h 24m       Time Resolution : 819 nsec        
  Drift                  : 0.00001 sec/sec 

  System Time            : Sun Aug  4 14:22:20 2019                
  Reference Time         : Sun Aug  4 13:45:29 2019                

Aruba-2930F-24G-PoEP-4SFPP(config)# show time
Sun Aug  4 14:22:26 2019
Aruba-2930F-24G-PoEP-4SFPP(config)# show run

Running configuration:

; JL255A Configuration Editor; Created on release #WC.16.08.0001
; Ver #14:07.6f.f8.1d.9b.3f.bf.bb.ef.7c.59.fc.6b.fb.9f.fc.ff.ff.37.ef:24
hostname "Aruba-2930F-24G-PoEP-4SFPP"
module 1 type jl255a
timesync ntp
ntp unicast
ntp server-name "us.pool.ntp.org" iburst
ntp enable
time daylight-time-rule user-defined begin-date 03/10 end-date 11/03
time timezone -420
snmp-server community "public" unrestricted
vlan 1
   name "DEFAULT_VLAN"
   untagged 1-28
   ip address dhcp-bootp
   ipv6 enable
   ipv6 address dhcp full
   exit

Aruba-2930F-24G-PoEP-4SFPP(config)# 

 

Highlighted
Frequent Contributor II

Re: Time incorrect / 1hr ahead on Aruba 2930F - Using NTP

Ah! - So I realized my mistake. I think what's actually needed (for this to happen automatically) is for me to set the timezone to PST and then set the daylight-time-rule to continental-us-and-canada.

 

The correct configuration should be:

 

time timezone -480
time daylight-time-rule continental-us-and-canada

Since I'm technically in the PST time zone, the switch now uses its internal calendar to set the time zone to PDT which is UCT -7 currently, even though I specified -480 in the config!

View solution in original post

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: