Wired Intelligent Edge (Campus Switching and Routing)

New Contributor

Unsupported DACs on 2540


We bought a few 2540 switches (JL357A) and like to connect them to our Cisco 9300 Switches via direct attach cables. The switches are running on the latest firmware (YC.16.09.0001) and I enabled support for unsupported transceivers. The DACs we use are Cisco SFP-H10GB-CU3M.

Looking at Table 1 in the "Allow unsupported transceivers"-guide from aruba, "10-GbE SFP+ 3m Direct Attach Cable" should be supported.
But when looking at the output of

show tech transceivers

it shows otherwise:

Transceiver Technical Information:
 Port # | Type      | Prod #     | Serial #         | Part #
 52    *|    ??     |       ??   | unsupported      |

* third-party transceiver

and the LED for the port is flashing orange.
As far as i understand, when enabling unsupported devices, any DAC should work.

Any hints on how to resolve this issue?
I don't want to change to aruba DACs and play the same game on the side of the Cisco Switches again.

MVP Expert

Re: Unsupported DACs on 2540

I'm afraid...but I suspect you're overrating the purpose of the feature "allow-unsupported-transceiver", Aruba states quite clearly on the Aruba Allow Unsupported Tranceivers Guide you cited:

"The Allow Unsupported Transceiver feature allows the user to try a transceiver part (including DAC cables) without the switch attempting to authenticate it as a genuine HPE Aruba part. There is no guarantee that all thirdparty transceivers will work: typically the ones that work are industry-standard types as identified by the MSA standards body. Those parts that do not comply will most likely still not be enabled."

The fact the second highligthed sentence does not specify a good "including DAC cables" being like: "There is no guarantee that all thirdparty transceivers (including DAC cables) will work" doesn't automatically mean that all other venders' DAC cable work for sure once the allow-unsuspported-transceiver command is executed.


And the Table 1 you refer to...contains just SFP/SFP+/DAC references that are enabled to eventually been accepted as unsupported, if recognized (again, here no warranty by Aruba). So IMHO you simply risk to slip on a wet floor by overrating the promises of this feature.

My take: go with (more expensive) SFP+ LC to SFP+ LC multi-mode fiber optic link(s)...even if the distance between your Cisco 9300 and your Aruba 2540 is just few meters long...it will cost you more (and you will save a test with the Aruba DAC that could be unsupported Cisco side)...but I'll work 100%.


If you enable debug mode and check logging (in reverse mode):


2540# debug event
2540# debug destination session
2540# show logging -r

 when you insert the Cisco DAC what is the logged output?

MVP Expert

Re: Unsupported DACs on 2540



This summary is correct — the allow-unsupported-transceivers command only permits the switch to try to enable an unsupported transceiver or cable. If it works, it works; if it doesn't, it doesn't (and it's probably because something about the transceiver or cable isn't compliant with industry standards).


Further, as is implied by the name of the command and explicitly stated by the disclaimer that pops up in the console when you run it, unsupported transceivers and cables are just that: unsupported. Aruba support may provide limited (or no) support for issues caused by an unsupported transceiver or cable.

Matt Fern
Technical Marketing Engineer, Wired Intelligent Edge

Aruba, a Hewlett Packard Enterprise company

T: 916.540.1759  |  E: mfern@hpe.com   |   Matt @ Twitter
New Contributor

Re: Unsupported DACs on 2540

@parnassus wrote:

when you insert the Cisco DAC what is the logged output?

port 52 Transceiver type not supported in this port.

Thanks for your replies, I thought it should work, because Cisco states that their DACs are SFP+ MSA SFF-8461 compliant and these cables work fine with our HPE 5130 (JG934A).

Lesson learned, I'll either go the extra mile and use SPF+ LC or just use LACP since there is not that much bandwith usage to expect.
Thanks again for your time and effort!

Search Airheads
Showing results for 
Search instead for 
Did you mean: