Wired Intelligent Edge (Campus Switching and Routing)

Reply
Highlighted
Frequent Contributor II

routing issue

Hi,

 

i have a 2930F with one interface in vlan 254 connected to a fw (which is here default router 192.168.254.254)
I use vlan 254 purely for routing in this case.

Switch config in a nutshell :

vlan 101
name "VLAN101"
untagged 47
tagged 1-45
no ip address
exit
vlan 111
name "VLAN111"
untagged 46
tagged 1-45
ip address 10.35.111.254 255.255.255.0
ip address 10.74.111.254 255.255.255.0
ip address 10.90.111.254 255.255.255.0
exit
vlan 254
name "VLAN254"
untagged 48
ip address 192.168.254.251 255.255.255.0
exit
primary-vlan 254
management-vlan 254

ip route 0.0.0.0 0.0.0.0 192.168.254.254
ip routing

 

When i ping (from the fw let's say) 192.168.254.251 everything is okay
When i ping 10.90.111.254 (or 10.74.111.254 or 10.35.111.254) i get destination unreachable

Routes are setup in the firewall btw.

What am i missing?  I performed a packetdump on the fw and i see no icmp packets returning...


Accepted Solutions
Highlighted
Frequent Contributor II

Re: routing issue

Did a little bit of testing this morning.  Following works :

 

vlan 111
name "VLAN111"
untagged 46
ip address 10.35.111.254 255.255.255.0
ip address 10.90.111.254 255.255.255.0
exit


vlan 254
name "VLAN254"
untagged 48
ip address 192.168.254.251 255.255.255.0

 

Then add a gateway :

ip default-gateway 192.168.254.254

 

And finally, enable routing

ip routing

 

DO NOT SET :

primary-vlan 254
management-vlan 254

View solution in original post


All Replies
Highlighted
Frequent Contributor II

Re: routing issue

Did a little bit of testing this morning.  Following works :

 

vlan 111
name "VLAN111"
untagged 46
ip address 10.35.111.254 255.255.255.0
ip address 10.90.111.254 255.255.255.0
exit


vlan 254
name "VLAN254"
untagged 48
ip address 192.168.254.251 255.255.255.0

 

Then add a gateway :

ip default-gateway 192.168.254.254

 

And finally, enable routing

ip routing

 

DO NOT SET :

primary-vlan 254
management-vlan 254

View solution in original post

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: