Wireless Access

Reply
Contributor I

203R series micro USB driver error

Dear community,

 

I'm trying to gain console access to a 203R RAP.

 

When I connect the RAP to my Windows 10 machine using a generic USB 2.0 A to micro USB cord I get an error: Unknown USB Device (Device Descriptor Request Failed). I never see the CP210x USB to UART device showing up in my device management.

 

I've tested 2 RAPs from the 203 series with same results, unfortunately I don't have any other type of AP with micro USB interface at my disposal. I've also tried various drivers with no success.

http://www.silabs.com/products/development-tools/software/usb-to-uart-bridge-vcp-drivers both v6.7.4 versions

https://support.arubanetworks.com/ToolsResources/tabid/76/DMXModule/514/EntryId/7511/Default.aspx

https://community.arubanetworks.com/t5/Controller-Based-WLANs/USB-Console-drivers/ta-p/239331

 

Anybody got any ideas to fix this issue? Do I need a special type of USB cable perhaps? 

 

Edit: tested a second RAP to see if the first one was faulty

MVP Guru

Re: 203R series micro USB driver error

You need to purchase a custom USB cable , see the ordering guide
http://www.arubanetworks.com/assets/og/OG_AP-203R.pdf


Get Outlook for iOS
Thank you

Victor Fabian
Lead Mobility Architect @WEI
AMFX | ACMX | ACDX | ACCX | CWAP | CWDP | CWNA
Contributor I

Re: 203R series micro USB driver error

Thanks for the quick reply, explains everything :-)

 

<edit> I'd like to express my frustration with Aruba's choices regarding console access. I used to be able to trust on a serial port being available. I understand there is a need for ports with a smaller footprint but please, can Aruba make a decision and stick to it! I'm now adding a third console access cable to my inventory where I used to have just one. I'm almost counting on having to add a custom BLE interface in the near future to troubleshoot Aruba products.

Contributor I

Re: 203R series micro USB driver error

Hey Victor,

 

The custom USB cable arrived, unfortunately I'm getting the exact same error: Unknown USB Device (Device Descriptor Request Failed). 

 

Cable label says: AP-CBL-SERU,JY728A 3.3V TTL Serial Cable

 

I'm submitting a ticket for technical support, will update here in case we find a solution.

Aruba

Re: 203R series micro USB driver error

Contributor I

Re: 203R series micro USB driver error

How do I get these installed? I tried to manually update the driver by pointing towards the unzipped folder, but windows found no drivers inside.

 

I discovered today that a slightly newer laptop had no issues getting the USB cable to work on the 203R. It runs a newer version of Windows 10 (version 1703 creators update) compared to mine (Version 1607)

Re: 203R series micro USB driver error

As I've just tried to connect to an AP-303H I have had encountered the same issue.

 

It would be preferable if Aruba stuck to using a standard RJ45 for console connectors. Additionally, now as noted by Udimonk I now have to buy a third cable! These are ridiculously priced for what you get. The proprietary cable i bought to be able to console into the 300 series is very flimsy and not worth the list price of £62!

 

Alexander.

University Information Services
University of Cambridge
Contributor II

Re: 203R series micro USB driver error

I know this is an old thread but wonder if these cables do go bad.

 

We had only one and now getting this same error when I've used the cable in the past without issues. Or a Windows update broke it?

 

Ordering a couple of more and will verify...

°(((=((===°°°(((================================================
Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: