Wireless Access

last person joined: yesterday 

Access network design for branch, remote, outdoor, and campus locations with HPE Aruba Networking access points and mobility controllers.
Expand all | Collapse all

3600 with public IP

This thread has been viewed 1 times
  • 1.  3600 with public IP

    Posted Jun 26, 2014 01:06 PM

    Hey guys,

     

    I have a controller with a public IP and I can ping and access the controller from any computer... I would like to create a NAT like the Pic below..

    If I connect a computer to the controller I have a DHCP IP but no internet.. I'm pretty sure im missing something in the DNS seetings.. Do I have to setup  Vlan 10 from scratch with public IP , netmask, gateway? what about DNS should I setup DNS then import DNS on Vlan 20 and use the gateway from vlan 10?

     

    I'm pretty sure is something simple, can you guys please help me?

     

    Thanks!

     

    Gio.

     

     11.JPG

     

    I have 2 Vlans..

     


    vlan 10
    vlan 20

    vlan-name Default
    vlan-name INSIDE
    vlan INSIDE 20
    vlan-name OUTSIDE
    vlan OUTSIDE 10


    interface gigabitethernet 1/0
    description "GE1/0"
    trusted
    trusted vlan 1-4094
    switchport access vlan 10
    !

    interface gigabitethernet 1/1
    description "GE1/1"
    trusted
    trusted vlan 1-4094
    switchport access vlan 20
    !

    interface gigabitethernet 1/2
    description "GE1/2"
    trusted
    trusted vlan 1-4094
    !

    interface gigabitethernet 1/3
    description "GE1/3"
    trusted
    trusted vlan 1-4094
    !

     

    !

    interface vlan 10
    ip address 66.1.131.5 255.255.255.0
    !

    interface vlan 1
    ip address 172.16.0.254 255.255.255.0
    !

    interface vlan 20
    ip address 192.168.1.2 255.255.255.0
    ip nat inside
    !

    ip default-gateway 66.1.131.1
    uplink disable

     

    ip dhcp excluded-address 192.168.1.0 192.168.1.10
    ip dhcp pool default-pool
    dns-server 172.16.0.254
    lease 0 0 10 0
    no vendor-class-identifier
    network 172.16.0.0 255.255.255.0
    authoritative
    !
    ip dhcp pool INTERNAL
    default-router 192.168.1.1
    dns-server import
    domain-name test
    lease 0 8 0 0
    network 192.168.1.0 255.255.255.0
    authoritative
    !
    service dhcp

     

     


    #3600


  • 2.  RE: 3600 with public IP

    Posted Jun 26, 2014 05:15 PM

    A couple questions...

     

    When you say you can't access the internet, do you mean webpages are not loading on your computer?

     

    What do you mean by setup VLAN 10 from scratch?

     

    Is this computer wired or wireless? If wireless, what sort of role is being assigned? Any ACL's being applied to any of the controller's interfaces?

     

    Can you ping your ISP's gateway from the controller? It may not be pingable, but usually they are.

     

    Can you ping a public IP like Google servers (4.2.2.2 or 8.8.8.8)?

     

    If you can ping those public IP's from the controller, can you ping them from your computer? If not, then you definately have a routing/NAT issue going on. If you can, then probably DNS. Try changing your DHCP DNS servers to a public DNS server provided by your ISP or Google.



  • 3.  RE: 3600 with public IP
    Best Answer

    Posted Jun 26, 2014 05:18 PM

    Your DHCP pool looks like it may be incorrect.   Pleae validate.

     

    ip dhcp pool INTERNAL
    default-router 192.168.1.1    (your controller is 192.168.1.2; if you are doing ip nat inside, you'll want .2 to be your gw)
    dns-server import       (do your clients get DNS servers assigned?   You do not have a DHCP interface, so there is nothing to import)
    domain-name test      (should be valid domain name, not a big deal)
    lease 0 8 0 0
    network 192.168.1.0 255.255.255.0
    authoritative