Wireless Access

Frequent Contributor II

650 ArubaOS upgrade from USB

Hey all,


I'm trying to copy an ArubaOS from USB to System partition for an out-of-the-box 650, and it doesn't seem like I can. Is TFTP the only way that I can place the ArubaOS from my USB to either partition on the controller?


I suppose I should edit this and say that I don't really have much choice and any other method would be laborious, as I have 8 650 controllers that I need to stamp with a config and it would be easier to do it using USB transfer to system, but I'll settle for something else I suppose.


Any help would be appreciated!

Re: 650 ArubaOS upgrade from USB

The software upgrades on our controllers are very simple (a la home router upgrades).  I assume you have remote access?  If so, you can go to Maintenance --> Image Management and just choose the Local File option.  Then, browse to the firmware file (could be sourced from a USB on your laptop :smileyhappy:) and then click OK.



Seth R. Fiermonti
Consulting Systems Engineer - ACCX, ACDX, ACMX
Email: seth@hpe.com
If you found my post helpful, please give kudos
Frequent Contributor II

Re: 650 ArubaOS upgrade from USB

@SethFiermonti wrote:

The software upgrades on our controllers are very simple (a la home router upgrades).  I assume you have remote access?  If so, you can go to Maintenance --> Image Management and just choose the Local File option.  Then, browse to the firmware file (could be sourced from a USB on your laptop :smileyhappy:) and then click OK.



So I supposed that I should've explained myself better, and I apologize. Here's the real issue.


I work as a contractor for a very large retail establishment, and we're rolling out Aruba to 6 smallish stores (~8,000 - ~10,000 sq. ft.), which means uprooting the existing, crappy Cisco implementation and putting in 650 controllers and a handful of IAP105s. I have a stack of Aruba boxes with 650s in them, and each one I'm having to update the firmware on (we're still running, I know, don't ask), which is different than the out-of-the-box that comes with the controller. So, I have to touch each controller and manually assign it an IP address (a temp one) via CLI, get the WebGUI running, and then push the new firmware; what I wanted to do was do it directly from CLI using the copy usb: <filename> system: partition 0 command, but it doesn't work that way. The controller ends up asking for a usb filepath and, no matter what I put in, it can't find the file specified (but in the WebGUI, it works just fine). So, I give it a basic config and push it through the WebGUI and it's fine, but it's an extra step and it's a hastle considering I have to have this finished by the end of tomorrow (with 3 other projects I'm working on, but enough of my excuses :P).


What I just explained above is actually the easy part; the next part involves having to copy a running-config from another controller, edit it in Notepad++, upload it to flash, over-ride default.cfg, DON'T save config, and then reboot the controller. In the CLI, I run into the same issue where I can't push something from the usb to the system (no file found, blah blah), and from the WebGUI, I can push from the controller to the USB in terms of TFTP from controller to USB, but I can't do it towards the controller, and more importantly, I don't have the option to push a running config to the controller. It seems like I should be able to push a config and have it boot to it straight away, but it looks like I might have to figure out a way to have the controller use the Restore config option instead, but I'm still renaming a file.


Hopefully my meaning has come through. I'll be in my lab all day working on this, so if anyone has any secrets for mass-configuring controllers, I humbly and graciously accept any help one may render.




Frequent Contributor II

Re: 650 ArubaOS upgrade from USB

Ok, so after much gnashing of teeth and yelling [Word Filter Evasion] a lot (and calling the TAC), I've figured out how to churn out multiple ArubaOS upgrades from cpboot (before the normal boot process).


Pre-setup: This method has only been tested with the 650 series controller (I'm going to try with a 3400 and will post back with what I find out), and as such, will only apply to this controller (for now). This method is intended to facilitate upgrading a lot of controllers (or just one, if that's all you need) very quickly to the latest (or any prod version your establishment is running) version of ArubaOS, without having to go through the normal process of booting the controller up, assigning it as master / local, etc. etc; this essentially skips the WebGUI method and gets straight to it.


Pre-setup includes an L2 / L3 switch (something that you can use with VLANS or not). Plug in your laptop or desktop to the switch, and plug in an eth cable to port 1 on the 650 controller. Just to clarify, there are 4 ports on the front labeled as such (0 | 1 | 2 | 3), so plug it into the second port, port 1. This will be known as xls_gmac1, which is important later.


Now, with PuTTy ready (or some other serial / console connection, like screen \dev\tty.usbserial 9600 for Mac, assuming correct driver installation), power on your controller and hit Enter to interrupt the normal boot process, which will take you to a cpboot> prompt. This is where it all happens.


On your laptop, you need to run a TFTP server. I use Solarwinds, but there are a million nice and neat applications you can run, so pick your favorite. Move the ArubaOS version you want to use into your TFTP server root folder, and you're set.


Now, onto the actual task at hand. You have to statically assign an IP on your laptop first, as your laptop will serve as your TFTP server, so when you initiate the upgrade command on the controller, it'll look for the TFTP IP address. I'll use examples for the next part, which are the actual commands you'll use.


In cpboot>, type the following (1/2):


setenv ipaddr (the controller's temp IP address. You can change this later)

setenv netmask

setenv gatewayip (this doesn't matter really, as you don't need an internet connection in order to do this, but it's still good to have)

setenv serverip (this is the address of the TFTP server, so in this case your laptop, but if you have a TFTP server on your network, then use that IP)


That's the first part of the command sequence. The next part will seem strange, so I'll explain it afterwards.


In cpboot>, type the following (2/2):


setenv ethact xls_gmac1

setenv ethprime xls_gmac1


Apparently the xls_gmac1 applied to a port interface on the controller, and ethact (ethernet activity) and ethprime (primary associative ethernet port to use on the controller) are used to designate which port on the controller should be used to facilitate what we're about to do. xls_gmac0 (in theory) should associate with port 0 on the controller, and xls_gmac2 with port 2 (so on and so forth), but I haven't tested it with any of the other ports, so just use xls_gmac1 and you should be ok. Once you've done this, you can execute the final command:


upgrade 0 ArubaOS_6xx_6.1.3.7_37112 (where 0 = which partition will be upgraded, 0 or 1, where 0 is normally the default partition, so it's best to upgrade that one, and whatever the filename of the ArubaOS image you have afterwards). It should then take its sweet time in upgrading, in which case you'll go back to the cpboot> menu. Type save, and then reset. It'll boot, and during the boot up phase, you should see your Aruba version info listed.


As I said earlier, I haven't tested this with other controllers yet (the 3000, 6000, and 7000 series), but I have everything but the 7000 available and will post a process for those bigger controllers.


If anyone has any problems or questions, please post them here and I'll help you out.




New Contributor

Re: 650 ArubaOS upgrade from USB

Exactly what We needed for out 650.  Much thanks!

New Contributor

Re: 650 ArubaOS upgrade from USB

Hello - 

I have tried this with no success. I cannot seem to establish basic ip connectivity from the switch to the tftp server.



Search Airheads
Showing results for 
Search instead for 
Did you mean: