Wireless Access

Reply
Frequent Contributor I

AOS 8 license allocation issue

Ok, I've been working with TAC on this but after trying multiple things (removing expired licenses on MM, restarting license manager) and upgrading from 8.2.2.4 to 8.3.0.6 I'm still having this issue. The issue is I am showing more licenses consumed than APs active and in the database. I'm curious to see if anyone else has seen this. 

 

I think TAC thought I might be hitting bug 191480 that was fixed in 8.3.0.6. They also implied this issue was with the mesh APs. After upgrading to 8.3.0.6 the issue remains though.

 

Environment:

- Two MMs in Active / Standby

- Two 7205s MDs in a L2 cluster

- Version currently is 8.3.0.6

- Total APs in database: 127 (same total on MM and MDs)

- Total APs active on controller 1 (including standbys): 95

- Total APs active on controller 2 (including standbys): 106

 

From the output below, you will see that the MM is reporting a total of 161 AP licenses in use even though there are only a total of 127 APs registered. This is a test environment and these controllers only have 150 licenses. Is this normal?

 

License-usage output from MM:

 

(mmisbaruba1) *[mynode] #show license-usage 

License Clients License Usage for pool /
----------------------------------------
Hostname         IP Address    Mac addr           AP    PEF   RF Protect   ACR   WebCC   MM    MC-VA-RW   MC-VA-EG   MC-VA-IL   MC-VA-JP   MC-VA-US   VIA  Last update (secs. ago)
--------         ----------    --------           ----  ----  -----------  ----  ------  ----  ---------  ---------  ---------  ---------  ---------  ---  -----------------------
mmisbaruba1      10.80.10.2    00:50:56:bb:4c:76  0     0     0            0     0       0     0          0          0          0          0          0    7
mcevsaruba-test  172.18.242.3  00:0b:86:b7:4e:af  93    93    93           0     0       94    0          0          0          0          0          0    3
mcisbaruba-test  172.18.242.2  00:0b:86:b7:49:17  68    58    58           0     0       69    0          0          0          0          0          0    13

TOTAL                                             161   151   151          0     0       163   0          0          0          0          0          0    

License aggregate output:

Aggregate License Table for pool /
----------------------------------
Hostname     IP Address  Mac addr           AP   PEF  RF Protect  ACR  WebCC  MM    MC-VA-RW  MC-VA-EG  MC-VA-IL  MC-VA-JP  MC-VA-US  VIA  
--------     ----------  --------           ---  ---  ----------  ---  -----  --    --------  --------  --------  --------  --------  ---  
From Server  10.80.10.2  00:50:56:bb:4c:76  150  150  150         0    0      1000  0         0         0         0         0         0    

License server-table output:

License Server Table for pool / profile root
--------------------------------------------
Service Type                                        PoolSize  ExpiredLic  ActualPoolSize  UsedLic  RemainingLic  Warnings  FeatureBit
------------                                        --------  ----------  --------------  -------  ------------  --------  ----------
Access Points                                       150       0           150             161      0             None      enabled
Next Generation Policy Enforcement Firewall Module  150       0           150             151      0             None      enabled
RF Protect                                          150       0           150             151      0             None      enabled
Advanced Cryptography                               0         0           0               0        0             None      enabled
WebCC                                               0         0           0               0        0             None      enabled
MM-VA                                               1000      0           1000            163      837           None      enabled
MC-VA-RW                                            0         0           0               0        0             None      enabled
MC-VA-EG                                            0         0           0               0        0             None      enabled
MC-VA-IL                                            0         0           0               0        0             None      enabled
MC-VA-JP                                            0         0           0               0        0             None      enabled
MC-VA-US                                            0         0           0               0        0             None      enabled
VIA                                                 0         0           0               0        0             None      enabled

 

Re: AOS 8 license allocation issue

Are there any unprovisioned APs? Not sure why that would be happening, nor what mesh would have to do with it. Any switches doing dynamic segmentation?

 


Jerrod Howard
Distinguished Technologist, TME
Frequent Contributor I

Re: AOS 8 license allocation issue

Hi Jerrod,

 

There are not any unprovisioned APs and we do not have any Aruba switches in the mix.

 

I only mentioned mesh because that is what TAC mentioned. They found a possible bug with mesh APs and licensing. Not sure if that is my actual issue though since upgrading to 8.3.0.6 that supposedly fixed that bug did not change anything.

 

Still working with TAC. I'll update once they find the issue.

Frequent Contributor I

Re: AOS 8 license allocation issue

Final follow-up on this. Looks like it was a bug. Fix is in 8.2.2.5 and 8.3.0.7 (or so I'm told). I downgraded to 8.2.2.5 and it resolved the issue.

 

release_notes.JPGMesh license bug

Highlighted
New Contributor

Re: AOS 8 license allocation issue

Hi,

 

Did you deploy your MM in L3 Redundency? did you apply all the linceses on the Primary? did you have to apply any licenses to the standby MM? I am assuming you would have to apply the base MM-VA-X Mob Mstr license at least

Frequent Contributor I

Re: AOS 8 license allocation issue

Yeah, all of the licensing was there. The AP licenses just were not being allocated correctly. I had way more licenses allocated than actual APs. Issue is fixed now in 8.2.2.5.

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: