Wireless Access

Reply
Highlighted
Aruba Employee

AP connected to VMC - wireless clients not getting IP address

Hi, 

 

I've been struggling with something that probably shouldn't be this difficult and any help would be appreciated! I'm currently using a physical controller as my DHCP server and gateway. All required VLANs have been configured on my controller and switch. All connected devices are in the correct VLAN and have the associated IP address.

 

I have my gateway connected to my home router and my switch and my ESXi server and AP also connected to my switch. I'm able to get an internet connection via the switch.

 

To break it down:

1. I have the following VLANS and what's connected to them

  1. VLAN 10 - Management (Mobilty Master)
  2. VLAN 20 - Controllers (Virtual Mobilty Controller)
  3. VLAN 30 - APs (AP 303P)
  4. VLAN 40 - Users (SSID on VLAN 40)

2. At first, my AP couldn't connect to my VMC becuase of certificate issues so I had to disable CPSEC - APs can now connect

3. Wireless clients on VLAN 40 (connected to my AP) are not able to recieve an IP address from the DHCP server.

4. I can ping VLAN 40 from my VMC 

 

I've attached an image of my ESXi vSwitch.

Screenshot 2019-11-06 at 17.32.24.png

 

Highlighted

Re: AP connected to VMC - wireless clients not getting IP address

Hi Doja,

 

Do you have configured promiscuous mode for the port groups and VLAN's on the ESXi? 


visit our Youtube Channel:
https://www.youtube.com/channel/UCFJCnuXFGfEbwEzfcgU_ERQ/featured
Please visit my personal blog as well:
https://www.flomain.de
Highlighted
MVP Guru

Re: AP connected to VMC - wireless clients not getting IP address

In your screenshot, you have not connected VLAN40 to your VMC1 and VMC2. And indeed verify the security settings on the port group and vSwitch.

--
If you have urgent issues, please contact your Aruba partner or Aruba TAC (click for contact details).
Highlighted
Aruba Employee

Re: AP connected to VMC - wireless clients not getting IP address

Turns out it was a vSwitch issue! I had to trunk it using vlan ID 4095. Everything works as it should minus not being able to connect up more than one AP - but that's a problem for another day.

 

Thanks!

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: