Wireless Access

Reply
New Contributor

APIN0205 (FACTORY RESET AND INTERRUPT AUTOBOOT) PROBLEM

I have four aruba APIN0205 one of them i can't reset it to factory defualt as i don't know the old configuration first i tried the back button but with no result so i decided to reset using console cable but also i can't as i can't stop the autoboot process as shown below :

 

APBoot 1.5.3.14 (build 45815)
Built: 2014-09-05 at 11:23:04

Model: AP-20x
CPU: BCM53011/15, revision A0
I2C: ready
SKU: 2
OTP: 0xeca01028
Clock:
CPU: 800 MHz
DDR: 533 MHz
AXI: 400 MHz
APB: 200 MHz
PER: 400 MHz
DRAM: 128 MB
POST1: memory passed
SF: Detected MX25L25635E with page size 4 kB, total 32 MB
Flash: 32 MB
PCIe0: RC, link up
dev fn venID devID class rev MBAR0 MBAR1 MBAR2 MBAR3
00 00 14e4 4360 00002 03 08000004 00000000 00000000 00000000
PCIe1: RC, link up
dev fn venID devID class rev MBAR0 MBAR1 MBAR2 MBAR3
00 00 14e4 4360 00002 03 40000004 00000000 00000000 00000000
Power: POE
Net: eth0
Radio: bcm43460#0, bcm43460#1

Hit <Enter> to stop autoboot: 0
Booting OS partition 0
Checking image @ 0x1e100000
Invalid image format version: 0xffffffff
Checking image @ 0x1ef00000
Copying image from 0x1ef00000

Image is signed; verifying checksum... passed
Signer Cert OK
Policy Cert OK
RSA signature verified.
Uncompressing... done
[ 0.000000]
[ 0.000000] Aruba Networks
[ 0.000000] ArubaOS Version 6.4.2.0-4.1.1.0 (build 45444 / label #45444)
[ 0.000000] Built by p4build@cartman on 2014-08-15 at 21:51:21 PDT (gcc version 4.7.2)
[ 0.000000]
[ 0.000000] Flash variant: variant0
[ 0.000000] Memory: 128MB = 128MB total
[ 0.000000] Memory: 117892k/117892k available, 13180k reserved, 0K highmem
[ 0.052000] hw perfevents: enabled with ARMv7 Cortex-A9 PMU driver, 7 counters available
[ 5.148000] PMU: registered new PMU device of type 0
[ 5.654000] pci 0001:00:00.0: BAR 8: assigned [mem 0x08000000-0x080fffff]
[ 5.656000] pci 0001:01:00.0: BAR 0: assigned [mem 0x08000000-0x08007fff 64bit]
[ 5.658000] pci 0001:01:00.0: BAR 0: set to [mem 0x08000000-0x08007fff 64bit] (PCI address [0x8000000-0x8007fff]
[ 6.160000] pci 0002:00:00.0: BAR 8: assigned [mem 0x40000000-0x400fffff]
[ 6.162000] pci 0002:02:00.0: BAR 0: assigned [mem 0x40000000-0x40007fff 64bit]
[ 6.164000] pci 0002:02:00.0: BAR 0: set to [mem 0x40000000-0x40007fff 64bit] (PCI address [0x40000000-0x40007fff]
[ 6.510000] i2c-springbank: using remapped base c8904060
[ 6.512000] mpcore_wdt mpcore_wdt: enabling watchdog.
[ 6.516000] qspi_iproc qspi_iproc.1: 1-lane output, 3-byte address
[ 6.518000] m25p80 spi1.0: mx25l25635e (32768 Kbytes)
[ 6.520000] Creating 1 MTD partitions on "spi1.0":
[ 6.522000] 0x000000000000-0x000002000000 : "qspi"
[ 6.524000]
[ 6.524000] Starting Kernel SHA1 KAT ...Completed Kernel SHA1 KAT
[ 6.528000] Starting Kernel HMAC-SHA1 KAT ...Completed Kernel HMAC-SHA1 KAT
[ 6.542000] Starting Kernel DES KAT ...Completed Kernel DES KAT
[ 6.546000] Starting Kernel AES KAT ...Completed Kernel AES KAT
[ 6.548000]
Domain Name: instant.arubanetworks.com
No panic info available
Check backup ENV.
Cfg len is 2.5k
Loading configuration file of length 2.5k...
wifi uplink not present...
extended ssid config detected...
Terminal access enabled...
factory default SSID detected...
extended ssid activate due to no valid ssid ...
[ 12.268000] ADDRCONF(NETDEV_UP): bond0: link is not ready
Ethernet uplink not active yet
Ethernet uplink not active yet
Ethernet uplink not active yet
Ethernet uplink not active yet
Ethernet uplink not active yet
Ethernet uplink not active yet
Ethernet uplink not active yet
Ethernet uplink not active yet
Ethernet uplink not active yet
Ethernet uplink not active yet
Mesh is DISABLED on this device.
Disabling wpa_supplicant for this paltform
[ 42.718000] AP xml model 81, num_radios 2 (jiffies 21359)
[ 42.720000] init_asap_mod: installation:0
[ 42.722000] radio 0: band 1 ant 0 max_ssid 16
[ 42.724000] radio 1: band 0 ant 0 max_ssid 16
[ 42.726000] election init: rand=1c HZ=500
[ 42.728000] IAP client match init
notify asap_mod 3g no present...
Starting watchdog process...
(none)

Compressing all files in the /etc/httpd directory...
Done.
Starting Webserver
bind: Transport endpoint is not connected
bind: Transport endpoint is not connected
bind: Transport endpoint is not connected
Launching NTP Client on pool.ntp.org
[ 48.306000] wifi0: AP type AP-205, radio 0, max_bssids 16
[ 48.350000] wifi1: AP type AP-205, radio 1, max_bssids 16
shutting down watchdog process (nanny will restart it)...
Completed SW FIPS KAT test

<<<<< Welcome to the Access Point >>>>>

User: [ 78.244000] process `snmpd_sap' is using obsolete setsockopt SO_BSDCOMPAT
[ 90.432000] Picked up default IP a9fedaa9, rand daa9!
[ 96.554000] Default IP is ready!
[ 99.848000] ip_time_handler: Got ip and packets on bond0 Started master election 1-0, rand 16
[ 115.904000] i am master now
[ 115.906000] (00:01:58) !!! Init ---> Master
[ 115.908000] asap_send_elected_master: sent successfully

 

Then it stops and reboot.

 

Sending SIGKILL to all processes.
Please stand by while rebooting the system.
[ 409.642000] Restarting system.

 

 

However, i already adjust the serial communication settings to be (9600 8 none 1 none) as mentioned in manual and other checked question in this community :

By the way below is the led status it might clarify the condition: 

 

pwoer: green

eth: light orange

2.4ghz: orange

5ghz: orange

 

MVP
MVP

Re: APIN0205 (FACTORY RESET AND INTERRUPT AUTOBOOT) PROBLEM

1. press the reset pin and hold it

2. power up the ap

3. wait atleast 10sec before release the reset pin.

 

Or interupt the bootprocess at the begin "Hit <Enter> to stop autoboot: 0". And type;

- purgenv

- save (not sure if you have to save)

- purgenv

- boot

 

And besure the mac-adress is not registerd in activate or cloudcentral, then it would autmatic pickup his config from the internet while booting ;).

 

 

 

Kind Regards Marcel Koedijk
HPE ASE Flexnetwork | ACMP | ACCP | Ekahau ECSE Design - Was this post usefull, Kudos are welcome.
New Contributor

Re: APIN0205 (FACTORY RESET AND INTERRUPT AUTOBOOT) PROBLEM

Thanks,

but i already tried the steps of reseting with no result and i'm not able to interruprt the autoboot process.

Re: APIN0205 (FACTORY RESET AND INTERRUPT AUTOBOOT) PROBLEM

The LED you mention, are the LEDs always solid at that color combination, or do they come on after it's booted?

 

You can watch the serial console while booting and it should indicate it's resetting. if you cannot get the serial console to respond and the reset button doesn't work, assuming you purchased them you can ask for a TAC case to replace. Otherwise, might be a bad AP

 


Jerrod Howard
Distinguished Technologist, TME
MVP
MVP

Re: APIN0205 (FACTORY RESET AND INTERRUPT AUTOBOOT) PROBLEM

Agree with Jerrod. If reset in both ways didnt work you have possible a bad AP. Please create a TAC case for this. If your are the first owner you possible have lifetime warranty.

 

https://www.arubanetworks.com/assets/support/networking-warranty-summary.pdf

 

"For products purchased after December 1, 2015, the warranty extends only for as long as the original end user owns the
product and is limited to five (5) years from the end of sale date"

Kind Regards Marcel Koedijk
HPE ASE Flexnetwork | ACMP | ACCP | Ekahau ECSE Design - Was this post usefull, Kudos are welcome.
New Contributor

Re: APIN0205 (FACTORY RESET AND INTERRUPT AUTOBOOT) PROBLEM

no first only the power led is blinking green then eth get solid light orange and both 2.4ghz and 5ghz solid orange.

 

below is what i get when i push the reset button:

APBoot 1.5.3.14 (build 45815)
Built: 2014-09-05 at 11:23:04

Model: AP-20x
CPU: BCM53011/15, revision A0
I2C: ready
SKU: 2
OTP: 0xeca01028
Clock:
CPU: 800 MHz
DDR: 533 MHz
AXI: 400 MHz
APB: 200 MHz
PER: 400 MHz
DRAM: 128 MB
POST1: memory passed
SF: Detected MX25L25635E with page size 4 kB, total 32 MB
Flash: 32 MB
PCIe0: RC, link up
dev fn venID devID class rev MBAR0 MBAR1 MBAR2 MBAR3
00 00 14e4 4360 00002 03 08000004 00000000 00000000 00000000
PCIe1: RC, link up
dev fn venID devID class rev MBAR0 MBAR1 MBAR2 MBAR3
00 00 14e4 4360 00002 03 40000004 00000000 00000000 00000000
Power: POE
Net: eth0
Radio: bcm43460#0, bcm43460#1
**** Configuration Reset Requested by User ****
Clearing state... Checking OS image and flags
Invalid image format version: 0xffffffff
Continuing with OS clear
Erasing flash sector @ 0x1e100000....done
Erased 1 sectors
Erasing flash sector @ 0x1ff80000....done
Erased 1 sectors

Erasing flash sector @ 0x1ff90000....done
Erased 1 sectors

Erasing flash sector @ 0x1ffb0000....done
Erased 1 sectors

Erasing flash sector @ 0x1ffc0000....done
Erased 1 sectors

Erasing flash sector @ 0x1ffd0000....done
Erased 1 sectors

done
Purging environment... preserving os_partition (0)
Erasing flash...Writing to flash..................done
Erasing flash...Writing to flash..................done
done

Hit <Enter> to stop autoboot: 0
Booting OS partition 0
Checking image @ 0x1e100000
Invalid image format version: 0xffffffff
Checking image @ 0x1ef00000
Copying image from 0x1ef00000

Image is signed; verifying checksum... passed
Signer Cert OK
Policy Cert OK
RSA signature verified.
Uncompressing... done
[ 0.000000]
[ 0.000000] Aruba Networks
[ 0.000000] ArubaOS Version 6.4.2.0-4.1.1.0 (build 45444 / label #45444)
[ 0.000000] Built by p4build@cartman on 2014-08-15 at 21:51:21 PDT (gcc version 4.7.2)
[ 0.000000]
[ 0.000000] Flash variant: variant0
[ 0.000000] Memory: 128MB = 128MB total
[ 0.000000] Memory: 117892k/117892k available, 13180k reserved, 0K highmem
[ 0.052000] hw perfevents: enabled with ARMv7 Cortex-A9 PMU driver, 7 counters available
[ 5.192000] PMU: registered new PMU device of type 0
[ 5.700000] pci 0001:00:00.0: BAR 8: assigned [mem 0x08000000-0x080fffff]
[ 5.702000] pci 0001:01:00.0: BAR 0: assigned [mem 0x08000000-0x08007fff 64bit]
[ 5.704000] pci 0001:01:00.0: BAR 0: set to [mem 0x08000000-0x08007fff 64bit] (PCI address [0x8000000-0x8007fff]
[ 6.208000] pci 0002:00:00.0: BAR 8: assigned [mem 0x40000000-0x400fffff]
[ 6.210000] pci 0002:02:00.0: BAR 0: assigned [mem 0x40000000-0x40007fff 64bit]
[ 6.212000] pci 0002:02:00.0: BAR 0: set to [mem 0x40000000-0x40007fff 64bit] (PCI address [0x40000000-0x40007fff]
[ 6.558000] i2c-springbank: using remapped base c8904060
[ 6.562000] mpcore_wdt mpcore_wdt: enabling watchdog.
[ 6.566000] qspi_iproc qspi_iproc.1: 1-lane output, 3-byte address
[ 6.568000] m25p80 spi1.0: mx25l25635e (32768 Kbytes)
[ 6.570000] Creating 1 MTD partitions on "spi1.0":
[ 6.572000] 0x000000000000-0x000002000000 : "qspi"
[ 6.576000]
[ 6.576000] Starting Kernel SHA1 KAT ...Completed Kernel SHA1 KAT
[ 6.580000] Starting Kernel HMAC-SHA1 KAT ...Completed Kernel HMAC-SHA1 KAT
[ 6.594000] Starting Kernel DES KAT ...Completed Kernel DES KAT
[ 6.598000] Starting Kernel AES KAT ...Completed Kernel AES KAT
[ 6.600000]
Domain Name: instant.arubanetworks.com
No panic info available
apfcutil: sector CACHE: Cache uninitialized
apfcutil: sector RAP: Cache uninitialized
apfcutil: sector FAT: Cache uninitialized
apfcutil: sector SCRATCH: Cache uninitialized
Check backup ENV.
apfcutil: sector MESH Prov: Cache uninitialized
Cfg len is 0
Configuration file is empty, turning on default services...
extended ssid activate due to no AP config ...
[ 14.504000] ADDRCONF(NETDEV_UP): bond0: link is not ready
Ethernet uplink not active yet
Ethernet uplink not active yet
Ethernet uplink not active yet
Ethernet uplink not active yet
Ethernet uplink not active yet
Ethernet uplink not active yet
Ethernet uplink not active yet
Ethernet uplink not active yet
Ethernet uplink not active yet
Ethernet uplink not active yet
Mesh is DISABLED on this device.
Disabling wpa_supplicant for this paltform
[ 44.954000] AP xml model 81, num_radios 2 (jiffies 22477)
[ 44.956000] init_asap_mod: installation:0
[ 44.958000] radio 0: band 1 ant 0 max_ssid 16
[ 44.960000] radio 1: band 0 ant 0 max_ssid 16
[ 44.962000] election init: rand=b HZ=500
[ 44.964000] IAP client match init
notify asap_mod 3g no present...
Starting watchdog process...
(none)

Compressing all files in the /etc/httpd directory...
Done.
Starting Webserver
bind: Transport endpoint is not connected
bind: Transport endpoint is not connected
bind: Transport endpoint is not connected
Launching NTP Client on pool.ntp.org
[ 50.540000] wifi0: AP type AP-205, radio 0, max_bssids 16
[ 50.586000] wifi1: AP type AP-205, radio 1, max_bssids 16
shutting down watchdog process (nanny will restart it)...
Completed SW FIPS KAT test

<<<<< Welcome to the Access Point >>>>>

User: [ 81.342000] process `snmpd_sap' is using obsolete setsockopt SO_BSDCOMPAT
[ 93.532000] Picked up default IP a9fedaa9, rand daa9!
[ 99.654000] Default IP is ready!
[ 103.074000] ip_time_handler: Got ip and packets on bond0 Started master election 1-0, rand 26
[ 129.152000] i am master now
[ 129.154000] (00:02:11) !!! Init ---> Master
[ 129.156000] asap_send_elected_master: sent successfully

Sending SIGKILL to all processes.
Please stand by while rebooting the system.
[ 412.456000] Restarting system.

 

 

Highlighted

Re: APIN0205 (FACTORY RESET AND INTERRUPT AUTOBOOT) PROBLEM

And you said no matter what you try, you cannot get to the console port to interrupt APBOOT? If that is the case, then I would say this AP is not recoverable. There's an odd image stating "Invalid image format version: 0xffffffff". Hard to know how that got there (if a corrupted image was loaded/forced, or if it got corrupted because the AP is failing. But without access to the console port, forcing a wipe/format and reload of the AP is not possible.

 


Jerrod Howard
Distinguished Technologist, TME
Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: