Wireless Access

Frequent Contributor I

Apple iOS 7.1.1 not communicating


Just wanted to give everyone a useful info when it comes to apple iOS 7.1.1, we faced an issue with the devices running that version if they are getting an IP from DHCP but there is not DNS set they won't initiate any traffic to any other subner except the subnet they reside on, how did we notice this us we had a customer having ipads and after connecting to the wireless he is not able to ping or access any other subnet at all, pinging the same subnet works fine, and if we ping TO the device from any other subnet it works fine as well, so I ahve tried manual IP with no DNS same result and at the end I said let me put any DNS and suddenly everything started to work perfectly fine, it doesn't matter if the DNS ip is valid or reachable it just need to be there.

The customer didn't put any DNS entry because he doesn't want Internet access or browsing for those devices.

Not sure if this is a know thing with the DNS and not sure if it is a bug in iOS 7.1.1 or some kind of a "security" enhancement from Apple like they always do.... -_-

Hope this helps, and we tested with different wireless vendors same result coz the customer was thinking it is an Aruba issue.

Search Airheads
Showing results for 
Search instead for 
Did you mean: