Wireless Access

Reply
Highlighted
Guru Elite

Re: Cisco 3750E Stack & Aruba 3400 Controller -- Port Channel Issue

Please open a support case so that they can look into the details of this.

 


*Answers and views expressed by me on this forum are my own and not necessarily the position of Aruba Networks or Hewlett Packard Enterprise.*
ArubaOS 8.5 User Guide
InstantOS 8.5 User Guide
Airheads Knowledgebase
Airheads Learning Videos
Remote Access Point Solution Guide
ArubaOS Consolidated Release Notes
ArubaOS 8 ViA VPN Solution Guide
Highlighted
Aruba Employee

Re: Cisco 3750E Stack & Aruba 3400 Controller -- Port Channel Issue

Looks like you changed port-channel interfaces.  If you're using int port-channel 7, but gig 1/1 in lacp group 7.

 

interface gigabitethernet  1/1        

 

lacp group 7 mode passive

 

interface port-channel 7        

trusted        

trusted vlan 1-4094        

switchport mode trunk        

switchport access vlan 70        

switchport trunk native vlan 70

 

Highlighted
Occasional Contributor II

Re: Cisco 3750E Stack & Aruba 3400 Controller -- Port Channel Issue

Yes I was pulling straws out of the hat.

 

One issue was that one of the interfaces was set to access instead of trunk on the aruba side.  The other issue is when configuring a cisco port channel and putting the native vlan in there as I was just trying to put it in the interface side.  I can ping the gateway.  Now adding additional ports and they don't seem to be coming up correctly.

 

Aruba Side:

 

 

interface gigabitethernet  1/0

        description "GE1/0"

        trusted

        trusted vlan 1-4094

        speed 1000

        duplex full

        switchport mode trunk

        switchport trunk native vlan 70

        switchport trunk allowed vlan 1-4094

        no spanning-tree

        lacp port-priority 1

        lacp timeout short

        lacp group 7 mode active

!

 

interface gigabitethernet  1/1

        description "GE1/1"

        trusted

        trusted vlan 1-4094

        speed 1000

        duplex full

        switchport mode trunk

        switchport trunk native vlan 70

        lacp port-priority 1

        lacp timeout short

        lacp group 7 mode active

!

 

interface gigabitethernet  1/2

        description "GE1/2"

        trusted

        trusted vlan 1-4094

        speed 1000

        duplex full

        switchport mode trunk

        switchport trunk native vlan 70

        lacp port-priority 1

        lacp timeout short

        lacp group 7 mode active

!

 

interface gigabitethernet  1/3

        description "GE1/3"

        trusted

        trusted vlan 1-4094

        speed 1000

        duplex full

        switchport mode trunk

        switchport trunk native vlan 70

        lacp port-priority 1

        lacp timeout short

        lacp group 7 mode active

!

 

interface port-channel 7

                trusted

        trusted vlan 1-4094

        switchport mode trunk

        switchport access vlan 70

        switchport trunk native vlan 70

        no spanning-tree

!

 

Cisco Side:

 

interface Port-channel7

 switchport trunk encapsulation dot1q

 switchport trunk native vlan 70

 switchport trunk allowed vlan 1,70,211

 switchport mode trunk

 switchport nonegotiate

end

 

interface GigabitEthernet1/0/39

 description Wireless Controller Port 1

 switchport trunk encapsulation dot1q

 switchport trunk native vlan 70

 switchport trunk allowed vlan 1,70,211

 switchport mode trunk

 switchport nonegotiate

 speed 1000

 duplex full

 channel-group 7 mode active

end

Highlighted
Aruba Employee

Re: Cisco 3750E Stack & Aruba 3400 Controller -- Port Channel Issue

I'm at a bit of a loss on this one.  Did you ever get it working?

 

The only thing I find odd is that "channel-protocol lacp" isn't showing up in your Cisco interface config.

Highlighted
Occasional Contributor II

Re: Cisco 3750E Stack & Aruba 3400 Controller -- Port Channel Issue

I have it all working now. 

Guru Elite

Re: Cisco 3750E Stack & Aruba 3400 Controller -- Port Channel Issue

Please let us know the solution and mark it solved, if it is not too much trouble.

 


*Answers and views expressed by me on this forum are my own and not necessarily the position of Aruba Networks or Hewlett Packard Enterprise.*
ArubaOS 8.5 User Guide
InstantOS 8.5 User Guide
Airheads Knowledgebase
Airheads Learning Videos
Remote Access Point Solution Guide
ArubaOS Consolidated Release Notes
ArubaOS 8 ViA VPN Solution Guide
Highlighted
Occasional Contributor II

Re: Cisco 3750E Stack & Aruba 3400 Controller -- Port Channel Issue

The above configuration will work.  Items to make sure:

 

Aruba side:

 

  Make sure you set your network interfaces to trunking before adding them into the port channel.  Once you do it won't let you change it until you take it out of the group.  Also the port group does not take precedence over what is configured on the interface.  So configure everything to work on each interface and then add to a port channel.

 

Cisco side:

 

Make sure you know how the port channel was orginally setup as this will affect how you can configure the port channel and then what takes precedence over needing to configure the port channel and interface or just port channel.

View solution in original post

Highlighted
Frequent Contributor II

Re: Cisco 3750E Stack & Aruba 3400 Controller -- Port Channel Issue

The following works for me going to a set of Cisco switches. I use LACP for each pair of ports servicing different vlans. I've simplified it and stripped off the other vlans but you get idea:

 

 

vlan 2 "corp"
vlan 3 "guest"

 

interface gigabitethernet  1/0
        description "uplink to sw1 port 13 pc1"
        trusted
        trusted vlan 2
        switchport mode trunk
        switchport trunk allowed vlan 2
        no spanning-tree
        lacp port-priority 32768
        lacp group 0 mode active
!

interface gigabitethernet  1/1
        description "uplink to sw2 port 13 pc1"
        trusted
        trusted vlan 2
        switchport mode trunk
        switchport trunk allowed vlan 2
        no spanning-tree
        lacp port-priority 32768
        lacp group 0 mode active
!

interface gigabitethernet  1/2
        description "uplink to sw1 port 14 pc2"
        trusted
        trusted vlan 3
        switchport mode trunk
        switchport trunk allowed vlan 3
        no spanning-tree
        lacp port-priority 32768
        lacp group 1 mode active
!

interface gigabitethernet  1/3
        description "uplink to sw2 port 14 pc2"
        trusted
        trusted vlan 3
        switchport mode trunk
        switchport trunk allowed vlan 3
        no spanning-tree
        lacp port-priority 32768
        lacp group 1 mode active
!

interface port-channel 0
        trusted
        trusted vlan 2
        switchport mode trunk
        switchport trunk allowed vlan 2
!

interface port-channel 1
        trusted
        trusted vlan 3
        switchport mode trunk
        switchport trunk allowed vlan 3
!

interface vlan 1
        shutdown
!

interface vlan 2
        ip address 1.2.3.4 255.255.254.0
        ip helper-address 1.2.3.10
!

interface vlan 3
        ip address 2.3.4.5 255.255.255.0
!

!

master-redundancy
  master-vrrp 2
  peer-ip-address 1.2.3.5 ipsec blah
!
vrrp 2
  priority 110
  authentication password
  ip address 1.2.3.2
  description "preferred-master"
  vlan 102
  preempt
  tracking master-up-time 30 add 20
  no shutdown
!
ip default-gateway 1.2.3.1

 

Highlighted
New Contributor

Re: Cisco 3750E Stack & Aruba 3400 Controller -- Port Channel Issue

I had a simular issue a couple of months ago and what I ended up doing was putting the switch ports on speed auto and duplex auto. The ports came up after those changes. I hope that this helps.

 

Thanks,

 

Winston Jordan

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: