Wireless Access

Reply
Highlighted
Occasional Contributor II

Cisco 3750E Stack & Aruba 3400 Controller -- Port Channel Issue

Hello. The issue I am having is when I put one port of an Aruba controller in a Port channel I can't ping the default gateway. I only have this one port connected to the switch to try and rule out any other issues. Once I take the one port out of the Aruba port channel and put it just pure trunked I can ping the default gateway. My laptop on the same network can ping the controller in both scenarios. Also once I do this, I lose all remote access to the controller (web/ssh).

Cisco Port Config:

 

description Wireless Controller Port 1

switchport trunk encapsulation dot1q

switchport mode trunk

switchport nonegotiate

flowcontrol receive on

channel-group 30 mode on

 

interface Port-channel30

description Port Channel for Wireless Controller

switchport trunk encapsulation dot1q

switchport mode trunk

switchport nonegotiate

flowcontrol receive on

spanning-tree portfast trunk

 

Aruba Side

interface gigabitethernet 1/1

description "GE1/1" trusted trusted vlan 1-4094

switchport mode trunk

switchport trunk allowed vlan 1-4094

 

interface port-channel 0

add gigabitethernet 1/1

trusted vlan 1-4093

switchport mode trunk

switchport trunk native vlan 70

switchport trunk allowed vlan 1-4094

spanning-tree portfast

 

ArubaOS 6.1.3.1


Accepted Solutions
Highlighted
Occasional Contributor II

Re: Cisco 3750E Stack & Aruba 3400 Controller -- Port Channel Issue

The above configuration will work.  Items to make sure:

 

Aruba side:

 

  Make sure you set your network interfaces to trunking before adding them into the port channel.  Once you do it won't let you change it until you take it out of the group.  Also the port group does not take precedence over what is configured on the interface.  So configure everything to work on each interface and then add to a port channel.

 

Cisco side:

 

Make sure you know how the port channel was orginally setup as this will affect how you can configure the port channel and then what takes precedence over needing to configure the port channel and interface or just port channel.

View solution in original post


All Replies
Highlighted
Guru Elite

Re: Cisco 3750E Stack & Aruba 3400 Controller -- Port Channel Issue

 Try this on the Aruba Controller:

 

interface port-channel 0

trusted.

 


*Answers and views expressed by me on this forum are my own and not necessarily the position of Aruba Networks or Hewlett Packard Enterprise.*
ArubaOS 8.5 User Guide
InstantOS 8.5 User Guide
Airheads Knowledgebase
Airheads Video Knowledge Base
Remote Access Point Solution Guide
ArubaOS Consolidated Release Notes
ArubaOS 8 ViA VPN Solution Guide
Highlighted
Occasional Contributor II

Re: Cisco 3750E Stack & Aruba 3400 Controller -- Port Channel Issue

Adding the trusted to the port channel now allowes me to remotely get into the controller, but I still can't ping the default gateway.

Highlighted
Guru Elite

Re: Cisco 3750E Stack & Aruba 3400 Controller -- Port Channel Issue

What is the default gateway?  Can you see it in your ARP table?

 


*Answers and views expressed by me on this forum are my own and not necessarily the position of Aruba Networks or Hewlett Packard Enterprise.*
ArubaOS 8.5 User Guide
InstantOS 8.5 User Guide
Airheads Knowledgebase
Airheads Video Knowledge Base
Remote Access Point Solution Guide
ArubaOS Consolidated Release Notes
ArubaOS 8 ViA VPN Solution Guide
Highlighted
Occasional Contributor II

Re: Cisco 3750E Stack & Aruba 3400 Controller -- Port Channel Issue

Nothing in arp. 

Highlighted
Guru Elite

Re: Cisco 3750E Stack & Aruba 3400 Controller -- Port Channel Issue

Are you pinging From:

 

A client on the LAN, the controller or a router?

What device is the default gateway in this situation?

 

 


*Answers and views expressed by me on this forum are my own and not necessarily the position of Aruba Networks or Hewlett Packard Enterprise.*
ArubaOS 8.5 User Guide
InstantOS 8.5 User Guide
Airheads Knowledgebase
Airheads Video Knowledge Base
Remote Access Point Solution Guide
ArubaOS Consolidated Release Notes
ArubaOS 8 ViA VPN Solution Guide
Highlighted
Occasional Contributor II

Re: Cisco 3750E Stack & Aruba 3400 Controller -- Port Channel Issue

When in port channel:

  Pinging from Cisco switch to controller = fail

  Pinging from controller to cisco switch = fail.

  Pinging from laptop in same subnet = is good

 

When in plain trunked port:

  everything works.

 

Cisco switch provides the default gateway.

Highlighted
Guru Elite

Re: Cisco 3750E Stack & Aruba 3400 Controller -- Port Channel Issue


@bettism wrote:

When in port channel:

  Pinging from Cisco switch to controller = fail

  Pinging from controller to cisco switch = fail.

  Pinging from laptop in same subnet = is good

 

When in plain trunked port:

  everything works.

 

Cisco switch provides the default gateway.


Can you clear the ARP table on all devices and try again?

 


*Answers and views expressed by me on this forum are my own and not necessarily the position of Aruba Networks or Hewlett Packard Enterprise.*
ArubaOS 8.5 User Guide
InstantOS 8.5 User Guide
Airheads Knowledgebase
Airheads Video Knowledge Base
Remote Access Point Solution Guide
ArubaOS Consolidated Release Notes
ArubaOS 8 ViA VPN Solution Guide
Highlighted
Aruba Employee

Re: Cisco 3750E Stack & Aruba 3400 Controller -- Port Channel Issue

A suggestion.

 

On the Cisco side:

 

interface xxxxx

 channel-protocol lacp
 channel-group 30 mode active

 

On the Aruba side:

 

interface gigabitethernet  1/1

 lacp group 0 mode passive

Highlighted
Occasional Contributor II

Re: Cisco 3750E Stack & Aruba 3400 Controller -- Port Channel Issue

Still no luck.  I have clear arp tables on both devices and no avail.

 

I did change everything over to LACP and still no luck.

 

interface gigabitethernet  1/1        

description "GE1/1"        

trusted        

trusted vlan 1-4094        

speed 1000        

duplex full        

lacp group 0 mode passive

 

interface port-channel 7        

trusted        

trusted vlan 1-4094        

switchport mode trunk        

switchport access vlan 70        

switchport trunk native vlan 70

 

Cisco:

 

sh eth sum

30     Po30(SU)        LACP      Gi1/0/39(P)

 

 

interface GigabitEthernet1/0/39  

description Wireless Controller Port 1

switchport trunk encapsulation dot1q  

switchport mode trunk  

switchport nonegotiate  

speed 1000  

duplex full  

channel-group 30 mode active

end

 

 

 

 

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: