Wireless Access

Occasional Contributor II

Help setting up 7005

Hi Everyone. This is my first time touching or seeing an Aruba device. I was given a 7005 to eventually setup as a wireless controller, but for now I just need to get it on the network. I'm a bit more versed with Cisco devices, so I have a conceptual understanding of what I need to do - I just don't have the command line knowledge to get it done. I'm hoping someone can help.


I went through the initial config and gave the device a 10.x.x.x address, and silly me, I thought just by plugging it into our network I'd be able to get to the web interface. No such luck - I'm assuming more configuration is needed.


There's just the default vlan (1) on the device right now, so I'm assuming I need to attach this vlan to a physical port? If I wanted to assign this to port 0, what is the command line sequence I would need to accomplish this - Google hasn't provided anything definitive?


Also, the boss said make sure STP is off. I Googled how to check it, and it is indeed on,  but I can't for the life of me find the command line process to accomplish this.


If I can simply get this thing online, on the network, and into the web interface today, I will consider it a win.





Regular Contributor I

Re: Help setting up 7005

You shouldn't have too much trouble with the CLI if you are familiar with cisco - many commands are the same and theres always the ? to help you.

If you only have one port plugged inkto the network there should be no spanning tree issues and VLAN is enabled on all ports by default.

To disable spanning tree, enter configuration mode and enter "no spanning-tree" command to disable globally.

One important concept when starting from scratch with an Aruba device is to make sure the port is trusted - just go into interface configuration mode of the connected port and type "trusted".


Re: Help setting up 7005

Did you run the full-setup initially?

That initial config gives the controller an ip address on its vlan 1 interface which is the access vlan on all ports.

So you should be able to connect to it relativly easy after that using https and or ssh. Just make sure the subnet you configure is available as native or access on the port you connect from.


Since you ran the intial configuration I do suppose you are connected serially. After runnign the full you can do some troubleshooting here if you like. CLI is pretty close to Cisco so should be easy goign for you for basic connectivity.


In the CLI you need to get into enable mode, then configure mode to do anything usefull. 


> enable
#configure terminal
(config) #no spanning-tree

And voila, nowe you know how to disable STP too.


Feel free to check out the quick start guide and other manuals here: https://support.arubanetworks.com/Documentation/tabid/77/DMXModule/512/Default.aspx?EntryId=23154


Once you have basic connectivity up and runnign you can try a few of the wizards in the GUI to get things working.

My advise though..  get someone with experience to help you with your first setup. 




Koen (ACMX #351 | ACDX #547 | ACCP)

-- Found something helpful, important, or cool? Click the Kudos Star in a post.
-- Problem Solved? Click "Accept as Solution" in a post.
Occasional Contributor II

Re: Help setting up 7005

Thank you both for the input.


STP is turned off now. One item checked off the list!


Unfortunately I still can't hit the web interface. Nobody here in this lab environment has ever worked with Aruba, so that is a bit of a problem. We purchased a bunch of the APIN0205 access points though, with the goal of setting up a secure wireless infrastructure, so I can see this is going to be a bit of a hurdle.


While we do have a bunch of Cisco devices here, they are basically set-it-and-forget-it devices that just work, so I can't say my Cisco knowledge is any further developed. Everything on my end requires lots of Googling, and then ensuing frustration when things still won't work.


Case-in-point, the very basic process of getting this web interface going. I basically have this 7005 and a computer connected to a dumb switch. This is a test setup. So barring any complicated back-end infrastructure, any thoughts on how to get this working?    From my web browser I type in https://10.x.x.x (the management IP address I specified through the terminal when configuring the 7005), and I get nothing. STP is off, IP is configured, and if what you say is correct that the ports automatically become active, then it should just work. Unfortunately it doesn't seem to be working though. I have swapped the ethernet cable to all the ports on the 7005 just to test, and nothing.


Sorry for the "noob" issues here, but I do appreciate the opportunity to expand my knowledge of this system.



Guru Elite

Re: Help setting up 7005

What VLAN did you set the 10.x.x.x network to?  If you assigned 10.x.x.x to a specific VLAN, but did not change the access VLAN on all the ports from 1 to 10, you will not have connectivity.  I don't think your problem is STP.


There is a quick start guide here:  http://support.arubanetworks.com/DOCUMENTATION/tabid/77/DMXModule/512/Command/Core_Download/Default.aspx?EntryId=10382 if you want to see how to setup a basic controller.

*Answers and views expressed by me on this forum are my own and not necessarily the position of Aruba Networks or Hewlett Packard Enterprise.*
ArubaOS 8.3 User Guide
InstantOS 8.3 User Guide
Airheads Knowledgebase
Airheads Learning Videos
Occasional Contributor II

Re: Help setting up 7005

Hi Colin - there was no vlan. This little branch was connected to a 4-port, $6 switch from Amazon. I gave all devices 10.x.x.x addresses in the same range just to test.


After about 6 hours messing around with this thing I moved it onto our production network to see if traffic had any effect on it. As expected, nothing.


However on this procudtion network, the specific branch I'm on has a VLAN ID. So I added a new matching VLAN on the Aruba using the following CLI statements which I found on Google, and assigned it to port 0:


(host) (config) #vlan <id>

(host) (config) #interface gigabitethernet 0/0/0

(host) (config-if) #switchport access vlan <id>


I am on port 0 of the Aruba, so the 0/0/0 is accurate.


I displayed the VLANS to ensure the new one was there, and indeed it is and on the port I need it on, but still no communication. Can't ping in or out from Aruba, and the connected computer obviously cannot ping out to anything either.


I just don't get what the complication is with this device. I don't want to scrap this, but I can't spend 20 hours trying to ping something. Everything logical has been covered to the best of my knowledge (which is a bit sparse in this area).


Thanks in advance for any other thoughts!


Regular Contributor I

Re: Help setting up 7005

Dave, can you share the output for the following commands -

show ip interface brief

show port status

show vlan

show ip route


Occasional Contributor II

Re: Help setting up 7005

Hello - yes, I'd be happy to provide that information. Please see below.

Thank you in advance for any suggestions. I'm 100% positive the issue is me not doing something correctly, so I'm eager to learn what has been missed.



(Aruba7005) #show ip interface brief

Interface                   IP Address / IP Netmask        Admin   Protocol
vlan 1              /     up      up
loopback                    unassigned / unassigned        up      up

(Aruba7005) #show port status

Port Status
Slot-Port  PortType  AdminState  OperState  PoE  Trusted  SpanningTree  PortMode  Speed   
---------  --------  ----------  ---------  ---  -------  ------------  --------  -----   
0/0/0      GE        Enabled     Up         N/A  Yes      Disabled      Access    1 Gbps  
0/0/1      GE        Enabled     Down       N/A  Yes      Disabled      Access    Auto    
0/0/2      GE        Enabled     Down       N/A  Yes      Disabled      Access    Auto    
0/0/3      GE        Enabled     Down       N/A  Yes      Disabled      Access    Auto    

(Aruba7005) #show vlan

VLAN  Description  Ports               AAA Profile
----  -----------  -----               -----------
1     Default      GE0/0/1-0/3 Pc0-7   N/A
402   VLAN0402     GE0/0/0             N/A

(Aruba7005) #show ip route

Codes: C - connected, O - OSPF, R - RIP, S - static
       M - mgmt, U - route usable, * - candidate default, V - RAPNG VPN/Branch

Gateway of last resort is Imported from DHCP to network at cost 10
Gateway of last resort is Imported from CELL to network at cost 10
Gateway of last resort is Imported from PPPOE to network at cost 10
Gateway of last resort is to network at cost 1
S*  [1/0] via*
C is directly connected, VLAN1

(Aruba7005) #
Regular Contributor I

Re: Help setting up 7005

So, your IP is in VLAN 1 which is attached to all ports except 0/0/0.

Interface 0/0/0 has only VLAN 402 connected to it but you don't have an IP in that VLAN.

So your VLAN 1 traffic  (10.20.1.x) can only exit out interfaces 0/0/1-3 which are all down.

You either need to trunk VLAN 1 on 0/0/0 or make it an access port for VLAN 1 (not 402).

Occasional Contributor II

Re: Help setting up 7005

Do you have any CLI statements that I can try to help resolve the issue? I'm googling as suggestions are coming in, but I'm not having much specific luck. At this point, literally ANYTHING would be beneficial. I understand the concepts of what you are asking, I just dont have the command line knowledge to implement any of them.


I only have one cable plugged into this 7005 at the moment - port 0. At the moment that is the only port that is up. The goal is simply to get access to its web interface.


Prior to this whole VLAN thing, VLAN1 was the only VLAN and it spanned all 4 ports. At that point, with the IP address attached to it, I was still unable to talk in or out. I don't believe that creating this vlan 402 within the Aruba will make a major difference - I still think something else is missing.


I will happily remove 402 if there are any other thoughts to get to the web interface??


Thank  you!!


Search Airheads
Showing results for 
Search instead for 
Did you mean: