Wireless Access

New Contributor

Key Encoding issue on Android Device for VIA Client


   The VIA clients I have tried with the android device (verision 2.2.3, 2.2.8)  are having issues pulling the private key from the keystore.  This is what I see in the logcat.


I/ArubaViaVpnPluginBridge( 6040): VIA VPN plugin library has been loaded
I/ArubaViaVpnPluginBridge( 6040): VIA VPN plugin initialization
E/ArubaVia( 6040): [VIA VPN service] VPN error
E/ArubaVia( 6040): com.aruba.via.keystore.ViaCertStorageException: Encoding is not supported by this key.
E/ArubaVia( 6040):      at com.aruba.via.keystore.ViaCertificateStorage.getEncodedPrivateKey(ViaCertificateStorage.java:169)
E/ArubaVia( 6040):      at com.aruba.via.vpn.ViaVpnService$2.run(ViaVpnService.java:261)
E/ArubaVia( 6040):      at java.lang.Thread.run(Thread.java:841)
I/ArubaVia( 6040): [VIA VPN service] VPN disconnecting...


I've tried re-creating the keys multiple times but it doesn't seem to like them.  I've also tried multiple versions of android upto kitkat.  For the record I am loading a p12/pfx file into the device which contains my private and public key pair.  I select the certiticate when Aruba asks for it and then I run into this error.  I am using RSA based certificates.  The client certs also have Extended Key Usage fields as well as NO BASIC Constraints set to FALSE.  Not sure if the certificate itself is missing some other attribute that the VIA client expects.  I've done this dozens of times.  Still not sure why this isn't working.  Any insight would be greatly appreciated.



Search Airheads
Showing results for 
Search instead for 
Did you mean: