Wireless Access

New Contributor

Problem with dell 1704 802.11b/g/n (2.4GHz)



I have a problem thats really driving me crazy!


We recently implemented IAP 315 (Firmware Version: campus wide wifi solution, high density deployment (30-40 feet per AP), since we have about 250 users inside this facility. 


I do not have any issues with the latest AC adapters, 5GHz works fine. 


The problem is we have about 40-50 old laptops with Dell 1704 802.11b/g/n (2.4GHz) adapters (Broadcom, driver version These laptops are mix of Windows 7 and Ubuntu 14.04 OS. 


When I connect to the SSID, it connect perfectly, but the client keeps hopping AP. For example, if there are APs A, B, C in this location, it keeps going back and forth from A to B to C and back to A every 30 seconds. Due to this the connection is not stable at all.


I tried setting the min transmit power to 6 max transmit power to 12 to reduce the coverage, but to no use. Bandwidth steering mode to "Preferred access" and also to "Fair Access", nothing helped. I fiddled a lot with these settings.


I started troubleshooting from the Dell 1704 adapter side. I forced the adapter settings to G mode (BSS mode - 802.11g Mode"


Below are my adapter settings:


802.11H loose 11h
Antenna diversity - AUX (originally auto)
AP Compatibility mode - Higher performance
arp offload - Enabled
Bandwidth capapcity - 11b/g:20/40 MHz
Bluetooth collaboration - Auto
BSS mode - 802.11g Mode
BT-Amp - Disabled
Fragmentation Threshold - 2346
IBSS 54g(tm) protection mode - Auto
IBSS mode - 802.11b/g/n auto
Locally administered MAC - Not present
Minimum power consumption - Enabled
NS Offload - Enabled
PLCP header - Auto (short/long)
priority & VLAN - priority & VLAN disabled
Rate (802.11b/g) - Best rate
Roam tendency - Moderate
Roaming decision - Default
RTS Threshold - 2347
Wake on magic packet - enabled
Wake on pattern match - Enabled
WiFi rekeying offload - Enabled
WMM - Disabled
WZC IBSS Channel Number - 11(20MHZ)
Xpress (TM) Technology - Disabled


but still the AP keeps switching. 


I tried with fresh install of Windows 7, Windows 10 OS also. The same behaviour with all the OSs.


I called logged with HP, but was not of much help. 


Authentication - Radius (windows 2016)

WPA2-Enterprise (AES)

We use VLAN tagging for SSIDs and have 7 different SSIDs for different VLANs


Anyone came across such issue and solved it? Please help.

Search Airheads
Showing results for 
Search instead for 
Did you mean: