Wireless Access

Reply
ryh
Contributor II

Triggering AP-Load Balancing in AOS 8.2 Cluster: Troubleshooting & manual CLI trigger

In a cluster of controllers (L2-connected, Redundancy on, active-ap-lb is on) I have APs that are not being rebalanced on the controllers.  Before and after a successful live-upgrade (480 APs in less than an hour!), the APs are all on one controller. The code version is 8.2.1.0.

 

I've tried adjusting the threshholds but it is not triggering.  Disabling and enabling again does nothing, even after a considerable waiting period.  Is there a manual way to trigger the load balancing?  I know I can perform "apmove" but I want to be sure this will automatically rebalance in the future.

ryh
Contributor II

Re: Triggering AP-Load Balancing in AOS 8.2 Cluster: Troubleshooting & manual CLI trigger

...Or is there a way to troubleshoot this or a list of the basic requirements for it to be implemented?  I've read the relevant section in the Aruba OS user-guide, and this should be working as is described.

 

Regards,

ryh

Re: Triggering AP-Load Balancing in AOS 8.2 Cluster: Troubleshooting

--





Thank you

Victor Fabian
Lead Mobility Architect @WEI
AMFX | ACMX | ACDX | ACCX | CWAP | CWDP | CWNA

Re: Triggering AP-Load Balancing in AOS 8.2 Cluster: Troubleshooting

Do you have AP Load Balancing enabled?
(BOSTON-MC-1) #show lc-cluster group-membership

Cluster Enabled, Profile Name = "BOSTON-CLUSTER-MC"
Redundancy Mode On
Active Client Rebalance Threshold = 50%
Standby Client Rebalance Threshold = 75%
Unbalance Threshold = 5%
AP Load Balancing: Enabled
Active AP Rebalance Threshold = 50%
Active AP Unbalance Threshold = 5%
Active AP Rebalance AP Count = 10
Active AP Rebalance Timer = 5 minutes
Cluster Info Table

The AP Load Balancing feature is disabled by default.
Thank you

Victor Fabian
Lead Mobility Architect @WEI
AMFX | ACMX | ACDX | ACCX | CWAP | CWDP | CWNA
ryh
Contributor II

Re: Triggering AP-Load Balancing in AOS 8.2 Cluster: Troubleshooting

Yes, it is enabled and I see the same information there in the "show lc-cluster group-membership" command, when issued on both controllers in the cluster.  I've even tried setting the threshold to an abnormally low value of 15% to really force it, to no success.

 

I'm miffed.

 

I have another cluster that I'm trying this on as well, but since it is in the beginning stages of deployment I am hovering around 1-2% of platform capacity and did not expect it to work there at this time.

New Contributor

Re: Triggering AP-Load Balancing in AOS 8.2 Cluster: Troubleshooting

Having the same issue here on 8.3.0.3. Currently with support to resolve other more pressing issues. But this bug and not being able to move clients onto different controllers is troublesome.

Re: Triggering AP-Load Balancing in AOS 8.2 Cluster: Troubleshooting


@ryh wrote:

Yes, it is enabled and I see the same information there in the "show lc-cluster group-membership" command, when issued on both controllers in the cluster.  I've even tried setting the threshold to an abnormally low value of 15% to really force it, to no success.

 

I'm miffed.

 

I have another cluster that I'm trying this on as well, but since it is in the beginning stages of deployment I am hovering around 1-2% of platform capacity and did not expect it to work there at this time.


This is specific to 8.2.X.X, but our APs aren't rebalancing either. We were in a situation recently where 4 fail-overs would occur a day due to heartbeats being missed between the 4 controllers. That stabilized about 10 days ago, but APs have not rebalanced. I was curious if this is the "normal behavior" in 8.2.X.X when I noticed an excerpt from the release notes of 8.3.X.X - that made it sound like pre 8.3.X.X - cluster leader load balanced based on Total AP Load (Active/Standby APs) - and in 8.3.X.X - cluster leader load balanced based soley on Active APs. When you calculate the % Load of Total APs, it appears to be balanced.
image003.jpgimage002.png

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: