Wireless Access

Reply
Occasional Contributor II

Re: WLC's and AP's on the same subnet/VLAN ?

Ok thanks. I'll configure that. Then i don't need this option DHCP 43 anymore ?

And what about the access to the WLC, is that normal that I can access it from the VLAN 101, 102 and 103 ? I really would like to avoid this...

 

AL

Occasional Contributor II

Re: WLC's and AP's on the same subnet/VLAN ?

Native vlan 100 didn't help ...

The AP in VLAN 101 needs to communicate with which interface, the interface VLAN 100 or interace VLAN 101 ?

 

I'm new in Aruba networks, I don't really know if this is working like Cisco...

 

Thank you,

AL

Guru Elite

Re: WLC's and AP's on the same subnet/VLAN ?

What is your default gateway for each VLAN? What default gateway is your DHCP server giving out?  Is that Cisco switch a layer 3 switch?


*Answers and views expressed by me on this forum are my own and not necessarily the position of Aruba Networks or Hewlett Packard Enterprise.*
ArubaOS 8.4 User Guide
InstantOS 8.3 User Guide
Airheads Knowledgebase
Airheads Learning Videos
Aruba Central Documentation
Sign up for Security Alerts
Aruba Technical Webinars
Occasional Contributor II

Re: WLC's and AP's on the same subnet/VLAN ?

The default gateway for each VLAN is located on a cisco switch indeed.

Later it will be an Aruba switch, but I am using a Cisco swich to prepare all the AP's.

 

AL

Guru Elite

Re: WLC's and AP's on the same subnet/VLAN ?

Okay.  On the port that connects the Cisco layer 3 switch to the Aruba controller, your native VLAN must be 100.  On the port that connects the Aruba Controller to the Cisco layer 3 switch, the native VLAN must also be 100.  

 

Your DHCP server must be giving out the ip address on your Cisco layer 3 switch on each VLAN as the default gateway.


*Answers and views expressed by me on this forum are my own and not necessarily the position of Aruba Networks or Hewlett Packard Enterprise.*
ArubaOS 8.4 User Guide
InstantOS 8.3 User Guide
Airheads Knowledgebase
Airheads Learning Videos
Aruba Central Documentation
Sign up for Security Alerts
Aruba Technical Webinars
MVP Guru

Re: WLC's and AP's on the same subnet/VLAN ?

Are you using an external DHCP server ? or the controller is acting as your DHCP server ?
Thank you

Victor Fabian
Lead Mobility Architect @WEI
AMFX | ACMX | ACDX | ACCX | CWAP | CWDP | CWNA
Highlighted
Occasional Contributor II

Re: WLC's and AP's on the same subnet/VLAN ?

The cisco switch is the DHCP server.

VLAN100 is the management Vlan, and VLAN101 is dedicated to the AP's.

 

Here is my scenario :

 

WLC-Aruba --SW-Cisco--AP Aruba

 

On the switch I have : 

 

interface FastEthernet0/1
description *** To WLC-Aruba-Gi0/0/0 ***
switchport trunk encapsulation dot1q
switchport trunk native vlan 100
switchport trunk allowed vlan 100,101,102,103
switchport mode trunk

 

ip dhcp pool APs
network 172.16.101.0 255.255.255.0
default-router 172.16.101.254
lease 7

!

interface Vlan100
ip address 172.16.100.254 255.255.255.0
ip helper-address 172.16.100.1
!
interface Vlan101
ip address 172.16.101.254 255.255.255.0

 

On Aruba WLC I have : 

 

interface gigabitethernet 0/0/0
description "***Uplink-to-Cisco-SW***"
trusted
trusted vlan 100-103
switchport mode trunk
switchport trunk native vlan 100
switchport trunk allowed vlan 100,101,102-103

!
vlan 100 172.16.100.1 / 255.255.255.0 
vlan 101 172.16.101.1 / 255.255.255.0

 

My AP is connected on a switchport in acc vlan 101.

 

I am wondering if the AP's in the VLAN 101 need to communicate with the WLC's interface vlan 100 or 101 ?

 

AL

Guru Elite

Re: WLC's and AP's on the same subnet/VLAN ?

What is your switch ip / vlan on the Aruba Controller?  (type "show switch ip").  You need to make it vlan 100.


*Answers and views expressed by me on this forum are my own and not necessarily the position of Aruba Networks or Hewlett Packard Enterprise.*
ArubaOS 8.4 User Guide
InstantOS 8.3 User Guide
Airheads Knowledgebase
Airheads Learning Videos
Aruba Central Documentation
Sign up for Security Alerts
Aruba Technical Webinars
MVP Guru

Re: WLC's and AP's on the same subnet/VLAN ?

In that case you will need to configure option 43 on that pool to point the APs to discover the master controller

If you don't want to that then you can use an external dhcp server and allow the aps to discover the controller via dns using the aruba-master

Another option would be to use the controller as your dhcp and configure the option 43 there or keep the dhcp on the Cisco switch but put all the APs on the same subnet as the controller and the APs will discover controller via ADP (multicast)

Get Outlook for iOS
Thank you

Victor Fabian
Lead Mobility Architect @WEI
AMFX | ACMX | ACDX | ACCX | CWAP | CWDP | CWNA
Guru Elite

Re: WLC's and AP's on the same subnet/VLAN ?

config t

controller-ip vlan 100

 


*Answers and views expressed by me on this forum are my own and not necessarily the position of Aruba Networks or Hewlett Packard Enterprise.*
ArubaOS 8.4 User Guide
InstantOS 8.3 User Guide
Airheads Knowledgebase
Airheads Learning Videos
Aruba Central Documentation
Sign up for Security Alerts
Aruba Technical Webinars
Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: