Wireless Access

Reply
Highlighted
New Contributor

Windows 10 DNS fails with VIA client.

Trying to use VIA client with split-tunnelling on windows-10.

Tunnelling itself works, can route correctly to Corp/Internet sites using IP address.

However DNS is always going to ISP addresses, not to DNS servers configured in VIA.

I think this is because the Via adaptor always creates a route-metric of 501, which makes it a higher cost than physical(ISP) connections. 

It can be temp-fixed by changing the interface-metric to 1, but this only lasts for that session, it will always reconnect with metric=501.

 

I need the client to force use of corporate DNS servers while it is connected. Can anyone advise?

 

Highlighted
MVP Expert

Re: Windows 10 DNS fails with VIA client.

Did you define the DNS servers for the pool under Services > General > Primary DNS ?



Thank you

Victor Fabian

Pardon typos sent from Mobile
Thank you

Victor Fabian
Lead Mobility Architect @WEI
AMFX | ACMX | ACDX | ACCX | CWAP | CWDP | CWNA
Highlighted
New Contributor

Re: Windows 10 DNS fails with VIA client.

Hi Fabian,

we use a Mobility Master, so settings are defined under configuration/authentication/L3 Authentication. 

Adapter details appear to be correct:

Description . . . . . . . . . . . : Aruba Virtual Adapter
Physical Address. . . . . . . . . : 00-FF-85-38-E1-60
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::1c8f:da91:b685:230a%12(Preferred)
IPv4 Address. . . . . . . . . . . : 1.8.3.32(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.255
Lease Obtained. . . . . . . . . . : 22 May 2020 16:07:18
Lease Expires . . . . . . . . . . : 22 May 2020 17:07:17
Default Gateway . . . . . . . . . :
DHCP Server . . . . . . . . . . . : 1.8.3.32
DHCPv6 IAID . . . . . . . . . . . : 201392005
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-23-3D-28-6B-00-15-5D-22-64-00
DNS Servers . . . . . . . . . . . : 172.24.64.100
NetBIOS over Tcpip. . . . . . . . : Enabled

 

DNS server is our internal server, and it works perfectly if I change the metric for the interface (only admin can change the metric).

 

If I do not change the metric, NSLookup goes to ISP DNS;

nslookup
Default Server: resolver1-fs.opendns.com
Address: 208.67.222.123

 

 

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: