Wireless Access

Occasional Contributor I

Wireless clients can't print to wired printers.


We have been experiencing a problem where users become unable to print to network-attached printers.  This has been going on for several months and I have tried resolving it in many ways, including upgrading the firmware. Nothing seems to resolve the problem.    Below are the facts of this issue, some explanation of our troubleshooting that we have completed, and I have also attached a configuration file from one of the AP-105US devices for your review.



  • A wireless workstation / laptop shows connectivity to the printers.  After about 5 minutes (sometimes much longer) the printer shows unavailable. The laptop can still ping the printers but cannot send jobs to them.
  • We reinstall the printer drivers and the user can print for a while (maybe minutes, hours, or even days). At some point the printers show unavailable again. 



  • The network layout is very simple in our environment:    AP-105 -> Cisco 300-28P switch -> Wired printers.  All AP devices, except one are connected to this single Cisco switch.   The AP device that is not is connected to another Cisco switch which is connected to the one that everything else is connected to.
  • There are 9 AP-105 devices used in this campus (it is a church).
  • Wired workstations do not experience any printing problems.
  • Wireless workstations that we “convert” to wired do not experience any printing problems. Once connected to the wired network they can immediately print. When we convert them back to wireless workstations they experience the problem again.
  • We have three main printers at the campus. Two are Konica printers and one is an HP Laser Jet.  We experience the same problem with all of them. 
  • The workstations are running Windows 7, Windows 8, and Mac OS X.
  • The wireless infrastructure is basic: two VLANs: one for staff and one for guests. The guests are on an isolated VLAN and have no access to office resources (printers, servers, etc).  
  • The wireless infrastructure provides DHCP services to only the guest VLAN. The office VLAN is passed to the main router (Comcast) for DHCP services).
  • At not time are these workstations disconnected from the network. Even when they cannot print, they can still access other office resources, access the external internet, etc.



  • I am a UNIX / Storage Admin by trade so I understand network technologies but am not proficient with them. I’m wondering if maybe there is a configuration setting on the APs that I have failed to set.
  • I have been unable to find documentation of a similar problem on your website, on message boards, etc so I’m hoping that this is a simple problem with our configuration.



Re: Wireless clients can't print to wired printers.

Is this a controller or Instant architecture?

Seth R. Fiermonti
Consulting Systems Engineer - ACCX, ACDX, ACMX
Email: seth@hpe.com
If you found my post helpful, please give kudos
Occasional Contributor I

Re: Wireless clients can't print to wired printers.

It's an Instant Architecture.

Aruba Employee

Re: Wireless clients can't print to wired printers.

I had a similar issue with an older HP wireless printer and 1 windows client only capable of 2.4 band. Once I upgraded my printer to a newer model the issue hasnt resurfaced.


I would check that on the 2.4G band radio of the IAP's that 802.11d/h is unchecked (this caused an issue with my old printer).


Since you still appear to have connectivity at layer 2 (wireless) and layer 3 (ping) and no other issues with connectivity to other devices and services on the same network I believe you are looking at a higher level software issue with the printer software on the laptops.



Occasional Contributor I

Re: Wireless clients can't print to wired printers.

I'll check that setting. Last night I found that the printers on each workstation were using SNMP to determine if the printer was online.   When I turned that off (printer properties -> ports -> Configure Ports) it showed the printer online and I haven't (yet) seen any further problem.


Thanks for the reply!

New Contributor

Re: Wireless clients can't print to wired printers.

Reminds me of the same thing the famous company of tshirt printing in Los Angeles was facing they really were really trying almost everything but nothing was working to be fair and then the things that worked out for you, same things clicked for them aswell good for them and I too finally got my problem solved, sometimes we are really missing out simple things and panicking too much lol...

New Contributor

Re: Wireless clients can't print to wired printers.

I know this is old, but I didn't see a solution. For me, turning on Bonjour worked. It is found under More>Services then check the box for Bonjour. I also enabled airprint and airplay.  http://screencast.com/t/m1ArjM18

Contributor I

Re: Wireless clients can't print to wired printers.

Hi every one!!


I have the same problem, with a ArubaOS with a 7210 controller, 6 APs Alcatel similar to IAP-105, the Guest Role that works in VLAN X cannot print on any printers on VLAN Y, Z, etc.



Guru Elite

Re: Wireless clients can't print to wired printers.

What are the ACLs for your guest role?

What protocol and TCP/UDP ports does your printer require to print?

Is your printer VLAN even routable from your guest VLAN?

*Answers and views expressed by me on this forum are my own and not necessarily the position of Aruba Networks or Hewlett Packard Enterprise.*
ArubaOS 8.4 User Guide
InstantOS 8.3 User Guide
Airheads Knowledgebase
Airheads Learning Videos
Aruba Central Documentation
Sign up for Security Alerts
Aruba Technical Webinars
Contributor I

Re: Wireless clients can't print to wired printers.

Hi Colin


I have not configure ACLs, I've configured to test the 35, 92, 170 tcp ports, the VLAN is added to the Controller but have not been created the route yet. I'm gonna test with the ports, after that with adding the route VLAN and then with the ACL.

When pinging the printers responds well.



Search Airheads
Showing results for 
Search instead for 
Did you mean: