Occasional Contributor II

Re: Google Expeditions

Thanks for posting, Brett!  Would you mind sharing more about the config you got Expeditions working with?  I'm having some trouble getting Expeditions working on our Aruba network.  The behavior I see is the teacher will open Expeditions on an Android or iOS device, enter Guide mode, create a class (e.g. download Mount Everest), click Start, and then on a student's Android or iOS device they go into Explorer mode but they never see the Guide.  I can get this working fine on an old Linksys WRT54G.  I cannot get Expeditions working on our campus Aruba controllers and AP's.


Here are some details about our infrastructure and the SSID I've been testing with: We have 7210 controllers, mostly AP-21x access points, and we're running code rev  I created a separate SSID and VLAN isolated to a single controller for testing this without affecting our production SSID's and VLAN's.  I tried the following:


Created expeditions AirGroup service with service ID: _googexpeditions._tcp


airgroup service expeditions enable    
airgroupservice expeditions
     id _googexpeditions._tcp
     autoassociate apgroup
     description Google Expeditions

Verified that AirGroup was allowed for the VLAN



airgroup vlan 106 allow

Tried disabling auto associate



airgroupservice expeditions no autoassociate

Tried enabling IGMP snooping



interface vlan 106
interface vlan 106 ip igmp snooping

I tried various combinations of the broadcast / multicast options for the SSID.  It seems logical to me that the problem exists somewhere in the broadcast / multicast settings on the controllers.  The knob I was expecting to be blocking the traffic was Drop Broadcast and Unknown Multicast, but still no go.



wlan virtual-ap "Expeditions-vap_prof"
  no dynamic-mcast-optimization
  no broadcast-filter all
  no broadcast-filter arp

I also found a helpful blog post called "Running Google Expeditions on your Cisco Wireless" (https://www.rsaeks.com/?p=469) that suggested formatting the service string as "_googexpeditions._tcp.local." instead, and when I tried entering it that way the controller said "The format should be " _abc._tcp/udp, _abc-def._tcp/udp or urn:schemas-upnp-org:device:MediaServer:1" so I guess Aruba controllers don't like the _local part.


Any ideas or replies are greatly appreciated!  Thanks!