Ty
New Member

Re: Latest code on a 620 controller

Yep it will support 6.4. I just upgraded one today. I couldn't upgrade through the webui however, I had to go through the cli.