Frequent Contributor I

Re: NAT

I followed this config to solve my issue. This might help someone else:

 

 

!
vlan 10 OUTSIDE-INTERNET
vlan 20 INSIDE-NETWORK
!
ip access-list session OUTSIDE-INTERNET
any any svc-dhcp permit (required for DHCP)
any any tcp 22 permit (use this to allow SSH to controller)
any any tcp 4343 permit (use this to allow SSL/WebUI to controller)
any any tcp 80 dst-nat ip 192.168.168.100 (use the following to host multiple web servers - this one is NAT only, no PAT)
any any tcp 81 dst-nat ip 192.168.168.101 80 (this one is port 81 incoming then NAT and PAT to port 80)
any any tcp 82 dst-nat ip 192.168.168.102 80 (this one is port 82 incoming then NAT and PAT to port 80)
any any tcp 83 dst-nat ip 192.168.168.103 80 (this one is port 83 incoming then NAT and PAT to port 80)
any any tcp 37777 dst-nat ip 192.168.168.99 (see hosted security camera example below)
any any any deny
!
interface gigabitethernet 1/0
description OUTSIDE-INTERNET
trusted
ip access-group OUTSIDE-INTERNET session
switchport access vlan 10
spanning-tree port fast
!
interface gigabitethernet 1/1
description INSIDE-NETWORK
trusted
switchport access vlan 20
spanning-tree portfast
!
interface vlan 10
ip address dhcp-client
operstate up
!
interface vlan 20
ip address 192.168.168.1 255.255.255.0
ip nat inside
operstate up
!
ip dhcp excluded-address 192.168.168.1 192.168.168.128
!
ip dhcp pool HOME-DHCP-POOL
default-router 192.168.168.1
dns-server import
domain-name arubanetworks.com
network 192.168.168.0 255.255.255.0
!
service dhcp
controller-ip vlan 20
!