Wireless Access

Who Me Too'd this topic

Contributor I

MAC OS X and 802.1x Issues

I know this is going to be a braindump,but here goes:

 

I have been experiencing many problems this semester with some odd behavior on Mac OS X clients ranging from 10.7.5 to 10.9.

 

My current environment is as follows:

 

7210 Controllers

AOS 7.4.1.0

Mixture of AP-105/205 mostly, tunneled

1 x 802.1x PEAP SSID running against MSFT NPS (soon to be clearpass I hope)

1 x Guest Open SSID running against AOS captive portal (soon to be clearpass I hope)

1 x WPA2-PSK legacy SSID that requires mac address registration

 

Lately I have been having several students bring Mac OS X devices in that worked previously that one day just deciede to stop authenticating against the 802.1x network. They simply say "invalid password." When these clients get in this state, in last year or so we have attempted to clear the keychain because for some reason they were becoming corrupted on our networks, but that doesn't seem to fix the problem anymore.

 

Oddly enough, the clients also seem to be unable to get the captive portal to load after they get an IP address on that network, but the WPA2-PSK network works fine.

 

Honestly, I know onboarding is better, but there is a lot of infrastructure around that I can't afford at the moment. There have been days I have wanted to drop the 802.1x network and just go to an open network, especially since mobility is only 1/6th my job :(

 

Any ideas on where to go to troubleshoot MAC OSX (I don't even have on of these devices to test)

Who Me Too'd this topic