Community Feedback

 View Only
last person joined: 4 days ago 

How is the community doing? Do you have any questions or feedback related for the Airheads Community team? This is the place to let us know.

Mikrotik DHCP options to connect Aruba APs to controller

This thread has been viewed 8 times
  • 1.  Mikrotik DHCP options to connect Aruba APs to controller

    Posted Dec 10, 2021 10:16 AM
    I searched for a while and found a few folks asking this question but no direct, informative answer. I decided to work it out myself and will post the results on how i got it to work.

    First, make your options
    /ip dhcp-server option
    add code=43 name=ArubaAP-43 value="'X.X.X.X'"      (controller IP in place of X's)
    add code=60 name=ArubaAP-60 value="'ArubaAP'"

    I bound them together under an option set
    /ip dhcp-server option sets
    add name=Aruba-AP options=ArubaAP-43,ArubaAP-60

    Add the option set to your dhcp server, as well as the dhcp network
    /ip dhcp-server
    add address-pool=managment dhcp-option-set=Aruba-AP disabled=no interface="10 Managment" lease-time=1h10m \
    name=managment
    /ip dhcp-server network
    add address=X.X.X.X/24 dhcp-option-set=Aruba-AP dns-server=X.X.X.X gateway=X.X.X.X

    That would do it for a simple setup. My setup is a bit more complex as this setup goes through a mikrotik router before it leaves the complex. In order for me to get it to pass to my control as its local ip, rather than the routers public ip it nats through, i added an exclusion rule, so it would not nat the local ip destined for the controler address, denoted by X.X.X.X below.

    /ip firewall nat
    add action=masquerade chain=srcnat dst-address=!X.X.X.X out-interface=ether1

    This functions because my controller can reach the private IP of the access point.

    Happy hunting!
    -Jeff

    ------------------------------
    Jeff Jones
    ------------------------------