Campus Switching and Routing

Reply
Occasional Contributor I

802.1Q interfaces

My company recently switched from Cisco to Aruba.  I am having trouble getting VLAN to work on the Aruba switches.  My issue is getting computers in the same VLAN to connect a computer on the same VLAN but located on a different switch.   I have one port on each switch tagged for all my VLAN then there are certain ports on the switch untagged for the appropriate VLAN.  If the computers are on the same switch they can ping each other but when I have them on different switches they can ping each other.  I know how to do this on a Cisco switch but I just can make it work on the Aruba switches.  We got 2930F for the access layer and they connect to a 3810m as the core switch.  Any help would be greatly appreciated.  

Contributor II

Re: 802.1Q interfaces

Hello Friend.

 

Did you certify that the uplink ports (switch to switch) have the correct vlan tags? Post configuration of both switches here ...


|ATP FLEXNETWORK V3|ACSA
Occasional Contributor I

Re: 802.1Q interfaces

Switch 1


hostname "asw2"
module 1 type jl256a
no web-management
web-management ssl
ip routing
snmp-server community "public" unrestricted
vlan 1
name "DEFAULT_VLAN"
no untagged 1-4,13-15
untagged 5-12,16-52
ip address dhcp-bootp
exit
vlan 64
name "Security"
tagged 52
no ip address
exit
vlan 99
name "Server"
tagged 52
no ip address
exit
vlan 100
name "corporate"
untagged 13-15
tagged 52
no ip address
ip helper-address 10.63.1.176
exit
vlan 101
name "future"
tagged 52
no ip address
exit
vlan 128
name "Public"
untagged 1-4
tagged 52
no ip address
ip helper-address 10.63.1.176
exit
vlan 192
name "POS"
tagged 52
no ip address
exit
no tftp server
no autorun
no dhcp config-file-update
no dhcp image-file-update
no dhcp tr69-acs-url
password manager
password operator

 

Switch 2


hostname "asw8"
module 1 type jl256a
no telnet-server
time timezone -5
no web-management
web-management ssl
ip access-list extended "100"
10 deny ip 10.1.10.0 0.0.0.255 0.0.0.0 255.255.255.255
20 permit ip 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255
exit
ip routing
interface 1
ip access-group "100" in
mvrp enable
exit
snmp-server community "public" unrestricted
vlan 1
name "DEFAULT_VLAN"
no untagged 1-4,13-15
untagged 5-12,16-52
ip address dhcp-bootp
exit
vlan 64
name "Security"
tagged 52
no ip address
exit
vlan 99
name "Server"
tagged 52
no ip address
exit
vlan 100
name "corporate"
untagged 13-15
tagged 52
no ip address
ip helper-address 10.63.1.176
exit
vlan 101
name "future"
tagged 52
no ip address
exit
vlan 128
name "Public"
untagged 1-4
tagged 52
no ip address
ip helper-address 10.63.1.176
exit
vlan 192
name "POS"
tagged 52
no ip address
exit
spanning-tree
no tftp server
no autorun
no dhcp config-file-update
no dhcp image-file-update
no dhcp tr69-acs-url
password manager
password operator

Aruba Employee

Re: 802.1Q interfaces

Greetings!

 

From the look of it, both 2930Fs are using port 52 as the uplink, so each of the VLANs appear to be tagged/untagged correctly; is the same VLAN ID tagged on the 3810's downlink ports for these two switches?  That would be the first thing I'd suggest to check. 

 

Next, I'm noting that you have spanning tree enabled on switch #2; I'd check to make sure that it's not blocking any ports.



Matthew Fern | Technical Marketing Engineer, Campus Networking
Aruba, a Hewlett Packard Enterprise Company
Occasional Contributor I

Re: 802.1Q interfaces

I ran show spanning-tree and it shows 

Multiple Spanning Tree (MST) Information

STP Enabled : No

 

Core switch config

hostname "MDFcore"
module 1 type jl075x
module 2 type jl075y
module 3 type jl075z
no web-management
web-management ssl
ip default-gateway 10.63.1.2
ip routing
snmp-server community "public" unrestricted
oobm
ip address dhcp-bootp
exit
vlan 1
name "DEFAULT_VLAN"
no untagged 1-16
no ip address
exit
vlan 64
name "Security"
tagged 1-16
ip address 172.31.0.1 255.255.0.0
exit
vlan 99
name "Server"
tagged 1-16
ip address 10.63.1.1 255.255.252.0
exit
vlan 100
name "corporate"
tagged 1-16
ip address 10.63.4.1 255.255.252.0
ip helper-address 10.63.1.176
exit
vlan 101
name "future"
tagged 1-16
no ip address
exit
vlan 128
name "Public"
tagged 1-16
ip address 10.1.10.2 255.255.255.0
ip helper-address 10.63.1.176
exit
vlan 192
name "POS"
tagged 1-16
ip address 10.63.12.1 255.255.252.0
exit
no tftp server
no autorun
no dhcp config-file-update
no dhcp image-file-update
password manager
password operator

Aruba Employee

Re: 802.1Q interfaces

Configurations look good, as far as I can tell; the next thing I'd check is basic connectivity between each of the 2930Fs and the 3810, followed by between the 2930Fs themselves. This should be as simple as putting a temporary IP address on the 2930F VLAN(s) you're having trouble with, and pinging in each direction between the switches to make sure you get responses.

 

If that works, but your clients still can't connect to each other across the network, let me know via PM so we can gather more info about what's going on.



Matthew Fern | Technical Marketing Engineer, Campus Networking
Aruba, a Hewlett Packard Enterprise Company
Occasional Contributor I

Re: 802.1Q interfaces

So I do have a connectivity problem switch ASW8(2930f) and MDFcore(3810m) can ping each other but I can't pint ASW2 from either of the other two switches.  I am troubleshooting that now.  

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: