Campus Switching and Routing

Reply
Occasional Contributor II

Configure 2930f

Hi

I'm new with Aruba-switches.

My schematic :

Basic

When i put a pc in port 1 (IP 10.10.100.101 - GW 10.10.100.254) , I can manage all the switches and go on the internet.

Now what should I do for the following:

Put a pc in port 5 of the 1210-16 so he get an IP (from dhcp on vlan30) and then this pc allow to go on the internet?

Thx for help

Delan

Aruba Employee

Re: Configure 2930f

Hi Delan,

 

Just to verify I think you mean VLAN 20 right? Do you get an IP with correct default gateway from DHCP? Do you have ip routing enabled on the 2930f?

 

Regards, Dobias

Occasional Contributor II

Re: Configure 2930f

Hi Dobias

yes , I have set all the ip-addresses manualy as in the schema.

IP routing is on.

The gateway's of the pc's (per vlan) are the ip addresses of the vlan interfaces.

I was struggling today and had no result.

It's like the routing isn't work.

I checked and the switch is in L3-mode.

 

Occasional Contributor II

Re: Configure 2930f

hi

I setup a test environment

The pfsense 10.70.200.254

switch 2930f :

Running configuration:

; JL259A Configuration Editor; Created on release #WC.16.03.0004
; Ver #10:08.3f.ff.bb.ef.7c.59.fc.6b.fb.9f.fc.ff.ff.37.ef:7e
hostname "Core"
module 1 type jl259a
ip default-gateway 10.70.200.254
ip routing
snmp-server community "public" unrestricted
vlan 1
name "DEFAULT_VLAN"
no untagged 13-14
untagged 1-12,15-28
ip address 10.70.200.11 255.255.255.0
exit
vlan 100
name "VLAN100"
untagged 13-14
tagged 24
ip address 10.70.201.12 255.255.255.0
exit
no tftp server
no autorun
no dhcp config-file-update
no dhcp image-file-update
password manager

Core(config)#

 

Core(config)# sh ip

Internet (IP) Service

IP Routing : Enabled


Default TTL : 64
Arp Age : 20
Domain Suffix :
DNS server :

| Proxy ARP
VLAN | IP Config IP Address Subnet Mask Std Local
-------------------- + ---------- --------------- --------------- ----------
DEFAULT_VLAN | Manual 10.70.200.11 255.255.255.0 No No
VLAN100 | Manual 10.70.201.12 255.255.255.0 No No


Core(config)#

 

Core(config)# sh ip route

IP Route Entries

Destination Gateway VLAN Type Sub-Type Metric Dist.
------------------ --------------- ---- --------- ---------- ---------- -----
10.70.200.0/24 DEFAULT_VLAN 1 connected 1 0
10.70.201.0/24 VLAN100 100 connected 1 0
127.0.0.0/8 reject static 0 0
127.0.0.1/32 lo0 connected 1 0


Core(config)#

 

This are all the settings

PC1 (in port 1) 

IP : 10.70.200.101 - GW : 10.70.200.254 - MASK : /24

PC2 (in port 13)

IP : 10.70.201.102 - GW : 10.70.201.12 - MASK : /24

(also tried with GW : 10.70.200.254)

 

From PC 1 ok to internet, no ping to pc2

From PC2 no internet and no ping to pc1

 

I don't understand it ????

 

Help please

Where can I try something?

THX

 

Occasional Contributor II

Re: Configure 2930f

Hi

I made a test environment :

The pfsense is 10.70.200.254 /24 in port 24

Switch settings :

Core# sh ru

Running configuration:

; JL259A Configuration Editor; Created on release #WC.16.03.0004
; Ver #10:08.3f.ff.bb.ef.7c.59.fc.6b.fb.9f.fc.ff.ff.37.ef:7e
hostname "Core"
module 1 type jl259a
ip default-gateway 10.70.200.254
ip routing
snmp-server community "public" unrestricted
vlan 1
name "DEFAULT_VLAN"
no untagged 13-14
untagged 1-12,15-28
ip address 10.70.200.11 255.255.255.0
exit
vlan 100
name "VLAN100"
untagged 13-14
tagged 24
ip address 10.70.201.12 255.255.255.0
exit
no tftp server
no autorun
no dhcp config-file-update
no dhcp image-file-update
password manager

 

Core# sh ip

Internet (IP) Service

IP Routing : Enabled


Default TTL : 64
Arp Age : 20
Domain Suffix :
DNS server :

| Proxy ARP
VLAN | IP Config IP Address Subnet Mask Std Local
-------------------- + ---------- --------------- --------------- ----------
DEFAULT_VLAN | Manual 10.70.200.11 255.255.255.0 No No
VLAN100 | Manual 10.70.201.12 255.255.255.0 No No

 

Core# sh ip route

IP Route Entries

Destination Gateway VLAN Type Sub-Type Metric Dist.
------------------ --------------- ---- --------- ---------- ---------- -----
10.70.200.0/24 DEFAULT_VLAN 1 connected 1 0
10.70.201.0/24 VLAN100 100 connected 1 0
127.0.0.0/8 reject static 0 0
127.0.0.1/32 lo0 connected 1 0

 

The PC's

PC1 in port 1

IP : 10.70.200.101 - GW : 10.70.200.254 MASK : /24

PC2 in port 13

IP : 10.70.201.102 - GW : 10.70.201.12 MASK : /24

 

PC1 : internet ok, ping to pc2 is not ok

PC2 : internet not ok, ping to pc1 not ok

on pc2 also tried with GW : 10.70.200.254 (same result)

 

I can't understand. I think there is something ...... I don't see it.

 

Help please !!

THX

Anonymous
N/A

Re: Configure 2930f

Let's start to break this down. In your last example you mentioned PC2 couldn't ping PC1. This was done from 2930f in port 13 right? Can you ping VLAN100 and VLAN1 IP when PC2 is connected in this port 13?

Aruba Employee

Re: Configure 2930f

I'm sorry not sure but was logged in with my wrong username. Just checking your config again and see that you configured ip default-gateway. This command set-up routing for switch itself (for e.g. management) when ip routing is disabled. You need to configure static default route via ip route 0.0.0.0 0.0.0.0 x.x.x.x for the router itself. Hope this helps!!

Occasional Contributor II

Re: Configure 2930f

Hi

Yes that is possible. I can ping to the VLAN IP's

 

Delan009

Occasional Contributor II

Re: Configure 2930f

Hi Dobias

I already tried this. no ip routing and then ip rout 0.

0.0.0 0.0.0.0 10.70.200.254 (the default gateway)

That was'nt WORKING :-(

I have already did hard resets to factory ....

No result

Delan009

Aruba Employee

Re: Configure 2930f

Hi,

 

It's the other way around. Enable IP routing and than ip route 0.0.0.0 0.0.0.0 x.x.x.x to add static default. IP default gatway is used when ip routing is disabled for switch itself.

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: