Controllerless Networks

Reply
New Contributor
Posts: 4
Registered: ‎03-25-2015

Aruba IAP-215s and Avaya ERS 4800s

[ Edited ]

Hello everyone,

We are having problems setting up our IAP-215s on our new Avaya Ethernet Routing Switch 4800 switches. We have successfully configured Instant on the first IAP-215 we installed, but there seems to be a problem with the broadcast traffic when we try to connect another IAP-215 on the same switch. The second IAP-215 can't join the cluster and tries to initialize a master election on its own. We have tried the same scenario with our older Nortel switches and it worked instantly, so we are guessing there is a feature on the Avaya switches that needs to be enabled/disabled. We have checked for Storm Control and Rate Limiting features and they seem to be disabled on the Avaya switches.

Here are the logs I have gathered with the console port on the problematic IAP-215:

Image is signed; verifying checksum... passed

Signer Cert OK

Policy Cert OK

RSA signature verified.

[    0.000000] Flash variant: variant0

[    0.000000]

[    0.000000] Aruba Networks

[    0.000000] ArubaOS Version 6.4.2.0-4.1.1.0 (build 45444 / label #45444)

[    0.000000] Built by p4build@cartman on 2014-08-15 at 22:19:51 PDT (gcc version 4.5.1)

[    0.000000]

[    0.000000] P1010 RDB board from Freescale Semiconductor

[    0.000000] Memory: 246716k/262144k available (12184k kernel code, 15428k reserved, 504k data, 358k bss, 8792k init)

[    0.001491] Brought up 1 CPUs

[    0.077631] PCI: Probing PCI hardware

[    0.120682] pci 0000:00:00.0: PCI bridge to [bus 01-ff]

[    0.183587] pci 0001:02:00.0: PCI bridge to [bus 03-ff]

[    0.245811] pci 0000:00:00.0: not setting up bridge for bus 0000:01

[    0.320382] pci 0001:02:00.0: not setting up bridge for bus 0001:03

[    6.321852] fsl-ifc ffe1e000.ifc: Freescale Integrated Flash Controller

[    6.426686] Kprobe smoke test started

[    6.476615] Kprobe smoke test passed successfully

[    6.640211] ee000000.nor: Found 1 x16 devices at 0x0 in 16-bit bank

[    6.715313] Amd/Fujitsu Extended Query Table at 0x0040

[    6.776802] number of CFI chips: 1

[    6.821190] fsl-gianfar ethernet.2: enabled errata workarounds, flags: 0x4

[    6.903552] gfar_probe: Renaming interface to bond0

[    6.962314] /proc/gfar_bond0_stats created

[    7.024537] Enabling watchdog on CPU 0

[    7.073485] Disabled fips elf aesccm selftest

[    7.125647]

[    7.125651] Starting Kernel SHA1 KAT ...Completed Kernel SHA1 KAT

[    7.217403] Starting Kernel HMAC-SHA1 KAT ...Completed Kernel HMAC-SHA1 KAT

[    7.307237] Starting Kernel DES KAT ...Completed Kernel DES KAT

[    7.379191] Starting Kernel AES KAT ...Completed Kernel AES KAT

[    7.422986]

[    7.468849] Starting Kernel HMAC SHA1 FIPS KAT ...Completed Kernel HMAC SHA1 FIPS KAT

[    7.564132] Starting Kernel HMAC SHA256 FIPS KAT ...Completed Kernel HMAC SHA256 FIPS KAT

[    7.667387] Starting Kernel HMAC SHA384 FIPS KAT ...Completed Kernel HMAC SHA384 FIPS KAT

[    7.771623] Starting Kernel HMAC SHA512 FIPS KAT ...Completed Kernel HMAC SHA512 FIPS KAT

[    7.875849] Starting Kernel AES-CBC FIPS KAT ...Completed Kernel AES-CBC FIPS KAT

[    7.973324] Starting Kernel 3DES-CBC FIPS KAT ...Completed Kernel 3DES-CBC FIPS KAT

Domain Name: instant.arubanetworks.com

No panic info available

apfcutil: sector CACHE: Cache uninitialized

apfcutil: sector RAP: Cache uninitialized

apfcutil: sector FAT: Cache uninitialized

apfcutil: sector SCRATCH: Cache uninitialized

Check backup ENV.

apfcutil: sector MESH Prov: Cache uninitialized

Cfg len is 0

Configuration file is empty, turning on default services...

extended ssid activate due to no AP config ...

[   16.778024] ADDRCONF(NETDEV_UP): bond0: link is not ready

Ethernet uplink not active yet

[   22.793903] PHY: bond0 (mdio@ffe24000:00) - Link is Up - 1000/Full

[   22.868399] ADDRCONF(NETDEV_CHANGE): bond0: link becomes ready

Mesh is DISABLED on this device.

[   23.149580] AP xml model 84, num_radios 2 (jiffies 11402)

[   23.214200] init_asap_mod: installation:0

[   23.262185] radio 0: band 1 ant 0 max_ssid 16

[   23.314311] radio 1: band 0 ant 0 max_ssid 16

[   23.366437] election init: rand=17 HZ=500

[   23.414379] IAP client match init

notify asap_mod 3g no present...

Starting watchdog process...

Getting an IP address...

Dec 31 16:00:23 udhcpc[2009]: udhcpc (v0.9.9-pre) started

Dec 31 16:00:23 udhcpc[2009]: send_discover: pkt num 0, secs 0

Dec 31 16:00:23 udhcpc[2009]: Sending discover...

Dec 31 16:00:25 udhcpc[2009]: send_discover: pkt num 1, secs 2

Dec 31 16:00:25 udhcpc[2009]: Sending discover...

Dec 31 16:00:27 udhcpc[2009]: send_discover: pkt num 2, secs 4

Dec 31 16:00:27 udhcpc[2009]: Sending discover...

[   29.021517] Enabling USB power

Dec 31 16:00:29 udhcpc[2009]: No lease, forking to background.

Dec 31 16:00:49 udhcpc[2114]: send_discover: pkt num 0, secs 26

Dec 31 16:00:49 udhcpc[2114]: Sending discover...

Dec 31 16:00:51 udhcpc[2114]: send_discover: pkt num 1, secs 28

Dec 31 16:00:51 udhcpc[2114]: Sending discover...

Dec 31 16:00:53 udhcpc[2114]: send_discover: pkt num 2, secs 30

Dec 31 16:00:53 udhcpc[2114]: Sending discover...

Dec 31 16:00:53 udhcpc[2114]: send_selecting: pkt num 0, secs 30

Dec 31 16:00:53 udhcpc[2114]: Sending select for 10.3.0.101...

Dec 31 16:00:53 udhcpc[2114]: Lease of 10.3.0.101 obtained, lease time 691200

Dec 31 16:00:53 udhcpc[2114]: DHCP OPT 60 is not ArubaAP

 

Dec 31 16:00:53 udhcpc[2114]: DHCP OPT 60 is ArubaInstantAP

 

Dec 31 16:00:53 udhcpc[2114]: DHCP OPT 43, len: 44, buf: AP_Administration,10.2.0.154,***********

 

Dec 31 16:00:53 udhcpc[2114]: ams-ip: 10.2.0.154, ams-key:**************

 

[   54.477344] ip_time_handler: Got ip and packets on bond0 Started master election 25-0, rand 22

10.3.0.101 255.255.252.0 10.3.0.1

Compressing all files in the /etc/httpd directory...

[   55.312109] Adding bridge entry for magic vlan GW, ifindex 8450, ac:a3:1e:c5:93:ee

[   55.402784] (00:00:55) !!! Init ---> Slave

Done.

Starting Webserver

bind: Transport endpoint is not connected

bind: Transport endpoint is not connected

bind: Transport endpoint is not connected

Launching NTP Client on pool.ntp.org

[   58.839617] wifi0: AP type AP-215, radio 0, max_bssids 16

[   58.947489] wifi1: AP type AP-215, radio 1, max_bssids 16

shutting down watchdog process (nanny will restart it)...

Completed SW FIPS KAT test

 

        <<<<<       Welcome to the Access Point     >>>>>

 

User: [   89.329869] asap_send_elected_master: sent successfully

[   89.409582] wait for stm to initialize over

[   89.459635] asap_send_elected_master: sent successfully

[   89.542672] process `snmpd_sap' is using obsolete setsockopt SO_BSDCOMPAT

Has anyone tried this combination of Avaya ERS 4800 switches and Aruba IAPs?

Many thanks for your help.

Valued Contributor II
Posts: 804
Registered: ‎12-01-2014

Re: Aruba IAP-215s and Avaya ERS 4800s

HI,

 

Please ensure that both the IAPs are in the same VLAN and master beacons are allowed that VLAN. BTW if you can share the console output we  can understand what is happening between IAPs

and also go through the output of "show election statistics" will give idea whether both are able to exchange beacons or not.

Cheers,
Venu Puduchery,
[Is my post helped you ? Give Kudos :) ]
New Contributor
Posts: 4
Registered: ‎03-25-2015

Re: Aruba IAP-215s and Avaya ERS 4800s

Hi,

 

Thank you very much for your help. We ended up figuring it out by ourselves:  A Virtual Controller VLAN was defined in System > General, and when we removed it the problem was solved. Though it was the correct VLAN for the Virtual Controller, it didn't seem to play nice with Avaya ERS 4800 switches.

 

In case anyone wants more information, we configured the ports on the switch to be trunked with the VLANs we use for our WiFi along with the parameter "UntagDefaultPVID" which I believe is the equivalent of the "native vlan" concept for Cisco switches.

 

Best regards.

Search Airheads
Showing results for 
Search instead for 
Did you mean: