Controllerless Networks

Reply
New Contributor
Posts: 1
Registered: ‎09-22-2014

Instant APs not being seen by controller

We had a power outage last week. Somehow it message with the Aruba PoE switch we had, and most likely the wireless controller as well. We performed several troubleshooting tasks, but eventually just had to wipe out the conifguration on the switch. Another tech rebuilt the configuration and we now have Internet access if you are plugged in with a cable. However, the Aruba 105 IAPs are not broadcasting SSIDs now and the controller can't find them. I am sure it has something to do with the fact that the switch the controller is connected to has been re-configured, but it should have almost identitical properties as before (same VLANs, etc.). 

 

Here's what I have:

Aruba S3500-24P PoE switch

Aruba 650 wireless controller. 

 

The address of the controller from the documentation I have is 10.116.0.5. I cannot ping that even if I am connected directly to the ports on the controller. When I am plugged in with a UTP cable, I get a DHCP IP address of 10.116.13.XXX, so I know there is communication happening between the controller and the switch somehow. The IAPs are also showing IP addresses on the same network. The only way to access the web interface of the controller is to set a static IP address on the same network (10.116.0.XX). 

 

I am very new to Aruba products, but it feels somewhat similar to Cisco, so I can feel my way around a little bit. 

 

Anyway, I plugged into an AP's console port and here is the output (Any names with XXX... is to provide at least some anonymity to the network):

 

APBoot 1.0.9.12 (build 22797)

Built: 2009-11-04 at 15:53:54

 

Model: AP-10x

CPU:   AR7161 revision: A2

Clock: 680 MHz, DDR clock: 340 MHz, Bus clock: 170 MHz

DRAM:  128 MB

POST1: passed

Copy:  done

Flash: 16 MB

PCI:   scanning bus 0 ...

       dev fn venID devID class  rev    MBAR0    MBAR1    MBAR2    MBAR3

       00  00  168c  0029 00002   01 10000000 00000000 00000000 00000000

       01  00  168c  0029 00002   01 10010000 00000000 00000000 00000000

Net:   eth0

Radio: ar922x#0, ar922x#1

 

Hit <Enter> to stop autoboot:  0

Checking image @ 0xbf100000

 

Image is signed; verifying checksum... passed

Signer Cert OK

Policy Cert OK

RSA signature verified.

ELF file is 32 bit

Loading .text @ 0x80e00000 (3768408 bytes)

Loading .data @ 0x81198060 (32 bytes)

Clearing .bss @ 0x81198080 (16 bytes)

## Starting application at 0x80e00000 ...

Uncompressing...................................

ú

Aruba Networks

ArubaOS Version 6.1.3.4-AirGroup (build 35647 / label #35647)

Built by p4build@stan on 2012-10-08 at 12:50:26 PDT (gcc version 4.3.3)

CPU Rev: aa

71x CPU

Flash variant: default

Cache parity protection disabled

Using 340.000 MHz high precision timer. cycles_per_jiffy=680000

Memory: 122880k/131072k available (1850k kernel code, 8088k reserved, 681k data, 2952k init, 0k highmem)

detected lzma initramfs

initramfs: LZMA lc=3,lp=0,pb=2,dictSize=8388608,origSize=12341760

LZMA initramfs by Ming-Ching Tiew <mctiew@yahoo.com> .............................................................................................................................................................................................

AR7100 GPIOC major 0

wdt: registered with refresh

Enabling Watchdog

Talisker RSSI LED initialization

Creating 1 MTD partitions on "ar7100-nor0":

0x00000000-0x01000000 : "flash"

i2c /dev entries driver

i2c-talisker: using default base 0x18040000

AD7416 driver probing for devices on AR7100 I2C

.<6>lo: Disabled Privacy Extensions

IPv6 over IPv4 tunneling driver

 

Starting Kernel SHA1 KAT ...Completed Kernel SHA1 KAT

Starting Kernel HMAC-SHA1 KAT ...Completed Kernel HMAC-SHA1 KAT

Starting Kernel DES KAT ...Completed Kernel DES KAT

Starting Kernel AES KAT ...Completed Kernel AES KAT

 

Domain Name: arubanetworks.com

No panic info available

Testing TPM... Passed

ag7100_mod: module license 'unspecified' taints kernel.

AG7100: Length per segment 512

AG7100: Max segments per packet 4

AG7100: Max tx descriptor count    400

AG7100: Max rx descriptor count    252

AG7100: fifo cfg 3 018001ff

AG7100CHH: Mac address for unit 0

AG7100CHH: d8:c7:c8:c2:69:1a

ATHRF1: Port 0, Neg Success

ATHRF1: unit 0 phy addr 0 ATHRF1: reg0 0

AP xml model 39, num_radios 2 (jiffies 4153)

init_asap_mod: installation:0

radio 0: band 1 ant 0 max_ssid 8

radio 1: band 0 ant 0 max_ssid 8

setting bond0 as bridge child

setting gre0 as split child

Starting watchdog process...

Getting an IP address...

ag7100_ring_alloc Allocated 4800 at 0x813b0000

ag7100_ring_alloc Allocated 3024 at 0x813a6000

AG7100: cfg1 0xf cfg2 0x7014

ATHRF1: Port 0, Neg Success

ATHRF1: unit 0 phy addr 0 ATHRF1: reg0 3100

AG7100: unit 0: phy not up carrier 1

Writing 4

ADDRCONF(NETDEV_UP): bond0: link is not ready

AG7100: unit 0 phy is up...RGMii 1000Mbps full duplex

AG7100: pll reg 0x18050010: 0x110000  AG7100: cfg_1: 0x1ff0000

AG7100: cfg_2: 0x3ff

AG7100: cfg_3: 0x18001ff

AG7100: cfg_4: 0xffff

AG7100: cfg_5: 0xfffef

AG7100: done cfg2 0x7215 ifctl 0x0 miictrl 0x22

ADDRCONF(NETDEV_CHANGE): bond0: link becomes ready

10.116.13.7 255.255.248.0 10.116.8.1

Running ADP...cat: /tmp/master: No such file or directory

Done. Master is

killall: nanny: no process killed

killall: sapd: no process killed

Sending SIGKILL to all processes.

Please stand by while rebooting the system.

___________________________________________________________________

 

Here are some lines from the "Show run..." command on the controller:

 

vlan range 2 wired aaa-profile "XXXX-aaa_prof"
vlan 3 wired aaa-profile "XXXX-WEP-aaa_prof"
vlan 4 wired aaa-profile "XXXXGuest-aaa_prof"

vlan-name XXXX-Trusted pool
vlan XXXX-Trusted 2-3
vlan-name XXXX-Untrusted pool
vlan XXXX-Untrusted 4


interface gigabitethernet 1/0
description "GE1/0"
trusted
trusted vlan 1-4094
!

interface gigabitethernet 1/1
description "GE1/1"
trusted
trusted vlan 1-4094
!

interface gigabitethernet 1/2
description "GE1/2"
trusted
trusted vlan 1-4094
!

interface gigabitethernet 1/3
description "GE1/3"
trusted
trusted vlan 1-4094
!

interface gigabitethernet 1/4
description "GE1/4"
trusted
trusted vlan 1-4094
!

interface gigabitethernet 1/5
description "GE1/5"
trusted
trusted vlan 1-4094
switchport mode trunk
!

interface gigabitethernet 1/6
description "GE1/6"
trusted
trusted vlan 1-4094
!

interface gigabitethernet 1/7
description "GE1/7"
trusted
trusted vlan 1-4094
!

interface vlan 1
ip address 10.116.0.5 255.255.255.0
!

ip default-gateway 10.116.8.1
no uplink wired vlan 1
uplink disable

 

ip dhcp excluded-address 192.168.99.1 192.168.99.10
ip dhcp excluded-address 192.168.98.1 192.168.98.10
ip dhcp excluded-address 192.168.97.1 192.168.97.10
ip dhcp excluded-address 192.168.96.1 192.168.96.10
ip dhcp excluded-address 192.168.96.253 192.168.96.254
ip dhcp pool DHCP-999
default-router 192.168.99.1
dns-server 10.116.12.41 10.116.12.49
domain-name XXXXXXX
lease 0 8 0 0
network 192.168.99.0 255.255.255.0
authoritative
!
ip dhcp pool DHCP-998
default-router 192.168.98.1
dns-server 10.116.12.41 10.116.12.49
domain-name XXXXXXX
lease 0 8 0 0
network 192.168.98.0 255.255.255.0
authoritative
!
ip dhcp pool DHCP-997
default-router 192.168.97.1
dns-server 4.2.2.1 4.2.2.2
lease 0 4 0 0
network 192.168.97.0 255.255.255.0
authoritative
!
ip dhcp pool DHCP-996
default-router 192.168.96.1
dns-server 4.2.2.1 4.2.2.2
lease 0 4 0 0
network 192.168.96.0 255.255.255.0
authoritative
!
service dhcp

____________________________________________________________________

 

Now from the switch:

 

ip-profile
default-gateway 10.115.0.161
controller-ip vlan 1
!
lcd-menu
!
interface-profile ospf-profile "default"
area 0.0.0.0
!
interface-profile pim-profile "default"
!
interface-profile igmp-profile "default"
!
stack-profile
!
ipv6-profile
!
interface-profile switching-profile "default"
!
interface-profile switching-profile "XXXXUpstream"
access-vlan 6
native-vlan 6
!
interface-profile switching-profile "Trunk"
switchport-mode trunk
access-vlan 10
native-vlan 10
!
interface-profile switching-profile "Upstream-profile"
access-vlan 10
native-vlan 10
!
interface-profile switching-profile "VLAN10"
access-vlan 10
native-vlan 10
!
interface-profile poe-profile "default"
!
interface-profile poe-profile "poe-factory-initial"
enable
!
interface-profile enet-link-profile "default"
!
interface-profile lldp-profile "default"
!
interface-profile lldp-profile "lldp-factory-initial"
lldp transmit
lldp receive
med enable
!
interface-profile mstp-profile "default"
!
interface-profile pvst-port-profile "default"
!
vlan-profile mld-snooping-profile "default"
!
vlan-profile igmp-snooping-profile "default"
!
vlan-profile igmp-snooping-profile "igmp-snooping-factory-initial"
!
spanning-tree
mode mstp
!
gvrp
!
mstp
!
lacp
!
vlan "1"
igmp-snooping-profile "igmp-snooping-factory-initial"
!
vlan "6"
description "VLAN0006"
!
vlan "10"
description "VLAN0010"
!
vlan "20"
description "VLAN0020"
!
interface gigabitethernet "0/0/0"
switching-profile "XXXXUpstream"
!
interface gigabitethernet "0/0/1"
switching-profile "Trunk"
!
interface gigabitethernet "0/0/2"
switching-profile "VLAN10"
!
interface gigabitethernet "0/0/3"
switching-profile "VLAN10"
!
interface gigabitethernet "0/0/4"
switching-profile "VLAN10"
!
interface gigabitethernet "0/0/5"
switching-profile "VLAN10"
!
interface gigabitethernet "0/0/6"
switching-profile "VLAN10"
!
interface gigabitethernet "0/0/7"
switching-profile "VLAN10"
!
interface gigabitethernet "0/0/8"
switching-profile "VLAN10"
!
interface gigabitethernet "0/0/9"
switching-profile "VLAN10"
!
interface gigabitethernet "0/0/10"
switching-profile "VLAN10"
!
interface gigabitethernet "0/0/11"
switching-profile "VLAN10"
!
interface gigabitethernet "0/0/12"
switching-profile "VLAN10"
!
interface gigabitethernet "0/0/13"
switching-profile "VLAN10"
!
interface gigabitethernet "0/0/14"
switching-profile "VLAN10"
!
interface gigabitethernet "0/0/15"
switching-profile "VLAN10"
!
interface gigabitethernet "0/0/16"
switching-profile "VLAN10"
!
interface gigabitethernet "0/0/17"
switching-profile "VLAN10"
!
interface gigabitethernet "0/0/18"
switching-profile "VLAN10"
!
interface gigabitethernet "0/0/19"
switching-profile "VLAN10"
!
interface gigabitethernet "0/0/20"
switching-profile "VLAN10"
!
interface gigabitethernet "0/0/21"
switching-profile "VLAN10"
!
interface gigabitethernet "0/0/22"
switching-profile "VLAN10"
!
interface gigabitethernet "0/0/23"
switching-profile "VLAN10"
!
interface vlan "1"
ip address 10.116.0.1 255.255.255.0
!
interface vlan "10"
ip address 10.116.8.1 255.255.248.0
!
interface vlan "20"
ip address 10.116.16.1 255.255.248.0
!
interface vlan "6"
ip address 10.115.0.162 255.255.255.252
!
interface mgmt
!
interface-group gigabitethernet "default"
apply-to ALL
lldp-profile "lldp-factory-initial"
poe-profile "poe-factory-initial"

_______________________________________________________________________

 

Hopefully there is some useful information in there. Any ideas to help get me started?

Guru Elite
Posts: 21,489
Registered: ‎03-29-2007

Re: Instant APs not being seen by controller

TAC is probably your best bet, because they can troubleshoot this live.  There is information missing that TAC can probably obtain on a call to determine what is wrong here.

 



Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

Search Airheads
Showing results for 
Search instead for 
Did you mean: