Controllerless Networks

Reply
New Contributor

how the heck should i set this up? Cisco Catalyst 3750x, Aruba IAP-225's, 3 SSID

i will be blunt, how should i set this up? i mean nothing fancy but just get it working..

setup. 

6 Aruba IAP-225's all updated to the latest firmware.

Cisco Catalyst 3750 

CPPM (will take care of this later)

3 SSID ( Internal only Employees), (External only for guest), and one for managers who have all access and point them to existing DHCP server.

 

i already have the IAPs setup working with a virtual controller on the cisco switch.

LACP ether/port channels to each iap because of the dual connections.

these are VLAN 40, 192.168.40.x

switchport mode access

 

I know how to create the SSID's and have. How do i go about making sure those SSID get on the correct vlans? Internal is Vlan 50 192.168.50.x, External is Vlan 51 192.168.51.x, Management is vlan 53 192.168.53.x (these are trunk vlans)

Do i need to make them the dot1q encapsulation??

do i associate those vlans with the port groups?

Is there a way for those vlans to see the existing dhcp server with scopes for those ip ranges i have already created? (this is with ip helper address in the vlan correct??)

 

Sorry if this is a lot but i have not done networking in a long time and not done enterprise grade wireless ever. Got stuck on this project and i need some major major help

 

Re: how the heck should i set this up? Cisco Catalyst 3750x, Aruba IAP-225's, 3 SSID

it is quite easy, you just put all those VLANs on the port-channel (which should be in trunk mode) towards the IAP.

 

on the IAP (which is default in trunk mode) you then assign the client to the correct VLAN on your SSID config tab 2) VLAN, network assigned, static, VLAN number.

 

then it works as if your clients are in that VLAN.

 

Do i need to make them the dot1q encapsulation??

  yes, on the cisco switch you do, on the IAP nothing is needed

do i associate those vlans with the port groups?

  yes, you set the port channel to turnk mode with allowed VLANs all or the ones you want, the native VLAN is for the management IP of the IAP

Is there a way for those vlans to see the existing dhcp server with scopes for those ip ranges i have already created? (this is with ip helper address in the vlan correct??)

  that will be the default, you dont need to do anything. the IAP just "puts" the client in the VLAN asif it was there via a wire.

 

if it doesnt work i would start simple and not work with the port-channel and don't try to restrict VLANs towards the IAP. start broad, get it working and then add the more complex stuf.

Re: how the heck should i set this up? Cisco Catalyst 3750x, Aruba IAP-225's, 3 SSID

Aruba has a free training on how to setup Instants:
http://cloud.arubanetworks.com/instant-training
Thank you

Victor Fabian
Lead Mobility Engineer @ Integration Partners
AMFX | ACMX | ACDX | ACCX | CWAP | CWDP | CWNA
New Contributor

Re: how the heck should i set this up? Cisco Catalyst 3750x, Aruba IAP-225's, 3 SSID

I think i got the aruba side with the with the SSIDs and the numbering of the vlans just fine.

 

could you give me a quick example of what i should see in the switch side?

the ports for the port channels

 

currently the port channel are default to what they were when they were created and to put dot1q you need to put them in truck mode correct?

then associate those port channels with the vlan correct?''

should it be something like this?

 

Interface port channel xxxx

switchport mode trunk

switchport trunk encapsulation dot1q

switchport trunk native vlan 40

switchport trunk allowed vlan 50,51,53

 

is that what i need to do on the port channels or on both the port channels and the interfaces?

Vlan 40 is an access vlan right now because its just a "management" vlan.

 

Anything else i should be doing?

Re: how the heck should i set this up? Cisco Catalyst 3750x, Aruba IAP-225's, 3 SSID

Try this:
interface Port-channel1
description LACP
switchport trunk encapsulation dot1q
Switchport mode trunk
Switchport trunk native Vlan 40
Switchport trunk allowed VLAN 40,50,51,53

interface GigabitEthernet0/2
switchport trunk encapsulation dot1q
Switchport mode trunk
Switchport trunk native Vlan 40
Switchport trunk allowed VLAN 40,50,51,53
channel-group 1 mode active

interface GigabitEthernet0/1
switchport trunk encapsulation dot1q
Switchport mode trunk
Switchport trunk native Vlan 40
Switchport trunk allowed VLAN 40,50,51,53
channel-group 1 mode active
Thank you

Victor Fabian
Lead Mobility Engineer @ Integration Partners
AMFX | ACMX | ACDX | ACCX | CWAP | CWDP | CWNA
New Contributor

Re: how the heck should i set this up? Cisco Catalyst 3750x, Aruba IAP-225's, 3 SSID

Thanks to both of you.

 

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: