Reply
Occasional Contributor I
Posts: 7
Registered: ‎05-04-2017

ALE and unassociated clients

Is there any reason why an ALE (running in estimated mode with Airwave) has the graph on the monitoring page showing the number of UNASSOCIATED CLIENTS at zero but the ASSOCIATED CLIENT is showing an expected number??

 

I have two ALE servers with two local controllers connected to each, both ALE are importing maps from the same Airwave but one of the ALE servers refuses to show any activity on the UNASSOCIATED USERS graph, whilst the other one does.

 

ALE is version 2.0.0.10

Aruba Employee
Posts: 436
Registered: ‎02-19-2015

Re: ALE and unassociated clients

Mike,

 

Could you please share the screen shots from both the ALE servers?

 

Regards,

Pavan

Occasional Contributor I
Posts: 7
Registered: ‎05-04-2017

Re: ALE and unassociated clients

Apart from the monitoring page. Is there any other page or logs??
Occasional Contributor I
Posts: 7
Registered: ‎05-04-2017

Re: ALE and unassociated clients

ALE02ALE01

Aruba Employee
Posts: 436
Registered: ‎02-19-2015

Re: ALE and unassociated clients

Hi Mike,

 

Are you able to generate PDB file on the ALE server which is not displaying unassociated clients information in dashlet from maintainence tab?

 

If PDB generation is deferred or fails, ALE cannot calculate device location. Campus, Building, Floor, Location, and Geo_Fence APIs are not published, and the unassociated clients dashlet may not show any data.

 

Have you enabled RTLS option on this server ,if YES try disable and generated PDB.

 

Regards

Pavan

 

Occasional Contributor I
Posts: 7
Registered: ‎05-04-2017

Re: ALE and unassociated clients

Pavan
I regenerated the PDB this morning and it completed successfully.
I am getting plenty of location events from that server but that graph never displays it yet on the other ALE it is. The only difference between the servers are the controllers that are talking to it. Could it be something on the controllers??
Occasional Contributor I
Posts: 7
Registered: ‎05-04-2017

Re: ALE and unassociated clients

I should also add I can see presence events
In the feed reader that has the client status as I UNASSOCIATED but the graph never shows them.
Bizzare.
Aruba Employee
Posts: 436
Registered: ‎02-19-2015

Re: ALE and unassociated clients

In location/persistance log are you seeing client association status as true or false?

 

Regards,

Pavan

Aruba Employee
Posts: 436
Registered: ‎02-19-2015

Re: ALE and unassociated clients

We could also use Location API/ Presence API and see in output whether we are seeing the association status as false for any client.

 

False status means client is unassociated.

 

Presence API queries use the following URL syntax:
https://<IP address>/api/v1/presence

 

Location API queries use the following URL syntax:
https://<IP address>/api/v1/location?sta_eth_mac=AA:BB:CC:DD:EE:FF

 

If we have unassociated clients but still not showing graphs try restart the location engine and check the status.

 

Does anonymization is enabled on this server, if Yes try disable it and check once.

 

We have bug in older version where when we enable anonymization unassoicated client count graph showing incorrect, it is fixed in latest code 2.0.0.12.

 

Bug 49413 Symptom: The unassociated client count increased continuously when anonymization was enabled, as ALE failed to clear old client records from the database.Scenario: This occurred in ALE 2.0.0.11 and earlier.

 

Regards,

Pavan

Occasional Contributor I
Posts: 7
Registered: ‎05-04-2017

Re: ALE and unassociated clients

Hi Pavan

 

I have noticed the clock is way out. What is the command line format to set the clock (I will need to get a change control raise to allow ntp going forward)

 

Cheers

Mike

Search Airheads
Showing results for 
Search instead for 
Did you mean: