Network Management

Reply
Occasional Contributor I
Posts: 5
Registered: ‎05-11-2010

Airwave 7.7.3 Error Fetching Config

I hope someone out here can help me.  I am doing a demo of Airwave and currently have all Cisco AP's Deployed.  I am trying to add the AP's so that we can see what we can get information wise from our Cisco devices.

 

The problem I am encountering is that I have several AP's that when they are contacted by Airwave in an attempt to pull the configs Airwave gives the following error:

 

Configuration: Error (Telnet/SSH Error: prompt after telnet password: Warning: Permanently added '172.26.238.25' (RSA) to the list of known hosts. )

 


Now SMNP ststus works fine and I have about 10 other AP's that are reporting back fine.  They are all set to use the same Credentials and I have verified the credentials work by SSH'ing to the devices and logging in with them.

 

Has anyone seen this before?

Aruba
Posts: 349
Registered: ‎04-14-2009

Re: Airwave 7.7.3 Error Fetching Config

That message means that we sshed in, but after we submitted the password we didn't get the prompt that we expected.  I can think of 3 causes of this:

 

1. Username/password are wrong (it might be worthhwile to re-enter them in case there was a space entered that you can't see)

2. User doesn't have sufficient privilges

3. The device name includes special characters that confuse us.  For example, if a Cisco device is named AP#2, the prompt would look something like this:

 

AP#2 #

 

Names like that have cause problems for us in the past.

Occasional Contributor I
Posts: 5
Registered: ‎05-11-2010

Re: Airwave 7.7.3 Error Fetching Config

Thanks for the prompt response.  I have in fact retyped credentials several times to no avail.  As I said the other ones work fine.  There is one thing to note. 

 

Yesterday I removed them from AMP, re-added them, on of the devices was actually able to fetch the config.  Two others were not.  Then this morning I came in and now the first one is reading the error.

 

I guess the other thing to note is that these devices are 250 ms away from the server.  I increased the timeouts accordingly but the error keeps coming back.  These devices response when logging in is as follows:

 

INHYD-AP02>en
Password:
INHYD-AP02#

 

All other AP's in the environment follow the same standards.

Aruba
Posts: 1,368
Registered: ‎12-12-2011

Re: Airwave 7.7.3 Error Fetching Config

Shot in the dark BUT...can you ssh as root to the Airwave server and then from that prompt ssh to the APs giving you heartache?  Make sure you can get in THEN exit out and retry adding the APs in the GUI.

 

Post any errors you receive please.  

 

Also, in the device audit page on Airwave, there is a View Telnet/SSH Command log...can you please post that if it's there?

 

Screen Shot 2013-08-27 at 8.04.54 PM.png

Seth R. Fiermonti
Consulting Systems Engineer - ACCX, ACDX, ACMX
Email: seth@hpe.com
-----
If you found my post helpful, please give kudos
Aruba
Posts: 349
Registered: ‎04-14-2009

Re: Airwave 7.7.3 Error Fetching Config

Seth's idea is a good one.  I've got another idea in case his suggestion doesn't lead to the answer.  By default, we only log stuff from an ssh session after we've logged in.  But it's possible to log the authentication process too.  To enable that, do this from the AMP cli:

 

# dbc "update seas_config set debug_telnet = 1"

 

Then try an audit of that AP again.  Each whole session will be logged in /tmp/telnet_dumps/.  It might be useful to compare a log file from a working AP against a not-working one.

 

Oh, and these log files will include your passwords, so be careful with them.

 

Dan

Occasional Contributor I
Posts: 5
Registered: ‎05-11-2010

Re: Airwave 7.7.3 Error Fetching Config

Seth thanks for the info.  I did SSH from the cli and did get the prompt.  I answered yes and for two of the devices the problem is resolved.  For some reason the 3rd one is still getting the error.  Really odd.  I did save it to the known hosts but it is still not happy.

 

The authenticity of host '172.26.238.27 (172.26.238.27)' can't be established.
RSA key fingerprint is 90:24:0d:fb:5b:36:5a:fe:88:b6:96:63:bf:a1:af:7c.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added '172.26.238.27' (RSA) to the list of known hosts.
Password:
Password:

 

So I may delete it and try again.

 

I appreciate all the help!

Aruba
Posts: 1,368
Registered: ‎12-12-2011

Re: Airwave 7.7.3 Error Fetching Config

Now the question is why this was needed. Hmmmm

Seth Fiermonti
781-632-6052
Sent from my iPhone
Seth R. Fiermonti
Consulting Systems Engineer - ACCX, ACDX, ACMX
Email: seth@hpe.com
-----
If you found my post helpful, please give kudos
Search Airheads
Showing results for 
Search instead for 
Did you mean: