Security

Reply
Contributor I
Posts: 27
Registered: ‎09-10-2013

Acceptable use policy page not displaying.

Hi

I am having an issue getting the Acceptable Use Policy to display from the link on the Captive Portal Authentication login page.  The pop-up window is blank.

 

Also if I select the checkbox 'Show the acceptable use policy page' on my GuestProfile in the Captive
Portal Authentication Profile configuraiton page the webpage only displays "User Agreement Policy" and an Accept button.

 

I am sure this is a simple settings that I am missing.

 

I have uploaded my AUP text within Management > Captive Portal > Customize Login Page and also Security > Access Control > Customize Guest Access Page.

 

Any help is appreciated. 

 

Thanks

Aruba
Posts: 1,548
Registered: ‎06-12-2012

Re: Acceptable use policy page not displaying.

A couple things

 

1. To just change the AUP you can upload a html file to the contentmanager and change the link on the Guest setup page

 

screenshot_02 Oct. 04 00.37.gif

 

2. or you can embed the lanuage into the page and just disble the check box and just change the wording on the button to say Login/accept terms

 

 

3. or you can embed a code sniplet to add a checkbox and your terms.

 

iFrame Expanded (see picture example)

 

  • Upload your terms file (html? txt? Etc.) in content manager
  • On the "Guest Manager" page, update the URL (e.g. public/terms.html if you uploaded terms.html)
  • Under Guest Self-Reg -> Choose your Guest Self-Reg -> Edit -> Diagram: "Forms"
  • Replace "creator_accept_terms" or "visitor_accept_terms" HTML with:
{if $_wpl.browser.small_screen}
I accept the <a href="{nwa_global name=guest_account_terms_of_use_url}" target="_blank" />terms of use:</a><br>
{else}
I accept the terms of use:<br />
<iframe src="{nwa_global name=guest_account_terms_of_use_url}" width="290" height="100" style="margin-bottom: 4px; margin-top: 4px;" /></iframe><br>
{/if}
 

 

Guest-terms-iframe-example.png

Thank You,
Troy

--Give Kudos: found something helpful, important, or cool? Click Kudos Star in a post.

--Problem Solved? Click "Accepted Solution" in a post.
Aruba
Posts: 1,548
Registered: ‎06-12-2012

Re: Acceptable use policy page not displaying.

Attached is a sample T & C

Thank You,
Troy

--Give Kudos: found something helpful, important, or cool? Click Kudos Star in a post.

--Problem Solved? Click "Accepted Solution" in a post.
Aruba
Posts: 1,548
Registered: ‎06-12-2012

Re: Acceptable use policy page not displaying.

Sorry I should ask is this on CPPM or the controller
Thank You,
Troy

--Give Kudos: found something helpful, important, or cool? Click Kudos Star in a post.

--Problem Solved? Click "Accepted Solution" in a post.
Contributor I
Posts: 27
Registered: ‎09-10-2013

Re: Acceptable use policy page not displaying.

Sorry I should have said this is on a Controller 3400. The settings do look different.

Contributor I
Posts: 27
Registered: ‎09-10-2013

Re: Acceptable use policy page not displaying.

Also thank you for the policy, it's very good.

 

I found my mistake regarding the Show the acceptable use policy page not displaying,  I didn't have my guest profile selected when uploading.

 

However I am at a loss how to get the Acceptable Use Policy hyperlink to display anything beside a blank pop-up page??

Guru Elite
Posts: 21,499
Registered: ‎03-29-2007

Re: Acceptable use policy page not displaying.

Are you using plaintext (which should work) or HTML.?



Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

Contributor I
Posts: 27
Registered: ‎09-10-2013

Re: Acceptable use policy page not displaying.

Hi, I am using HTML format, this is the format requested. I have just copied the same content from the user acceptance policy which is ok now.

 

I will try plain text just incase.

Search Airheads
Showing results for 
Search instead for 
Did you mean: