Security

Reply
Occasional Contributor II
Posts: 14
Registered: ‎11-27-2012

Certificate Not Trusted - Captive Portal

Hi there,

 

Picked up a certificate (Instant SSL type) from Geotrust, placed it on the controller for both the WEB UI and the captive portal.

 

Problem shows up though I was hoping to avoid....when clients (iPads, computers etc) go to the captive portal screen, they get a certificate error as "Not Trusted".  I am sure I am missing something simple...but is there a way to get around that?

 

Thanks...

 

Grant

 

Guru Elite
Posts: 20,822
Registered: ‎03-29-2007

Re: Certificate Not Trusted - Captive Portal

Does it show the certificate you purchased in those browsers?  Is it redirecting to the fqdn of the certificate you purchased?



Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

Occasional Contributor II
Posts: 14
Registered: ‎11-27-2012

When I connect to the "Guest" network, the response from...

When I connect to the "Guest" network, the response from the captive portal redirection is "sluggish"...take much longer to appear than when I have the default certificate assigned.

 

Then, when in comes up (in this case Firefox), I get the following:

 

The controller has the DNS entry of "aruba-master".  Note...it WAS called arubamaster previously, and though I have changed the name on the controller, I have NOT restarted the controller since the name change....not sure if that has any relevance.

 

Grant

 

Capture.JPG

Aruba Employee
Posts: 148
Registered: ‎11-25-2009

Re: When I connect to the "Guest" network, the response from...

do you have the trusted CA cert on the client machine. 

 

the cert presented by the controller should be validated by the trusted ca. 

Vinod Kumaar AVM ACMX, ACDX
Principal Network Engineer
Customer Advocacy | Aruba Networks Inc.

Did something you read in the Community solve a problem for you? If so, click "Accept as Solution" in the bottom right hand corner of the post.
Occasional Contributor II
Posts: 14
Registered: ‎11-27-2012

Re: When I connect to the "Guest" network, the response from...

I have not manually installed any certicate....being a large certificate provider, I assumed it would be "accepted".

 

But what is weird is that when I connect to the Aruba WEB UI, which I have ALSO configured to use the certificate, it works just fine....I get the "green" lock.

 

But the same certificate on the captive portal setup sets off the error.  I may just be missing something really simple (I am not a certificate "expert" by any means), but I assume if it works on the WEB UI, it would work on the captive portal too...

 

Grant

 

Aruba Employee
Posts: 148
Registered: ‎11-25-2009

Re: When I connect to the "Guest" network, the response from...

Check the show web-server output to see if the switch-cert and the cp-cert are mapped to the same certificate. Error in the browser is more like the browser is not able to validate the issuer of the cert. 

 

 

following link might also help you. 

 

http://support.mozilla.org/en-US/questions/927097

Vinod Kumaar AVM ACMX, ACDX
Principal Network Engineer
Customer Advocacy | Aruba Networks Inc.

Did something you read in the Community solve a problem for you? If so, click "Accept as Solution" in the bottom right hand corner of the post.
Search Airheads
Showing results for 
Search instead for 
Did you mean: