Security

Reply
Regular Contributor I
Posts: 279
Registered: ‎02-11-2013

Problem with special type in SMS

Hi,

 

I have a problem with the SMS service in ClearPass. I would like to send a SMS with usernames that contain a "+" (usernames are phonenumbers). The issue is that the "+" is deleted from the SMS. It's not coming from my SMS provider (I have tested it, works well).

 

Any idea ?


Thanks

 

Dimitri

MVP
Posts: 518
Registered: ‎05-11-2011

Re: Problem with special type in SMS

Hmm - seems the reply by email doesn't work anymore - as my reply by email landed in a different post..

 

Anyways:

 

I have a self-registration that allows +<countrycode><phonenumber> and registers that as username. The sms receipt shows the + just fine. I’m using this code {$u.username|escape} in the sms receipt.

 


Regards
John Solberg

-ACMX #316 :: ACCP-
Intelecom - Norway
----------------------------
Remember to Kudo if a post helped you! || Problem Solved? Click "Accept as Solution" in a post!
Regular Contributor I
Posts: 279
Registered: ‎02-11-2013

Re: Problem with special type in SMS

Thanks.

 

I don't understand because I have the same code and the + is still escaped.

 

Regards

Dimitri

MVP
Posts: 518
Registered: ‎05-11-2011

Re: Problem with special type in SMS

Is this through the self-registration? What happens if you go to the SMS gateway in Administration and Send SMS directly from there.

Just type in various letters and see what arrives at your phone.


Regards
John Solberg

-ACMX #316 :: ACCP-
Intelecom - Norway
----------------------------
Remember to Kudo if a post helped you! || Problem Solved? Click "Accept as Solution" in a post!
Regular Contributor I
Posts: 279
Registered: ‎02-11-2013

Re: Problem with special type in SMS

If I do it thru the SMS gateway, it's the same. The + is escaped.

 

But if I send a SMS thru the SMS provider (directly by its website), no problem, I can see all types.

 

Thanks for your help.

 

Dimitri

MVP
Posts: 518
Registered: ‎05-11-2011

Re: Problem with special type in SMS

Try this..

 

Edit the SMS Gateway

Check the box for "Convert text to hex-encoded UTF-16"

 

It really shouldn't be a problem with + sign tho..


Regards
John Solberg

-ACMX #316 :: ACCP-
Intelecom - Norway
----------------------------
Remember to Kudo if a post helped you! || Problem Solved? Click "Accept as Solution" in a post!
Regular Contributor I
Posts: 279
Registered: ‎02-11-2013

Re: Problem with special type in SMS

[ Edited ]

As I am using SMS Global, there isn't this option.

 

Edit : I have tried to configure a custom http handler, it seems that SMS Global doesn't support utf-16.

 

Dimitri

MVP
Posts: 518
Registered: ‎05-11-2011

Re: Problem with special type in SMS

 

Are you saying the + is removed or escaped to some other character?

 

You are certain the + is saved in the username? (just checking :))

 

You could try to use the ClearPass Guest SMS Service gateway and see if the same happens. Won't help you much, but you might be able to narrow down where the issue might be. 

 

 


Regards
John Solberg

-ACMX #316 :: ACCP-
Intelecom - Norway
----------------------------
Remember to Kudo if a post helped you! || Problem Solved? Click "Accept as Solution" in a post!
Regular Contributor I
Posts: 279
Registered: ‎02-11-2013

Re: Problem with special type in SMS

The + is removed.

 

Yes the + is saved in the username.

 

Ok I will try with ClearPass Guest SMS Service gateway and give feedback.

 

Dimitri

Regular Contributor I
Posts: 279
Registered: ‎02-11-2013

Re: Problem with special type in SMS

So I can't try the ClearPass Guest SMS Service gateway, can you do it in your lab ?

 

Thanks

 

Dimitri

Search Airheads
Showing results for 
Search instead for 
Did you mean: