Security

Reply
New Contributor
Posts: 1
Registered: ‎06-20-2013

invalid registration token when responding to guest registration request

Users get invalid registration tokenwhen responding to clear pass guest user request

 

Has anybody seen this? 

Guru Elite
Posts: 20,820
Registered: ‎03-29-2007

Re: invalid registration token when responding to guest registration request

What version of CPPM is this?  There was a bug that displayed the same error that was fixed in CPPM 6.1...bug#12664

 

 



Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

Contributor II
Posts: 58
Registered: ‎05-12-2009

Re: invalid registration token when responding to guest registration request

I am having the same issue on 6.1.  Any ideas as to why?  I will be sure to post my findings as well.

 

Thanks

Guru Elite
Posts: 20,820
Registered: ‎03-29-2007

Re: invalid registration token when responding to guest registration request

jmadej,

 

We do not have enough information to determine what is going wrong in your situation.  Please open a TAC case so that they can go through the details of your configuration.

 



Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

Contributor II
Posts: 58
Registered: ‎05-12-2009

Re: invalid registration token when responding to guest registration request

It turns out this happens anytime a sponsor confirms an email that is not associated with a user account any longer.  I have seen this happen when a guest sends a sponsor an email and then sends another sponsor one as well.  When the original sponsor confirms the original email it has no account associated anymore and displays invalid token.  This can occur anytime the email confirmation is no longer associated with the original disabled user account that was created in the original request.  

MVP
Posts: 1,110
Registered: ‎10-11-2011

Re: invalid registration token when responding to guest registration request

Just wanted to chime in that I'm seeing this issue as well on 6.2.2.56621.  The first click to confirm the guest request results in "invalid registration token" but if I close my browser and click the link again it works.  I haven't found any consistency to it.

=======================================
If a reply adequately addresses your issue, please click on the "Accept as Solution" and "Give Kudos" button so this information can benefit other users.
MVP
Posts: 226
Registered: ‎03-03-2011

Re: invalid registration token when responding to guest registration request

As previously stated this appears to be a generic error message.

For info I have had this problem when an account has been created with a user role which the operator is not allowed to approve (as defined in their operator profile).

 

David
ACDX #98 | ACMP | ACCP
Regular Contributor I
Posts: 187
Registered: ‎03-27-2013

Re: invalid registration token when responding to guest registration request

[ Edited ]

Hi,

I have ClearPass 6.3.0 and have same issue.

Have you found a solution for this issue?

 

Best regards

Andrea Acampa

Andrea
Guru Elite
Posts: 20,820
Registered: ‎03-29-2007

Re: invalid registration token when responding to guest registration request

Again, this is a generic error and could mean a few things.  Please open a case with support to determine why.



Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

Highlighted
Aruba
Posts: 1,285
Registered: ‎08-29-2007

Re: invalid registration token when responding to guest registration request


dg27 wrote:

As previously stated this appears to be a generic error message.

For info I have had this problem when an account has been created with a user role which the operator is not allowed to approve (as defined in their operator profile).

 


This suggestion was a great help and was the exact reason I was getting the same message.

 

I had my operator profile set to only create guests with [Employee] but in the self-registration page, the role-id field was set to 2, which maps to [Guest].

 

Thanks


If my post is helpful please give kudos, or mark as solved if it answers your post.

ACCP, ACMP, ACMX #294
mclarke@arubanetworks.com
Search Airheads
Showing results for 
Search instead for 
Did you mean: