Wireless Access

Reply
New Contributor
Posts: 3
Registered: a week ago

Help - Sonos with Aruba

Hi all,

I am having some serious difficulty configuring 4 x Play 3 Speakers and 1 x Play 1 speaker on an Aruba Wireless Network.

I have done some reading and completed the following:

 - Disabled all Broadcast Filtering
 - Enabled Bonjour, DLNA, & AirGroup Across Multiple VLAN's
 - Enabled the AirGroup Services Including AirPlay & DLNA Media
 - Created an AirGroup Service named "Sonos DLNA", entered in the following and enabled it:
  id "urn:schemas-upnp-org:service:GroupRenderingControl:1"
  id "urn:schemas-sonos-com:service:Queue:1"
  id "urn:schemas-upnp-org:service:AVTransport:1"
  id "urn:schemas-upnp-org:service:RenderingControl:1"
  id "urn:schemas-tencent-com:service:QPlay:1"
  id "urn:schemas-upnp-org:service:GroupManagement:1"
  id "urn:schemas-upnp-org:service:ZoneGroupTopology:1"
  id "urn:schemas-upnp-org:service:DeviceProperties:1"
  id "urn:schemas-upnp-org:service:MusicServices:1"
  id "urn:schemas-upnp-org:service:AlarmClock:1"
  id "urn:schemas-upnp-org:device:ZonePlayer:1"
  id "urn:schemas-upnp-org:service:SystemProperties:1"
  id "urn:schemas-upnp-org:service:ContentDirectory:1"
  id "urn:schemas-upnp-org:service:ConnectionManager:1"
 - I have re-booted all the AP's including the controller

 

After completing all the necessary steps I could find online I can successfully setup 1 x speaker however when I attempt to add an additional speaker the process halts when you need to press the play/pause and + button as the "Next" button is greyed out and I cannot go any further.

 

I have factory reset all the speakers several times and created new Sonos Controllers with different speakers and it always halts at the same place.

 

Please help as I am pulling my hair out.

 

I have also posted this on the Sonos forum.

Thanks,
James.

Guru Elite
Posts: 21,291
Registered: ‎03-29-2007

Re: Help - Sonos with Aruba

I would check to see if there are any blocked queries or blocked service id's when it is happening:

 

show airgroup blocked-service-id

show airgroup blocked-queries

 

That would indicate that adding a devices requires a new service ID to be added to the string...



Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

New Contributor
Posts: 3
Registered: a week ago

Re: Help - Sonos with Aruba

Thanks Joseph,

 

Ended up allowing all that looked even remotely related to SONOS and got it working.

 

Thanks again,

James.

Guru Elite
Posts: 21,291
Registered: ‎03-29-2007

Re: Help - Sonos with Aruba

@jtraz82,

 

Do you mind publishing the full list that you have?  It seems that Sonos has added a few over the years.

 

Thanks in advance.



Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

New Contributor
Posts: 3
Registered: a week ago

Re: Help - Sonos with Aruba

Hi Colin,

 

Looks like I spoke too soon.

 

I ended up adding in the following ServiceID's into the new AirGroup:

 

 id "urn:schemas-upnp-org:service:GroupRenderingControl:1"
  id "urn:schemas-sonos-com:service:Queue:1"
  id "urn:schemas-upnp-org:service:AVTransport:1"
  id "urn:schemas-upnp-org:service:RenderingControl:1"
  id "urn:schemas-tencent-com:service:QPlay:1"
  id "urn:schemas-upnp-org:service:GroupManagement:1"
  id "urn:schemas-upnp-org:service:ZoneGroupTopology:1"
  id "urn:schemas-upnp-org:service:DeviceProperties:1"
  id "urn:schemas-upnp-org:service:MusicServices:1"
  id "urn:schemas-upnp-org:service:AlarmClock:1"
  id "urn:schemas-upnp-org:device:ZonePlayer:1"
  id "urn:schemas-upnp-org:service:SystemProperties:1"
  id "urn:schemas-upnp-org:service:ContentDirectory:1"
  id "urn:schemas-upnp-org:service:ConnectionManager:1"

(NEW) id "urn:smartspeaker-audio:service:SpeakerGroup:1

 

Out of desperation I also added in the following:

urn:schemas-wifialliance-org:device:WFADevice:1

urn:schemas-wifialliance-org:service:WFAWLANConfig:1

urn:schemas-upnp-org:device:InternetGatewayDevice:1

urn:schemas-upnp-org:service:WANIPConnection:1

urn:schemas-upnp-org:service:WANPPPConnection:1

 

In the end I was able to add in the Extra Sonos Speakers but only by having them connected to the same WAP as the first Sonos Speaker I setup.

 

Once they were all installed and setup in the app I re-positioned the 5 x speakers around the site.

 

Once I had all 5 of the speakers connected I conducted some testing and found that depening on which AP I was connected to changed the amount of speakers I could see in the Sonos Application.

At one end of the site I could see 4 of 5 speakers and at another end of the site I could only see 1 etc.

 

Is there a setting in the Aruba controller that could have something to do with this?

I currently have Broadcast filtering, Multicast transmission optimization and Dynamic multicast optimization ALL disabled.

 

Any help would be greatly appreciated.

Search Airheads
Showing results for 
Search instead for 
Did you mean: