Wireless Access

Reply
Occasional Contributor I

LDAP Connection - Internal Error : Invalid response (-1)

Hi,

I tried the last few hours to connect our Aruba 3200 Appliance (ArubaOS 6.1.2.3) to our MS w2k8 Active Directory by using LDAP but it doesn`t work. When I use the "AAA Test Server" I get the message: 'Internal Error : Invalid response (-1)'

 

I use these settings:

 

Admin-DN: CN=Admin,OU=Users,DC=campus,DC=local

Base-DN: OU=teacher,OU=school,DC=campus,DC=local

Filter: (objectclass=person)

Key Attribute: sAMAccountName

 

I have no idea why this doesn't work or what's wrong with the configuration or the response. Other Systems are using an LDAP connection to our Active Directory as well. Has anyone an idea what could been the problem?
Regards,
Alex
Guru Elite

Re: LDAP Connection - Internal Error : Invalid response (-1)

Is the admin password correct?

 



Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

Occasional Contributor I

Re: LDAP Connection - Internal Error : Invalid response (-1)

Hi,

we tried the users "Admin" and "Administrator" and we got the same message. When I try to connect to another Active Directory, the same problem appeared.

 

Regards,

Alex

Frequent Contributor II

Re: LDAP Connection - Internal Error : Invalid response (-1)

Hi Alex,

This may help ;

Yesterday I was doing same Ldap integration .

I have selected  1. Preferred connection Type = clear-text   and checked the box  "allow clear -text" .   under Servers > LDAP Server in controller.

I got the same error when I tried  to check  the authentication from  Controller > dignostics > aaa server test  then I noticed the method selected was MS-CHAP-v2   for this setup PAP is required . after selecting PAP the authentication was successful.

 

 

Occasional Contributor I

Re: LDAP Connection - Internal Error : Invalid response (-1)

Hi harshad,

thanks for your response. I tried it successfully and now it works. :)

 

Regards,

Alex

Occasional Contributor I

Re: LDAP Connection - Internal Error : Invalid response (-1)

Hate commenting on a thread that is just over a year old.  Here we go.

 

I am having the same issues as above.  I had to change my Termination Inner EAP-Type to eap-gtc in order to get iOS devices to authenticate. However now it seems that now my Windows clients are unable to authenticate.  

 

When I switch the inner eap-type back back eap-mschapv2 neither can connect using 802.1x.

 

EDIT:  Nevermind, found my answer here... SHIM!

http://community.arubanetworks.com/t5/ArubaOS-and-Mobility-Controllers/Can-I-make-the-802-1x-authentication-Via-LDAP-server/td-p/17610

 

 

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: