Wireless Access

Reply
Super Contributor II

Not able to configure an IAP without IP from WebUI

Hi experts,

 

We have a customer with many CAPs, but for some reason we are going to convert some CAPs to IAPs from the controller option, and later we will configure them to form some Instant clusters.
The customer has no DHCP server on the network, and all the CAPs have static IP addresses.
I am testing this scenario in my office, and when converting a CAP to IAP or when factory resetting an IAP, the IAP boots but I cannot configure it from WebUI because it keeps rebooting because the gateway is unreachable:

 

AP uptime is 5 minutes 13 seconds
Reboot Time and Cause: AP rebooted Thu Jan 1 08:08:36 UTC 1970; Gateway unreachable

 

and it reboots again and again. How can I keep an IAP up for configuring from WebUI if it has no dynamic IP?

 

Regards,
Julián

Guru Elite

Re: Not able to configure an IAP without IP from WebUI

You do need a gateway configured and reachable.

 

 I would stand up a temporary DHCP server to make this easier, because that is how the product was designed.  Allowing users to provision an entire network using static ip addressing is not really designed into the product so users who want to do everything statically will have much more difficulty.



Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

Super Contributor II

Re: Not able to configure an IAP without IP from WebUI

Hi Colin,

 

But even standing up a temporary DHCP server is not totally feasible, because you will need to deploy this DHCP server in the AP native VLAN (VLAN 0 I think). But most clients doesn't use the native VLAN, so if the DHCP server is deployed within a VLAN other than VLAN 0, the AP DHCP requests will not get a response, then the AP will not get an IP address and then will start to reboot. Maybe an "IP helper- address" would solve this, not sure. Easy things Aruba make them hard...

 

Regards,

Julián

Super Contributor II

Re: Not able to configure an IAP without IP from WebUI

Hi Colin,

 

I have made some tests and finded out that it also depends of the firmware version. For example,

 

  • 6.5.2.0 --> IAP doesn't reboot, but you cannot access the WebUI
  • 6.4.4.8-4.2.4.3 --> IAP reboots every 5 minutes and when is up you cannot access the WebUI

In both situations AP gets a default IP in subnet 169.254.0.0/16. If you connect the AP to a switch and a device configured with an IP within subnet 169.254.0.0/16 to the same switch,

 

  • 6.5.2.0 --> IAP doesn't reboot, you can access the WebUI only entering the AP IP in the browser
  • 6.4.4.8-4.2.4.3 --> IAP doesn't reboot, you can access the WebUI either connecting to the "instant" network or entering the AP IP in the browser

Wierd behaviour, complicated to configured factory IAP with no DHCP server, not as easy as it should be...

 

Regards,

Julián

 

 

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: