Wireless Access

Reply
Aruba
Posts: 1,285
Registered: ‎08-29-2007

Problem with HP thin client t5740e, Atheros AR5009

I came across an interesting problem that I'd like to share in case anyone else is unfortunate enough to have the same problem.

 

Customer has a large deployment of HP thin client t5740e across many sites.  Most of these sites the devices are working fine, but suddenly we found that for some new sites, the performance was really bad.  Everything was the same in terms of hardware, drivers, software and Aruba configuration.

 

After much testing and packet captures, I suddenly realised (a bit of a eureka moment) that the devices were showing 2 stream capability, when they only had one antenna.

 

(controller) #show ap association essid wifi

Flags: W: WMM client, A: Active, K: 802.11K client, B: Band Steerable

PHY Details: HT: High throughput; 20: 20MHz; 40: 40MHz
             <n>ss: <n> spatial streams

Association Table
-----------------
Name                        bssid              mac                auth  assoc  aid  l-int  essid  vlan-id  tunnel-id  phy             assoc. time     num assoc  Flags
----                        -----              ---                ----  -----  ---  -----  -----  -------  ---------  ---             -----------     ---------  -----
AP060  00:24:6c:61:73:12  70:f1:a1:e7:87:3c  y     y      2    1      wifi   36       0x10c5     a-HT-40sgi-2ss  7d:11h:49m:40s  1          WAB
AP15  00:24:6c:61:73:52  70:f1:a1:94:fa:fa  y     y      1    1      wifi   36       0x10f1     a-HT-40sgi-2ss  2d:2h:52m:5s    2          WA
AP02  00:24:6c:61:72:91  70:f1:a1:94:f9:cd  y     y      1    1      wifi   36       0x10fa     a-HT-40sgi-2ss  4d:20h:53m:14s  1          WAB

Ping tests to any of these clients showing 2ss results in loss of 10-12%, whereas to one of these clients with 1ss results in 0% loss.  A raw download test will show up to a 10 fold increase in speed when they use only 1 stream.

 

Changing the ht-ssid-profile to have a supported mcs set of 0-7 was an effective workaround in forcing these clients to only use 1 stream.

 

Driver version 9.2.0.480 from HP also disables the client advertising 2 streams.  I tested on a client connected to AP with default config of mcs set 0-23 and indeed they connected showing only 1 stream.

 

Hopefully this will avoid anyone else going through the same pain I had to endure.

 

:smileyhappy:


If my post is helpful please give kudos, or mark as solved if it answers your post.

ACCP, ACMP, ACMX #294
mclarke@arubanetworks.com
Aruba Employee
Posts: 100
Registered: ‎12-02-2011

Re: Problem with HP thin client t5740e, Atheros AR5009

Really good finding. 

Just wondering why would client associate to the AP with 2SS when it can't support it? Association request and response frame can give you this information. Many people may run into this issue, so I think its worth investing. 

Aruba
Posts: 1,285
Registered: ‎08-29-2007

Re: Problem with HP thin client t5740e, Atheros AR5009

The adapters have two antenna connectors, but these units only have one antenna.  I assume if you connected a second antenna, it would work fine, but that is not how these units made.

 

Unfortunately, comparing the wireless adapter from a good and bad unit, as far as I can tell, they are exactly the same, so who knows where the problem lies.

 

Fix = driver 9.2.0.480

 


If my post is helpful please give kudos, or mark as solved if it answers your post.

ACCP, ACMP, ACMX #294
mclarke@arubanetworks.com
Aruba Employee
Posts: 5
Registered: ‎04-07-2007

Re: Problem with HP thin client t5740e, Atheros AR5009

Hi Michael_Clarke - hope you are well.

 

I have a hospital that has run into the same problem with the HP thin clients, trying to do 2SS. They are however running that driver, 9.2.0.480, yet still seeing 2SS associations. When you installed that driver, were there any changes you had to make in the Registry or Advanced Settings? Or did it just work?

 

Thanks,

Mike

-----
Michael Landry
Customer Success Architect
Aruba HPE
Aruba
Posts: 1,285
Registered: ‎08-29-2007

Re: Problem with HP thin client t5740e, Atheros AR5009

Hi Mike,

 

From memory, I think it just worked.  You might need to change the mcs set in the ht-ssid-profile, but then other clients on that ssid won't benefit from the higher rates.

 

 


If my post is helpful please give kudos, or mark as solved if it answers your post.

ACCP, ACMP, ACMX #294
mclarke@arubanetworks.com
Search Airheads
Showing results for 
Search instead for 
Did you mean: