Controllerless Networks

 View Only
last person joined: yesterday 

Aruba Instant Wi-Fi: Meet the controllerless Wi-Fi solution that's easy to set-up, is loaded with security and smarts, and won't break your budget.
Expand all | Collapse all

Airgroup works on Master (Conductor) but not on Slaves (Members)

This thread has been viewed 19 times
  • 1.  Airgroup works on Master (Conductor) but not on Slaves (Members)

    Posted Feb 24, 2022 05:16 PM
    Hello,

    We have 6 Aruba 505 managed bei a virtual controller. Firmware 8.9.02. Conductor electon, wireless LAN and configuration sync works flawlessly.
    Airgroup - Bonjour and DLNA - are enabled on the master and all members. Airplay and Airprint are enabled.

    Problem:
    On the Virtual Controller "show airgroup servers" and "show airgroup users" works as expected. Wireless devices (iPad, iPhone) associated with SSID "HTL-AAA" on the master can see all services. When the same device connects to a member AP it can't see any services. No output from "how airgroup cache entries" on members. It is my understanding, that every member should manage his own cache. All members are in the same mangement VLAN and trunked to a switch port carrying all VLANS.

    Any help is greatly appreciated.

    Best Regards,
    Kurt

    ------------------------------
    Kurt Albrecht
    ------------------------------


  • 2.  RE: Airgroup works on Master (Conductor) but not on Slaves (Members)

    EMPLOYEE
    Posted Mar 05, 2022 05:23 PM
    in Instant AP clusters, all the AP s in the cluster should maintain the airgroup service info like servers, cache.
    so in your case is your Bonjouor/DLNA servers wired connected? if so you need to ensure the switch ports that connects to the IAPs have the same VLANs configuration and all those VLANs are permitted/allowed incl the native VLAN

    ------------------------------
    Any opinions expressed here are solely my own and not necessarily that of Hewlett Packard Enterprise or Aruba.
    ------------------------------



  • 3.  RE: Airgroup works on Master (Conductor) but not on Slaves (Members)

    Posted Mar 09, 2022 08:03 AM
    The Bonjour Servers are on the wired network. Every AP is connected to a trunk port on Cisco Switch.

    On the Switch:
    #show int trunk
    Port        Mode         Encapsulation  Status        Native vlan

    Fa3/0/22    on           802.1q         trunking      1
    ...
    Port      Vlans allowed on trunk
    Fa3/0/22    1-4094

    On the AP:
    wired-port-profile default_wired_port_profile
     switchport-mode trunk
     allowed-vlan all
     native-vlan 1
     uplink-enable
     trusted
     no shutdown
     access-rule-name default_wired_port_profile
     speed auto
     duplex full
     no poe
     type employee
     auth-server InternalServer
     captive-portal disable
     no dot1x

     The elected master AP gathers all server information.

    A-02-04 d0:4d:c6:c1:4b:a2# show airgroup servers
    AirGroup Servers

    ----------------

    MAC IP Type Host Name Service VLAN Wired/Wireless Role Group Name AP-Name
    --- -- ---- --------- ------- ---- -------------- ---- ----- ---- -------
    58:38:79:32:42:db 172.24.33.89 mDNS RNP5838793242DB airprint 33 wired A-02-04 d0:4d:c6:c1:4b:a2
    88:51:fb:57:06:46 172.24.25.30 mDNS C-02-08 airplay 25 wired A-02-04 d0:4d:c6:c1:4b:a2
    ...
    On slave APs the server list is empty.
    It is my understanding, that the slaves should sync with the master.

    A-02-04 d0:4d:c6:c1:4b:a2# show airgroup debug statistics 
    AirGroup slave status :TRUE
    AirGroup master status :TRUE
    AirGroup multi swarm status :TRUE
    status value :0xfe
    My ip address :172.24.35.12
    My VC address :172.24.35.251
    Peer VC address :0.0.0.0
    Peer VC address :0.0.0.0
    Peer VC address :0.0.0.0
    Peer VC address :0.0.0.0
    Peer VC address :0.0.0.0
    Peer VC address :0.0.0.0
    Peer VC address :0.0.0.0
    Peer VC address :0.0.0.0

    AirGroup Debug Statistics
    --------------------------
    Key Value
    --- -----
    network cache init counter 1(0)
    mdns apdb init counter 1(0)
    airgroup restore count 1(0)
    dropped as init not done rx 26(0)
    mdns recieved bonjour pkt from device 49683(20176)
    mdns recieved dlna pkt from device 20507(7656)
    mdns ptr cache flush record tx 505(153)
    mdns ap update tx 496(145)
    master to vc hello tx 95(45)
    mdns ap to swarm hello tx 95(45)
    mdns total pkt sent to asap tx 37052(15943)
    On a slave AP:
    *********************************************************************************************************3/9/2022 13:39:26 PM Target: A-02-19 d0:4d:c6:c1:40:ba Command: show airgroup debug statistics *********************************************************************************************************AirGroup slave status :TRUEAirGroup master status :FALSE
    AirGroup multi swarm status :FALSE
    status value :0xee
    My master's address :172.24.35.12
    My ip address :172.24.35.11
    AirGroup Debug Statistics
    --------------------------
    Key Value
    --- -----
    network cache init counter 1(0)
    mdns apdb init counter 1(0)
    airgroup restore count 1(0)
    mdns recieved bonjour pkt from device 10159(1966)
    mdns recieved dlna pkt from device 4791(934)
    mdns ptr cache flush record tx 30(10)
    mdns ap update tx 26(8)
    mdns ap to swarm hello tx 12(3)
    mdns total pkt sent to asap tx 4163(26)
    Any idea why they don't sync?
    Thanks for any help
    Kurt

    ------------------------------
    Kurt Albrecht
    ------------------------------



  • 4.  RE: Airgroup works on Master (Conductor) but not on Slaves (Members)

    Posted Apr 15, 2022 02:20 AM
    After a lot of troubleshooting I found a simple solution:

    Airgroup not working
    Uplink/management VLAN 35
    Wireless network 1: SSID HTL-AUT; VLAN 110 static;
    Wireless network 2: SSID HTL-AAA; dynamic VLAN assignment via RADIUS, Standard VLAN 110;

    After adding a Guest WLAN with default VLAN everything worked fine. The APs did immediately start to exchange their airgroup caches.
    I tried changing the VLAN to 110 and the APs stopped exchanging airgroup data.
    Finally I removed the Guest WLAN and changed the Standard VLAN of HTL-AAA to VLAN 1. Now everything works as expected.

    Airgroup working
    Uplink/management VLAN 35
    Wireless network 1: SSID HTL-AUT; VLAN 110 static;
    Wireless network 2: SSID HTL-AAA; dynamic VLAN assignment via RADIUS, Standard VLAN 1;

    It is my understanding, that the APs exchange swarm information via the assigned uplink/managment VLAN 35. So this behavior seem to be a bug in the firmware.

    ------------------------------
    Kurt Albrecht
    ------------------------------