Community Feedback

 View Only
last person joined: 18 hours ago 

How is the community doing? Do you have any questions or feedback related for the Airheads Community team? This is the place to let us know.
Expand all | Collapse all

ArubaCX in EVE-NG, problem with communication

This thread has been viewed 57 times
  • 1.  ArubaCX in EVE-NG, problem with communication

    Posted Oct 03, 2020 05:55 PM

    Hello,

    I started learning Aruba devices configuration and I have problem with traffic between two centos nodes passing through ArubaCX in EVE-NG environment. When I ping from centos1 to centos2 it works but when I tried to ssh from one to another device there is a problem. Wiereshark sees "TCP Retransmission" packets and centos node returns "Connection timeout".

     

    When I swap Aruba with EVE-NG built in bridge network it just works. I worked with Cisco IOSvL2 int the past and i didn't have problems with that to.

     

    There is a bug in EVE-NG/ArubaCX or I need to config something?

    I have tiny Cisco experience and with Aruba I started today.

     

    My topology for now is very simple:

    centos1 - ArubaCX - centos2

     

    ArubaCX config:

    ...

    interface 1/1/2

      no shutdown

      no routing

      vlan access 1

    interface 1/1/3

      no shutdown

      no routing

      vlan access 1

    ...

     

    I'll deploy ArubaCX in vmware tommorow and i'll check this but maybe in the meantime someone have any idea what is going on...



  • 2.  RE: ArubaCX in EVE-NG, problem with communication

    MVP GURU
    Posted Oct 04, 2020 02:04 PM

    Couldn't it be an MTU related issue? try to set MTU 9198 at physical interface context level on ArubaOS-CX.



  • 3.  RE: ArubaCX in EVE-NG, problem with communication

    Posted Oct 30, 2020 11:39 PM
    I'm having a similar issue in eve-ng; for some crazy reason it looks like only my Fedora 32 box doesn't want to have any TCP communications work, but it gets a good DHCP address and can ping other devices on the network no problem. This is a real head-scratcher, seems like my Windows boxes in eve-ng are working flawlessly. Did you end up getting ArubaCX in vmware to have the same problem?

    ------------------------------
    Tom Costello
    ------------------------------



  • 4.  RE: ArubaCX in EVE-NG, problem with communication

    Posted Oct 31, 2020 12:04 AM
    I think I figured it out; if you edit the CentOS node's properties to have an e1000 NIC instead of the default virtio-net-pci NIC, all the TCP traffic should start working as desired

    That was a real mind-blow at first; last night I was digging through firewalld, thinking I had a duplicate MAC somewhere, or who knows what. But the fact that my Windows hosts were working 100% made no sense.

    Sure enough, after thinking about it a little more and comparing the Win hosts to my networksecuritytoolkit.org Fedora 32 build, the NIC type jumped out at me, and I'm happy to be keeping the ArubaOS-CX in my eve-ng topology!



  • 5.  RE: ArubaCX in EVE-NG, problem with communication

    Posted Dec 25, 2021 09:25 AM
    This information should be somewhere in the simulator forum too, was just trying to figure the same thing and this helped. It was also UDP traffic that got blocked before switching to e1000 for Linux VMs


  • 6.  RE: ArubaCX in EVE-NG, problem with communication

    Posted Feb 14, 2022 01:35 PM
    Dear administrators, please keep this reply Pinned in the forum. I was about to lose my mind, I was having FTP and SSH connections timeout, until I read this gentleman's reply... I am very happy to keep Aruba in my topology. ​

    ------------------------------
    Lemon Lover
    ------------------------------