Community Feedback

 View Only
last person joined: yesterday 

How is the community doing? Do you have any questions or feedback related for the Airheads Community team? This is the place to let us know.

Switch 2530-24G complete reinstall

This thread has been viewed 4 times
  • 1.  Switch 2530-24G complete reinstall

    Posted Dec 10, 2021 10:16 AM


    I inherited a switch 2530-24G and I tried to reset it to set up a fixed IP + web management interface. The factory reset procedure went OK, I could set name and IP but there was no way to have the management interface up and running despite the fact using show console the service was marked as turned ON.

    So I (wrongly) thought I could erase everything and start from scratch with a new firmware... However after hours of tries I can't put a firmware on this machine using xmodem protocol.

    When it boots:

    ROM information:
    Build directory: /ws/swbuildm/lakesrom_qaoff/rom/build/lakesrom(swbuildm_lakesrom_qaoff_smb)
    Build date: Oct 31 2012
    Build time: 15:27:40
    Build version: YA.15.12
    Build number: 11165

    Error, /cfa0/boot.ini corrupted; please reboot to console and repair.
    Could not open Image file

    Bad code in FLASH

    Flash memory needs reprogramming or chassis could be faulty.
    Use a PC as the console and perform the update procedure
    by serial Xmodem download of the current Switch Image.
    If unsuccessful w/ downloading, then try replacing chassis.

    HP 2530-48G-PoE+ Switch - J9772(A)
    ROM Build Directory: /ws/swbuildm/lakesrom_qaoff/rom/build/lakesrom(swbuildm_lakesrom_qaoff_smb)
    ROM Version: YA.15.12
    ROM Build Date: 15:27:40 Oct 31 2012
    ROM Build Number: 11165

    Copyright (C) 1995-2012 Hewlett-Packard Development Company, L.P.

    Confidential computer software. Valid license from HP required for possession,
    use or copying. Consistent with FAR 12.211 and 12.212, Commercial Computer
    Software, Computer Software Documentation, and Technical Data for Commercial
    items are licensed to the U.S. Government under vendor's standard commercial
    20555 State Highway 249, Houston, TX 77070

    Enter h or ? for help.
    then using screen on Linux/MacOS or TeraTerm/ExtraPutty onWindows, I tried to upload the firmware YA_16_04_0016.swi but after the upload nothing happens.

    Following I went up to the last line ... but the switch doesn't reboot nor display messages once the .swi file is sent


    You have invoked the console download utility.
    Do you wish to continue? (Y/N)>
    On the terminal I see the packets sent but it never reboots nor go further than the above message

    I can't believe there's no way to push a firmware on a machine that expensive.(like from USB key ?)
    Any ideas I should try ? Or is it now an expensive brick?

    Arnaud Fortier