Wired Intelligent Edge

last person joined: yesterday 

Bring performance and reliability to your network with the Aruba Core, Aggregation, and Access layer switches. Discuss the latest features and functionality of the ArubaOS-Switch and ArubaOS-CX devices, and find ways to improve security across your network to bring together a mobile first solution.
Expand all | Collapse all

Setting Access Port for Procurve 2910

Jump to Best Answer
This thread has been viewed 3 times
  • 1.  Setting Access Port for Procurve 2910

    Posted Apr 06, 2020 04:08 PM

    Hello. I am very new to HP switching. I come from Cisco so naturally im a little lost here. We had just replaced a Cisco switch with a procurve 2910. I got it trunked to another Cisco and that seems to be working fine. My problem is I have a computer directly connected to this 2910 (port 3) and I cannot get it to come back online. In the cisco it was configured as an access port and im having the typical confusion with no untagged/yes tag/tag/untag/ stuff. I tried to apply a access port configuration as best I could but I am doing something wrong...

     

    Here is the previous config before we swapped hardware, it was cisco to cisco:

     

    interface FastEthernet0/16
    description GFI Computer
    switchport access vlan 7
    switchport mode access

     

    interface GigabitEthernet0/1
    description TRUNK-TO-CISCO
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 2
    switchport mode trunk

     

    After hardware swap, hp to cisco:

     

    vlan 7
    name "Public"
    untagged 3
    tagged Trk2
    no ip address
    exit

     

    24 | Cisco-Trunk 1000SX | Trk2 LACP


    #ALE


  • 2.  RE: Setting Access Port for Procurve 2910

    Posted Apr 06, 2020 04:47 PM

    Hi

     

    For an access the port a simple configuration would be similar to this:

     

    interface 3
    name "PC"
    untagged vlan 7

    enable
    exit

    If you already configured the port like this, run an "show interface 3" and post it here.



  • 3.  RE: Setting Access Port for Procurve 2910

    Posted Apr 06, 2020 04:52 PM

    That command is not accepted:

    procurvevlan.PNG



  • 4.  RE: Setting Access Port for Procurve 2910

    Posted Apr 06, 2020 06:35 PM

    Anyone else have any idea on how to configure an access port on  a HP switch? I've been googling and trying out different things. I can't find a clear solution



  • 5.  RE: Setting Access Port for Procurve 2910

    Posted Apr 06, 2020 06:42 PM

    FuelIsland# sh int 3

    Status and Counters - Port Counters for port 3

    Name : GFI-Computer
    MAC Address : 38eaa7-762d7d
    Link Status : Up
    Totals (Since boot or last clear) :
    Bytes Rx : 15,160,026 Bytes Tx : 31,283,315
    Unicast Rx : 39,905 Unicast Tx : 38,750
    Bcast/Mcast Rx : 57,671 Bcast/Mcast Tx : 291,666
    Errors (Since boot or last clear) :
    FCS Rx : 0 Drops Tx : 0
    Alignment Rx : 0 Collisions Tx : 0
    Runts Rx : 0 Late Colln Tx : 0
    Giants Rx : 0 Excessive Colln : 0
    Total Rx Errors : 0 Deferred Tx : 0
    Others (Since boot or last clear) :
    Discard Rx : 0 Out Queue Len : 0
    Unknown Protos : 0
    Rates (5 minute weighted average) :
    Total Rx (bps) : 344160 Total Tx (bps) : 510856
    Unicast Rx (Pkts/sec) : 0 Unicast Tx (Pkts/sec) : 0
    B/Mcast Rx (Pkts/sec) : 0 B/Mcast Tx (Pkts/sec) : 6
    Utilization Rx : 00.34 % Utilization Tx : 00.51 %



  • 6.  RE: Setting Access Port for Procurve 2910

    Posted Apr 06, 2020 06:43 PM

    procurve2.PNG



  • 7.  RE: Setting Access Port for Procurve 2910

    Posted Apr 06, 2020 08:01 PM

    Try one of the following options:

     

    #interface 3 untaged vlan 3

    #interface 3 enable

     

    or

     

    #vlan 7

    (vlan-7) untaged 3

    #interface 3 enable



  • 8.  RE: Setting Access Port for Procurve 2910

    Posted Apr 06, 2020 08:26 PM

    "or

     

    #vlan 7

    (vlan-7) untaged 3

    #interface 3 enable"

     

    I already have port 3 untagged for vlan 7. And the first suggestion would not work for this,  configuring vlan 3 does not have any connection to this issue.



  • 9.  RE: Setting Access Port for Procurve 2910

    Posted Apr 06, 2020 08:49 PM

    You were asking about how to configure a port as untaged to a vlan.

    Now if you have already done that and as the interface status you uploaded shows that the interface is up, you should already be able to establish  communication between two devices on that vlan. Nothing else is needed.

    What tests are you performing? When you say the the port does not com on line, what exactly you mean?

    And post here the full switch configuration.

     



  • 10.  RE: Setting Access Port for Procurve 2910

    Posted Apr 06, 2020 09:07 PM

    I was asking to configure a port as an access port, in Cisco they are called access ports, I don't know what hp calls them. But I need the computer on the other end to get an ip address so I can remote into it. So far I cannot ping it.



  • 11.  RE: Setting Access Port for Procurve 2910

    Posted Apr 06, 2020 09:30 PM

    Ok. So the problem could be the communication between the 2910 and the other device the switch are connected to.

    Remember that you should add the trunk  (port-channel) to the vlan as a tagged or untamed port.

     

    trunk 10-11 Trk1 LACP

    vlan 172
    name "VLAN172"
    tagged 50,Trk1
    exit

     

    As the PC can not get an IP address, you can try a static IP to see if there is communication and make sure that it is not a DHCP problem. Another test you can do is to assign a IP address to the switch on the vlan you are testing.

     

    If the tests fail,  you should check the communication between the 2910 and the other device. For example:

    Are the switches running spanning-tree?

    What is the status of the spanning-tree for those ports?

    Is there any mac-address on the 2910 ports, PC port and trunk port?

    Are you using trunk (port-channel) static or LACP?

    What is the status of trunk/lacp?

    Is dhcp-snooping been used?

     

    Some commands you can use to troubleshoot:

     

    #show trunk

    #show lacp

    #show spanning-tree

    #show log

    #show mac-address

    #show dhcp-snooping



  • 12.  RE: Setting Access Port for Procurve 2910

    Posted Apr 06, 2020 09:36 PM

    The previous connection was not a port channel so this one is not too. Just a Cisco and HP connected with a single connection. The HP port 24 is set to trk2 and lacp, the Cisco port is set to trunk.



  • 13.  RE: Setting Access Port for Procurve 2910

    Posted Apr 07, 2020 05:28 AM

    @ChrisCC28 wrote:

    The previous connection was not a port channel so this one is not too. Just a Cisco and HP connected with a single connection. The HP port 24 is set to trk2 and lacp, the Cisco port is set to trunk.


    Your first sentence:

     

    "The previous connection was not a port channel so this one is not too. Just a Cisco and HP connected with a single connection"

     

    is in total contrast with the second sentence (as per configuration you show [*]):

     

    "The HP port 24 is set to trk2 and lacp, the Cisco port is set to trunk"

     

    The point is that Trunk in Cisco terms means carrying more VLANs on a interface (physical or logical)...the same on HP can be achieved by simply tagging that interface with one or more VLANs.

     

    In your specific case, since you hadn't any EtherChannel before then you should not have any EtherChannel after...and so Port Trunking, in HP terms, should not be part of the equation in your HP configuration.

     

    In other terms: you had single link between switches before, you should have single link between them after (if the topology and inter-links were not changed in between)...thus simply don't use HP Port Trunking (exactly like you said you didn't use Cisco EtherChannels). Forget about Trk1 and Trk2.

     

    Thus if HP port 24 is connected to the Cisco...then you should remove Trk2 logical interface and then you should untag (and, if necessary, tag) port 24 with required VLAN(s) to cope/match with those assigned to peer interface on the Cisco side.

     

    To understand HOW a port was configured with regards to VLAN untagging/tagging a very useful command would be:

     

    show vlan port x detail (where x is the port id you want to diagnose)

     

    [*] where:

    trunk 22 Trk1 LACP

    trunk 24 Trk2 LACP

    mean that you created two logical aggregated interfaces (Ether-Channels in Cisco jargon, Port Trunk in HP jargon) each one made of just one physical interface, 22 for Trk1 and 24 for Trk2.



  • 14.  RE: Setting Access Port for Procurve 2910

    Posted Apr 07, 2020 10:46 AM

    Ok so here is the config for the cisco:  

     

    interface GigabitEthernet0/1
    description TRUNK-TO-ADMIN-1
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 2
    switchport mode trunk

     

    Here is the config for HP 

     

    vlan 7
    name "Public"
    untagged 3
    tagged Trk2
    no ip address
    exit

     

    trunk 24 Trk2 LACP

     

    Just so I am understanding this correct. You are suggesting I remove TRK2 from port 24, add port 24 to all required vlans. You mentioned tag or untag if neccessary... how do I know which to use? This is what confuses me. Also what about port 3? This is where I need the connection between the switch and computer to work for vlan 7.



  • 15.  RE: Setting Access Port for Procurve 2910

    Posted Apr 07, 2020 12:52 PM

    Hi,


    @ChrisCC28 wrote: Ok so here is the config for the cisco:  

     

    interface GigabitEthernet0/1
    description TRUNK-TO-ADMIN-1
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 2
    switchport mode trunk

    Perfect...that configuration means that interface GigabitEthernet0/1 is untagged member of VLAN 2 (switchport trunk native vlan 2) and no other VLANs were added as permitted, that's strange for a "Trunk" port (in Cisco jargon)...because one expects that a "Trunk" port will carry more VLAN ids but...here...there aren't...indeed there isn't the usual expected row "switchport trunk allowed vlan <single vlan-ids or range>" (see here to understand what I mean). Consider that the native VLAN is also allowed automatically...so your GigabitEthernet0/1 is a "Trunk" port with no other VLAN ids permitted other than its native VLAN 2.

     


    @ChrisCC28 wrote: Here is the config for HP 

     

    vlan 7
    name "Public"
    untagged 3
    tagged Trk2
    no ip address
    exit


    That's more simple...the Trk2 (logical) interface - made of port 24 all alone - is tagged member of VLAN 7...and interface 3 is untagged (AKA native) member of VLAN 7 too...here the context is VLAN biased.

     


    @ChrisCC28 wrote: trunk 24 Trk2 LACP
    Just so I am understanding this correct. You are suggesting I remove TRK2 from port 24, add port 24 to all required vlans.

    Yes, I am suggesting exactly that. On Cisco side there isn't any etherchannel (where etherchannel = link aggregation = port trunking = interface bonding...call it the way you like more...again see the "HP jargon adversus Cisco jargon for VLANs and Links Aggregations" presentation I linked above). Once you work with the simple port 24 (not more part of Trk2) you should let that port to became untagged member of VLAN 2...that's to match what we see on Cisco GigabitEthernet0/1.

     


    @ChrisCC28 wrote: You mentioned tag or untag if neccessary... how do I know which to use? This is what confuses me. Also what about port 3? This is where I need the connection between the switch and computer to work for vlan 7.

     

    IF you need to pass VLAN 7 TOO (in addition to VLAN 2 we all see on the Cisco...) you need to pass it tagged...so tag it to port 24 (interestingly the Trk2 is tagged, do the same on port 24 once the port became normal) and allow it on GigabitEthernet0/1...but, again, that's because NOW you have the HP with VLAN 7 tagged and the Cisco untagged on VLAN 2...so you should understand what you want. Do you need to pass VLAN 2 to HP? if so you can pass it untagged or tagged...but since it's already untagged on Cisco side you better do the same on HP side...so untag port 24 on VLAN 2...and this is the first match...then you will worry about VLAN 7...do you need to pass it to Cisco? OK...tag it on port 24...and, as said, allow it on port GigabitEthernet0/1.

     

    Technically speaking you can also turn the scenario upside down...and use the VLAN 7 as untagged (Native) and allow the VLAN 2 (tagged on HP)...there isn't a rule to say what VLAN should be native on a point-to-point link between two switches...it's also possible to have no untagged VLANs and to work with all and only tagged VLANs on such inter-links. It's a matter of taste...the key is to have a matching configuration on both sides.

     

    Port 3 on HP is - de-facto - set as an access port...for VLAN unaware hosts...so it's OK...the host should be (IP) addressed on the range expected for VLAN 7. It's simple.

     

    But, generally speaking, you should summarize about VLANs you have, VLANs you need, VLANs you need to be transported between switches...in order to understand how to pass them between devices and from devices to edge hosts.



  • 16.  RE: Setting Access Port for Procurve 2910

    Posted Apr 07, 2020 03:34 PM

    "indeed there isn't the usual expected row "switchport trunk allowed vlan <single vlan-ids or range>" (see here to understand what I mean). Consider that the native VLAN is also allowed automatically...so your GigabitEthernet0/1 is a "Trunk" port with no other VLAN ids permitted other than its native VLAN 2."

     

    I tried to add another vlan:

     

    interface GigabitEthernet0/52
    description TRUNK-TO-FI-SWITCH
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 2
    switchport trunk allowed vlan 10
    switchport mode trunk

     

    Then I pinged the HP switch:

     

    AVTA_SW_Admin-1#ping 192.168.2.9
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.2.9, timeout is 2 seconds:
    .....
    Success rate is 0 percent (0/5)

     

    This broke the connection. I had remove vlan 10 and the connection came back up. It doesnt seem like I can use the allow vlan command to pass through other vlans to the HP...

     



  • 17.  RE: Setting Access Port for Procurve 2910

    Posted Apr 07, 2020 04:32 PM

    Here is what have changed, there is no more Trk2 on HP:

     

    vlan 2
    name "INSIDE"
    untagged 2-3,5-19,24,Trk1
    ip helper-address 192.168.2.234
    ip address 192.168.2.9 255.255.254.0
    jumbo
    ip igmp
    exit  

     

    vlan 7
    name "Public"
    tagged 24
    no ip address
    exit

     

    All of my required VLANS have port 24 tagged now instead of Trk2:

    vlan 10
    name "VOICE"
    ip helper-address 192.168.2.234
    tagged 2,4-20,24,Trk1
    voice
    no ip address
    jumbo
    ip igmp
    exit


    vlan 15
    name "SERVERS"
    tagged 24,Trk1
    no ip address
    exit
    vlan 20


    name "DATA"
    tagged Trk1
    no ip address
    exit
    vlan 25


    name "WIRELESS"
    untagged 1
    tagged Trk1
    no ip address
    exit
    vlan 26


    name "BUS-VIDEO-WIRELESS"
    tagged 1,24,Trk1
    no ip address
    exit
    vlan 27


    name "WIRELESS-DATA"
    tagged 1,24,Trk1
    no ip address
    exit
    vlan 30


    name "SECURITY"
    tagged 24,Trk1
    no ip address
    exit


    vlan 40

    name "SECURITY-BADGE"
    tagged 9,24,Trk1
    no ip address
    exit


    vlan 45
    name "CONTRACTOR"
    tagged 24,Trk1
    no ip address
    exit


    vlan 172
    name "GUEST"
    tagged 1,24,Trk1
    no ip address
    exit


    vlan 222
    name "AV-SYSTEMS"
    tagged 24,Trk1
    no ip address
    exit


    vlan 28
    name "GENERAL2-WLAN"
    tagged 1,24,Trk1
    no ip address
    exit


    vlan 254
    name "HAMS-WIRELESS"
    tagged 1,24,Trk1
    no ip address
    exit


    vlan 35
    name "Security"
    tagged 24,Trk1
    no ip address
    exit


    vlan 7
    name "Public"
    tagged 24
    no ip address
    exit

     

    On cisco, when I add vlan 7 to the trunk it still breaks my connection to the HP switch:

     

    interface GigabitEthernet0/52
    description TRUNK-TO-FI-SWITCH
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 2
    switchport trunk allowed vlan 7
    switchport mode trunk

     

    I also tried adding the rest of my VLANS to pass through the trunk, still broken connection, cannot ping HP switch: 

     

    interface GigabitEthernet0/52
    description TRUNK-TO-FI-SWITCH
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 2
    switchport trunk allowed vlan 7,10,15,20,25-28,30,35,40,45,172,222,254
    switchport mode trunk

     

     



  • 18.  RE: Setting Access Port for Procurve 2910

    Posted Apr 07, 2020 09:19 PM

    I think its worth taking a look at the spanning-tree configuration.

    Use the show spanning-tree on Cisco and HP switches to make sure they agree on the correct root for the network ( as the description you have been giving it is problably the cisco switch).

    And also use the show log on both switches to look for messages that can give you an idea about what happens when you add the others vlans to the port channel.

     

    Information

    Common Spanning-Tree (CST).

    Details

    What Spanning-Tree mode should be chosen between Cisco and ProCurve Switches?

    MSTP is obviously the ideal choice because it is standard based and supported by both vendors, it converges quickly and allows load-balancing of traffic on uplinks with appropriate configuration. If not all the devices support MSTP yet, a progressive migration to MSTP can be put in place as it inter-operates with Standard, Rapid Spanning Tree modes and with PVST via the Native Vlan.

    NOTE: All STP modes interoperate via the standard spanning-tree mode also named the Common Spanning-Tree (CST). So whatever you choose, i.e MST, PVST+, you should always carefully define the root and secondary root of the CST.

    On a Cisco switch, issue the Show Spanning-Treecommand from the CLI and look after the priority of the STP in the Native Vlan (vlan 1 by default), on a ProCurve switch issue the Show Spanning-Tree CLI command and look after the globalpriority of STP to determine the root and secondary root of the CST.

    Details from this article were found in the HP ProCurve/Cisco Interoperability Guide.



  • 19.  RE: Setting Access Port for Procurve 2910

    Posted Apr 08, 2020 05:34 AM

    Hi, provided that I agree with @Minondas about the STP that need to be understood and harmonized between your two interconnected switches...can you provide the output (both on Cisco and HP sides) of:

     

    show  spanning-tree (and the equivalent on Cisco IOS to understand what STP is used)

    show vlan port 24 detail (and the equivalent on Cisco IOS to understand how the GigabitEthernet0/52...wasn't 0/1 before?...is configured with regards to VLANs)

     

    what do you mean with the terms "when I add vlan 7 to the trunk it still breaks my connection to the HP switch" or "still broken"?

     

    Is the link up or not? Ping is another story...first you need to understand if the link is up or down, theoretically (I didn't see a topology map or actual sanitized configurations) there should be no physical loops between the Cisco and the HP...so STP should not seize your single link.



  • 20.  RE: Setting Access Port for Procurve 2910

    Posted Apr 08, 2020 10:36 AM

    So when I added my vlans to Cisco trunk I was no longer able to remote into the HP and could not ping it. This is what I meant when I said it broke my connection. The status and protocol was still up. Only until I added allow vlan 2 to the command, then I was able to ping and remote back into HP. I didnt think I had to allow vlan 2 since the command for native vlan 2 was already in that trunk, at the moment I sitll cannot reach computer at the other end of port 3 on the HP which uses vlan 7:

     

    interface GigabitEthernet0/52 (accidentally posted int0/1 before)
    description TRUNK-TO-FI-SWITCH
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 2
    switchport trunk allowed vlan 2,7,10,15,20,25-28,30,35,40,45,172,222,254
    switchport mode trunk

     

    Cisco spanning tree:

     

    AVTA_SW_Admin-1# sh spanning-tree summary
    Switch is in pvst mode
    Root bridge for: VLAN0002, VLAN0007, VLAN0010, VLAN0015, VLAN0025, VLAN0035
    VLAN0045, VLAN0110
    Extended system ID is enabled
    Portfast Default is disabled
    PortFast BPDU Guard Default is disabled
    Portfast BPDU Filter Default is disabled
    Loopguard Default is disabled
    EtherChannel misconfig guard is enabled
    UplinkFast is disabled
    BackboneFast is disabled
    Configured Pathcost method used is short

    Name Blocking Listening Learning Forwarding STP Active
    ---------------------- -------- --------- -------- ---------- ----------
    VLAN0001 0 0 0 6 6
    VLAN0002 0 0 0 23 23
    VLAN0007 0 0 0 8 8
    VLAN0010 0 0 0 23 23
    VLAN0015 0 0 0 7 7
    VLAN0019 0 0 0 6 6
    VLAN0025 0 0 0 7 7
    VLAN0026 0 0 0 7 7

    Name Blocking Listening Learning Forwarding STP Active
    ---------------------- -------- --------- -------- ---------- ----------
    VLAN0027 0 0 0 7 7
    VLAN0028 0 0 0 7 7
    VLAN0030 0 0 0 7 7
    VLAN0035 0 0 0 7 7
    VLAN0040 0 0 0 7 7
    VLAN0045 0 0 0 7 7
    VLAN0110 0 0 0 6 6
    VLAN0172 0 0 0 7 7
    VLAN0222 0 0 0 7 7
    VLAN0254 0 0 0 7 7
    ---------------------- -------- --------- -------- ---------- ----------
    18 vlans 0 0 0 156 156

     

    AVTA_SW_Admin-1#sh spanning-tree int gi0/52

    Vlan Role Sts Cost Prio.Nbr Type
    ------------------- ---- --- --------- -------- --------------------------------
    VLAN0002 Desg FWD 4 128.52 P2p
    VLAN0007 Desg FWD 4 128.52 P2p
    VLAN0010 Desg FWD 4 128.52 P2p
    VLAN0015 Desg FWD 4 128.52 P2p
    VLAN0025 Desg FWD 4 128.52 P2p
    VLAN0026 Desg FWD 4 128.52 P2p
    VLAN0027 Desg FWD 4 128.52 P2p
    VLAN0028 Desg FWD 4 128.52 P2p
    VLAN0030 Desg FWD 4 128.52 P2p
    VLAN0035 Desg FWD 4 128.52 P2p
    VLAN0040 Desg FWD 4 128.52 P2p
    VLAN0045 Desg FWD 4 128.52 P2p
    VLAN0172 Desg FWD 4 128.52 P2p
    VLAN0222 Desg FWD 4 128.52 P2p
    VLAN0254 Desg FWD 4 128.52 P2p

     

    Spanning Tree HP:

     

    FuelIsland# sh spanning-tree

    Multiple Spanning Tree (MST) Information

    STP Enabled : Yes
    Force Version : STP-compatible
    IST Mapped VLANs : 1-4094
    Switch MAC Address : 38eaa7-762d40
    Switch Priority : 32768
    Max Age : 20
    Max Hops : 20
    Forward Delay : 15

    Topology Change Count : 16,558
    Time Since Last Change : 24 mins

    CST Root MAC Address : 38eaa7-762d40
    CST Root Priority : 32768
    CST Root Path Cost : 0
    CST Root Port : This switch is root

    IST Regional Root MAC Address : 38eaa7-762d40
    IST Regional Root Priority : 32768
    IST Regional Root Path Cost : 0
    IST Remaining Hops : 20

    Root Guard Ports :
    TCN Guard Ports :
    BPDU Protected Ports :
    BPDU Filtered Ports :
    PVST Protected Ports :
    PVST Filtered Ports :

    | Prio | Designated Hello
    Port Type | Cost rity State | Bridge Time PtP Edge
    ----- --------- + --------- ----- ---------- + ------------- ----- --- ----
    1 100/1000T | 20000 128 Forwarding | 38eaa7-762d40 2 Yes No
    2 100/1000T | Auto 128 Disabled |
    3 100/1000T | 200000 128 Forwarding | 38eaa7-762d40 2 Yes No
    4 100/1000T | Auto 128 Disabled |
    5 100/1000T | 200000 128 Forwarding | 38eaa7-762d40 2 Yes No
    6 100/1000T | Auto 128 Disabled |
    7 100/1000T | Auto 128 Disabled |
    8 100/1000T | 20000 128 Forwarding | 38eaa7-762d40 2 Yes No
    9 100/1000T | 200000 128 Forwarding | 38eaa7-762d40 2 Yes No
    10 100/1000T | Auto 128 Disabled |
    11 100/1000T | Auto 128 Disabled |
    12 100/1000T | Auto 128 Disabled |
    13 100/1000T | 200000 128 Forwarding | 38eaa7-762d40 2 Yes No
    14 100/1000T | Auto 128 Disabled |
    15 100/1000T | Auto 128 Disabled |
    16 100/1000T | Auto 128 Disabled |
    17 100/1000T | Auto 128 Disabled |
    18 100/1000T | Auto 128 Disabled |
    19 100/1000T | Auto 128 Disabled |
    20 100/1000T | Auto 128 Disabled |
    21 100/1000T | Auto 128 Disabled |
    23 100/1000T | Auto 128 Disabled |
    24 1000SX | 20000 128 Forwarding | 38eaa7-762d40 2 Yes No
    Trk1 | 20000 64 Forwarding | 38eaa7-762d40 2 Yes No

     

     

    FuelIsland# sh vlan port 24 det

    Status and Counters - VLAN Information - for ports 24

    Port name: Admin-Trunk
    VLAN ID Name | Status Voice Jumbo Mode
    ------- -------------------- + ---------- ----- ----- --------
    2 INSIDE | Port-based No Yes Untagged
    7 Public | Port-based No No Tagged
    10 VOICE | Port-based Yes Yes Tagged
    15 SERVERS | Port-based No No Tagged
    20 DATA | Port-based No No Tagged
    25 WIRELESS | Port-based No No Tagged
    26 BUS-VIDEO-WIRELESS | Port-based No No Tagged
    27 WIRELESS-DATA | Port-based No No Tagged
    28 GENERAL2-WLAN | Port-based No No Tagged
    30 SECURITY | Port-based No No Tagged
    35 Security | Port-based No No Tagged
    40 SECURITY-BADGE | Port-based No No Tagged
    45 CONTRACTOR | Port-based No No Tagged
    172 GUEST | Port-based No No Tagged
    222 AV-SYSTEMS | Port-based No No Tagged
    254 HAMS-WIRELESS | Port-based No No Tagged

       

     

    FuelIsland# sh int brief

    Status and Counters - Port Status

    | Intrusion MDI Flow Bcast
    Port Type | Alert Enabled Status Mode Mode Ctrl Limit
    ------- --------- + --------- ------- ------ ---------- ----- ----- ------
    1 100/1000T | No Yes Up 1000FDx MDIX off 0
    2 100/1000T | No Yes Down 1000FDx Auto off 0
    3 100/1000T | No Yes Up 100FDx MDIX off 0
    4 100/1000T | No Yes Down 1000FDx Auto off 0
    5 100/1000T | No Yes Up 100FDx MDIX off 0
    6 100/1000T | No Yes Down 1000FDx Auto off 0
    7 100/1000T | No Yes Down 1000FDx Auto off 0
    8 100/1000T | No Yes Up 1000FDx MDIX off 0
    9 100/1000T | No Yes Up 100FDx MDI off 0
    10 100/1000T | No Yes Down 1000FDx Auto off 0
    11 100/1000T | No Yes Down 1000FDx MDI off 0
    12 100/1000T | No Yes Down 1000FDx Auto off 0
    13 100/1000T | No Yes Up 100FDx MDIX off 0
    14 100/1000T | No Yes Down 1000FDx Auto off 0
    15 100/1000T | No Yes Down 1000FDx MDIX off 0
    16 100/1000T | No Yes Down 1000FDx Auto off 0
    17 100/1000T | No Yes Down 1000FDx MDIX off 0
    18 100/1000T | No Yes Down 1000FDx Auto off 0
    19 100/1000T | No Yes Down 1000FDx Auto off 0
    20 100/1000T | No Yes Down 1000FDx Auto off 0
    21 100/1000T | No Yes Down 1000FDx Auto off 0
    22-Trk1 1000SX | No Yes Up 1000FDx off 0
    23 100/1000T | No Yes Down 1000FDx Auto off 0
    24 1000SX | No Yes Up 1000FDx off 0

     

     

     

     

     



  • 21.  RE: Setting Access Port for Procurve 2910

    Posted Apr 08, 2020 08:16 PM

    The HP switch is considering itself as the root for the CST instance. That means that the switches are not exchanging stp bpdu as expected.

    Cisco switch is running the PVST and as this is a proprietary protocol the HP switch does not have that option and is running MSTP.  

    The recommendation here would be to have booth switches running MSTP option.

     

    That said if you want to keep trying the mst/pvst interoperability I would first remove the option "stp force-version stp-compatible" from configuration.

    Then you will have to allow vlan 1 on the trunk/portchannel because cisco PVST will run the CST on that vlan no matter what the native vlan is. That's not the best practice to use vlan 1, but you can try leaving it as native on cisco and untagged on HP instead of vlan 2.

     

    In this scenario the MSTP and PVST will communicate through native/untaged vlan 1. As the booth sides have the vlan 1 configured as untaged/native that configuration may work.

     

    After that run the show spanning-tree on hp switch and make sure that the root for the CST the Cisco switch.

     

     

    1. If the PVST+ bridge is the root, this bridge must be the root for all VLANs (including the CST, which always runs on VLAN 1, regardless of the native VLAN, when the CST runs PVST+).

     

     



  • 22.  RE: Setting Access Port for Procurve 2910

    Posted Apr 08, 2020 05:37 AM

    Hi, provided that I agree with @Minondas about the STP that need to be understood and harmonized between your two interconnected switches...can you provide the output (both on Cisco and HP sides) of these two commands:

     

    • show  spanning-tree (and the equivalent on Cisco IOS to understand what STP is used)
    • show vlan port 24 detail (and the equivalent on Cisco IOS to understand how the GigabitEthernet0/52...wasn't GigabitEthernet0/1 before?...is actually configured with regards to VLANs)

    Moreover what do you mean with the terms "when I add vlan 7 to the trunk it still breaks my connection to the HP switch" or "still broken connection"?

     

    Is the link up or not? Ping is another story...first you need to understand if the link is up or down, theoretically (I didn't see a topology map or actual sanitized configurations) there should be no physical loops between the Cisco and the HP...so STP should not seize your single link.



  • 23.  RE: Setting Access Port for Procurve 2910

    Posted Apr 06, 2020 09:11 PM

    This is the output of an 2610 switch that has the same OS as the 2910.

     

    hostname "SW-2610"
    no telnet-server
    ip routing
    timesync sntp
    snmp-server community "public" Unrestricted
    vlan 1
    name "DEFAULT_VLAN"
    untagged 1-48,51-52
    ip address 192.168.1.8 255.255.255.0
    tagged 50
    no untagged 49
    exit
    vlan 1921
    name "VLAN1921"
    untagged 49-50
    no ip address
    exit
    vlan 172

    name "VLAN172"
    tagged 50
    exit
    ip route 0.0.0.0 0.0.0.0 192.168.1.1
    dhcp-snooping
    dhcp-snooping vlan 1
    ip ssh

    #

    #

    SW-2610(config)# show vlan 1921

    Status and Counters - VLAN Information - Ports - VLAN 1921

    VLAN ID : 1921
    Name : VLAN1921
    Status : Port-based
    Voice : No
    Jumbo : No

    Port Information Mode Unknown VLAN Status
    ---------------- -------- ------------ ----------
    49 Untagged Learn Down
    50 Untagged Learn Down


    GH-SW-2610_Escritorio(config)#

     

    With this simple configuration devices on the same vlan should have no problem communicating with each other.

     



  • 24.  RE: Setting Access Port for Procurve 2910

    Posted Apr 06, 2020 09:15 PM

    Running configuration:

     

    ; J9146A Configuration Editor; Created on release #W.14.38

     

    hostname "FuelIsland"

    time timezone -8

    time daylight-time-rule Continental-US-and-Canada

    module 1 type J9146A

    interface 1

       name "Aruba-Fuel-Island-AP"

       poe-lldp-detect enabled

    exit

    interface 2

       poe-lldp-detect enabled

    exit

    interface 3

       name "GFI-Computer"

       poe-lldp-detect enabled

    exit

    interface 4

       poe-lldp-detect enabled

    exit

    interface 5

       name "Workstation-and-VOIP"

       poe-lldp-detect enabled

    exit

    interface 6

       poe-lldp-detect enabled

    exit

    interface 7

       name "Workstation-and-VOIP"

       poe-lldp-detect enabled

    exit

    interface 8

       poe-lldp-detect enabled

    exit

    interface 9

       name "Fuel-Island-Lenel-Controller"

       poe-lldp-detect enabled

    exit

    interface 10

       poe-lldp-detect enabled

    exit

    interface 11

       name "Workstation-and-VOIP"

       poe-lldp-detect enabled

    exit

    interface 12

       poe-lldp-detect enabled

    exit

    interface 13

       name "Workstation-And-VOIP"

       poe-lldp-detect enabled

    exit

    interface 14

       poe-lldp-detect enabled

    exit

    interface 15

       poe-lldp-detect enabled

    exit

    interface 16

       poe-lldp-detect enabled

    exit

    interface 17

       poe-lldp-detect enabled

    exit

    interface 18

       poe-lldp-detect enabled

    exit

    interface 19

       poe-lldp-detect enabled

    exit

    interface 20

       poe-lldp-detect enabled

    exit

    interface 22

       name "Bushwash-Trunk"

    exit

    interface 24

       name "Admin-Trunk"

    exit

    trunk 22 Trk1 LACP

    trunk 24 Trk2 LACP

    ip default-gateway 192.168.2.5

    vlan 1

       name "DEFAULT_VLAN"

       untagged 20-21,23

       no untagged 1-19,Trk1-Trk2

       no ip address

       exit

    vlan 2

       name "INSIDE"

       untagged 2,5-19,Trk1-Trk2

       ip helper-address 192.168.2.234

       ip address 192.168.2.9 255.255.254.0

       jumbo

       ip igmp

       exit

    vlan 10

       name "VOICE"

       ip helper-address 192.168.2.234

       tagged 1-2,4-20,Trk1-Trk2

       voice

       no ip address

       jumbo

       ip igmp

       exit

    vlan 15

       name "SERVERS"

       tagged Trk1-Trk2

       no ip address

       exit

    vlan 20

       name "DATA"

       tagged Trk1-Trk2

       no ip address

       exit

    vlan 25

       name "WIRELESS"

       untagged 1

       tagged Trk1-Trk2

       no ip address

       exit

    vlan 26

       name "BUS-VIDEO-WIRELESS"

       tagged 1,Trk1-Trk2

       no ip address

       exit

    vlan 27

       name "WIRELESS-DATA"

       tagged 1,Trk1-Trk2

       no ip address

       exit

    vlan 30

       name "SECURITY"

       tagged Trk1-Trk2

       no ip address

       exit

    vlan 40

       name "SECURITY-BADGE"

       tagged 9,Trk1-Trk2

       no ip address

       exit

    vlan 45

       name "CONTRACTOR"

       tagged Trk1-Trk2

       no ip address

       exit

    vlan 172

       name "GUEST"

       tagged 1,Trk1-Trk2

       no ip address

       exit

    vlan 222

       name "AV-SYSTEMS"

       tagged Trk1-Trk2

       no ip address

       exit

    vlan 28

       name "GENERAL2-WLAN"

       tagged 1,Trk1-Trk2

       no ip address

       exit

    vlan 254

       name "HAMS-WIRELESS"

       tagged 1,Trk1-Trk2

       no ip address

       exit

    vlan 35

       name "Security"

       tagged Trk1-Trk2

       no ip address

       exit

    vlan 7

       name "Public"

       untagged 3

       tagged Trk2

       no ip address

       exit

    fault-finder bad-driver sensitivity high

    fault-finder bad-transceiver sensitivity high

    fault-finder bad-cable sensitivity high

    fault-finder too-long-cable sensitivity high

    fault-finder over-bandwidth sensitivity high

    fault-finder broadcast-storm sensitivity high

    fault-finder loss-of-link sensitivity high

    fault-finder duplex-mismatch-HDx sensitivity high

    fault-finder duplex-mismatch-FDx sensitivity high

    sflow 1 destination 192.168.15.232 9999

    sflow 1 polling 2-19 30

    sflow 1 sampling 2-19 128

    timesync sntp

    sntp unicast

    sntp server priority 1 192.168.15.100 3

    web-management ssl

    ip timep manual 192.168.15.100

    snmp-server community "publicv2" unrestricted

    spanning-tree

    spanning-tree Trk1 priority 4

    spanning-tree Trk2 priority 4

    spanning-tree force-version stp-compatible

    primary-vlan 2

    no autorun

    password manager

     


  • 25.  RE: Setting Access Port for Procurve 2910
    Best Answer

    Posted Apr 14, 2020 10:28 AM

    I was able to establish a connection with the device at the other end of port 3 with this configuration:

     

    HP:

    vlan 7
    name "Public"
    untagged 3
    tagged 24
    no ip address

     

    Cisco:

    interface GigabitEthernet0/52
    description TRUNK-TO-FI-SWITCH
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 2
    switchport trunk allowed vlan 2,7
    switchport mode trunk

     

    Thank you everyone that took time to reply with helpful suggestions.