Wired Intelligent Edge

 View Only
last person joined: 14 hours ago 

Bring performance and reliability to your network with the Aruba Core, Aggregation, and Access layer switches. Discuss the latest features and functionality of the ArubaOS-Switch and ArubaOS-CX devices, and find ways to improve security across your network to bring together a mobile first solution.
Expand all | Collapse all

job scheduler creating empty file, manual run works fine

This thread has been viewed 23 times
  • 1.  job scheduler creating empty file, manual run works fine

    Posted May 12, 2022 10:54 AM
    I have created a job to do a weekly config backup and on my switch stack this works well, but I have a small edge switch (an Aruba 2530 8G PoE+ Switch (J9774A)) and on this the job appears to run, but it only ever creates a 0 kb file with no contents. When I run the scheduled command manually, the file contains the config as expected, so it appears to be an issue with the job scheduler.

    The job is as follows:
    job "Backup-Config" at 16:30 on Sun "copy running-config tftp 10.X.X.X /ArubaSwitchCFGs/EdgeSwitch.bak"

    In an attempt to fix the issue I have upgraded the firmware from YA.16.03.0004 to YA.16.06.0006, but this hasn't had any effect on the problem.

    Any ideas on what to do/check to get this working?

    Aaron Smith

  • 2.  RE: job scheduler creating empty file, manual run works fine

    Posted May 12, 2022 05:55 PM
    Does the command work properly when it is run manually? I'm seeing that you're trying to copy to a subdirectory on the TFTP server - does the same command work as expected if you specify only the filename?

    Matt Fern
    Sr. Technical Marketing Engineer, Aruba Switching
    Aruba, a Hewlett Packard Enterprise company

  • 3.  RE: job scheduler creating empty file, manual run works fine
    Best Answer

    Posted May 12, 2022 07:52 PM
    Hi Matt, thanks for the reply, yes, when run manually the command works properly. I will try changing it to the root directory as suggested to see what happens though.

    Edit: After trying it to the root it seemed to run twice without issue, so I deleted the file in the subdirectory and it then worked twice in a row without issue there too. From memory, the first run did successfully create a good file before, but it was subsequent runs that deleted the file contents or created a blank one, so perhaps deleting the file and recreating it fixed some leftover permission problem caused by the previous firmware and allowed the file to be overwritten correctly. I will wait to see what happens on Sunday now in case there is some other environmental issue at that time.

    Edit 2: Scheduler ran at desired time and successfully overwrote the previous file so above process worked.
    In summary:
    1. Update to latest firmware
    2. Delete any files from previous attempts
    3. Successful file creation on subsequent attempts

    Aaron Smith

  • 4.  RE: job scheduler creating empty file, manual run works fine

    Posted Jun 09, 2022 12:00 AM
    Unfortunately this issue has returned. I checked the last run and once again I have an empty 0 KiB file. Anyone have any further ideas?