Wired Intelligent Edge

 View Only
last person joined: 3 days ago 

Bring performance and reliability to your network with the Aruba Core, Aggregation, and Access layer switches. Discuss the latest features and functionality of the ArubaOS-Switch and ArubaOS-CX devices, and find ways to improve security across your network to bring together a mobile first solution.
Expand all | Collapse all

Correct uplink between 2930F and 6300M

This thread has been viewed 36 times
  • 1.  Correct uplink between 2930F and 6300M

    Posted 25 days ago
    I am wondering what the best or ideal way to connect these two models (2930F and 6300M) would be?

    I have a point to point OSPF routing setup which is working. I have read a guide that had comparisons of the different OS types and how the command should look. I am thinking configuring it as an interface lag from the 6300M to the 2930F is the preferred way though?

    ------------------------------
    rford1219
    ------------------------------


  • 2.  RE: Correct uplink between 2930F and 6300M

    MVP GURU
    Posted 24 days ago
    Hi! Not sure how the OSPF Routing thing will be impacted by (or will be related to) the interconnection between two Switches you're trying to perform...but, probably, the most resilient way to interconnect them is to use a LAG (Links Aggregation) interface involving at least two physical interfaces and using LACP (so a quite standard LAG with LACP on Aruba 6300M side and a Port Trunk with LACP on the Aruba 2930F side).

    ------------------------------
    Davide Poletto
    ------------------------------



  • 3.  RE: Correct uplink between 2930F and 6300M

    Posted 24 days ago
    If you just need routing, I would create a routed lag on the 6300M, eliminating STP between the switches.
    2930F cannot do routed interface, but you could create a LACP trunk with the VLAN interface as Davide suggest.

    ------------------------------
    Tom Roholm
    ------------------------------



  • 4.  RE: Correct uplink between 2930F and 6300M

    Posted 23 days ago
    Ok, this is what I have done so far and I think I have the routed lag setup:

    On the 2930F I have only 2 VLANs (1 and lets say 100). I have an IP address assigned to both. I have the interface untagged on 100 and tagged on 1as trk1.

    vlan 1
    name "DEFAULT_VLAN"
    untagged 3-10
    tagged Trk1
    ip address 10.1.1.1 255.255.255.0
    exit
    vlan 100
    name "VLAN100"
    untagged Trk1
    ip address 10.100.1.1 255.255.0.0
    exit

    On my 6300M I have the following:
    ...
    vlan 1
    description Data Comm
    ...
    vlan 100
    description Voice
    ...
    interface lag 100
    no shutdown
    no routing
    vlan trunk native 1
    vlan trunk allowed all
    lacp mode active
    lacp rate fast
    ...
    interface vlan 1
    description Data Comm
    ip 10.1.1.2 255.255.255.0
    ip ospf 1 area 0.0.0.0
    ...
    interface vlan 100
    description Legacy
    ip address 10.100.1.2/16
    ip ospf 1 area 0.0.0.0

    What I see is that between the 2930 and 6300 I am able to ping the IPs and such, but I am not able to ping anything beyond this. The whole network is a 2930F connected to a 6300M which is connected to an 8320. Everything between the 6300 and 8320 pings and works fine, but trying to go from the 2930 to the 8320 I am not getting responses.

    ------------------------------
    rford1219
    ------------------------------



  • 5.  RE: Correct uplink between 2930F and 6300M

    MVP GURU
    Posted 22 days ago
    Hello, looking at the Trk1 (Aruba 2930F side) VLAN membership and at the lag100 (Aruba 6300M side) VLAN membership, they don't match:

    Aruba 2930F side -> Trk1 Untagged member of VLAN 100 and Tagged member of VLAN 1
    Aruba 6300M side -> lag100 Untagged member of VLAN 1 and Tagged member of All VLANs (implicitly including the VLAN 100).

    By the way, with respect to what was suggested you by Tom Roholm, the lag100 was not eventually configured as a "Routed LAG" (look at the "no routing" option you applied to it).

    I don't enter the OSFP part since I don't understand what you're really trying to achieve.

    ------------------------------
    Davide Poletto
    ------------------------------



  • 6.  RE: Correct uplink between 2930F and 6300M

    Posted 19 days ago
    Hello, 

    This switch is going to be just an access switch coming off of the 6300M and will only have a few Users/ devices on it. The network for this device is an 8320 in our Server Room going to the 6300M then to the 2930F. This is what a routed LAG set up looks like from what I gathered, I may be missing something (these are not the actual IPs).

    interface lag 1
    no shutdown
    routing
    lacp mode active
    lacp rate fast
    ip address 192.168.1.1/ 30
    int 1/1/1-1/1/2
    no shutdown
    routing
    lag 1

    On the 2930F:
    trunk 9-10 trk1 lacp
    VLAN 1
    untagged trk1
    ip address 192.168.1.2 255.255.255.252
    VLAN 100
    tagged trk1
    ip address 10.10.10.1 255.255.255.0

    What I see is that VLAN 1 IP addresses I am only able to ping on both 6300 and 2930 and nothing else. I do have an IP set up on VLAN 100 on the 2930 as well. On the 6300 I have all the interface VLANs setup and such. I am thinking I need a default route?


    ------------------------------
    rford1219
    ------------------------------



  • 7.  RE: Correct uplink between 2930F and 6300M

    MVP GURU
    Posted 17 days ago
    "This switch is going to be just an access switch coming off of the 6300M and will only have a few Users/ devices on it."

    If "This switch" is the Aruba 2930F...I really don't understand what is forcing you to avoid a simpler configuration where the Aruba 2930F is just will be configured as a Layer 2 extension of the existing Aruba 6300M (the extension will be done via a resilient LAG interconnection other than via a not-resilient single link interconnection).

    I mean...If you're forced to perform a Layer 3 interconnection between the Aruba 2930F (Access) and the Aruba 6300M (Distribution) - considering that your Aruba 8320 (Core) already seems to act a Layer 3 core for your networks (from what you wrote) - then you should plan it accordingly and let the Aruba 2930F to become a Routing switch, to create a /31 Transit VLAN to Aruba 6300M, to be configured with all necessary static routing on both ends (so the Aruba 2930F will know how to reach networks behind the Aruba 6300M and vice-versa so the Aruba 6300M will know how to reach networks behind the Aruba 2930F and let's it).

    Networks of Aruba 2930F <- Transit VLAN connection -> Networks of Aruba 6300M <-- L2 ? L3? connection -> Network of Aruba 8320

    IMHO this sounds very over-complicated IF the Aruba 2930F's role is just "Access" (your words: "access switch coming off of the 6300M and will only have a few Users/ devices on it") and a simple plain Layer 2 extension to the Aruba 6300M will be enough (and without considering that the routing for your network is already taking place at Aruba 8320).

    So, in the end, what exactly are you trying to achieve? What is your Network Topology? Who is doing the Routing for your Network segments? and so on...

    ------------------------------
    Davide Poletto
    ------------------------------