SD-WAN

 View Only
last person joined: 9 hours ago 

Forum to discuss Silver Peak EdgeConnect SD-WAN and Aruba SD- Branch. This includes SD-WAN Orchestration WAN edge network functions including routing, security, zone-based firewall, segmentation and WAN optimization, micro-branch solutions, best practices, third party integrations, All things SD-WAN!
Expand all | Collapse all

2 x BGWs at one site (WAN HA) issues ?

This thread has been viewed 32 times
  • 1.  2 x BGWs at one site (WAN HA) issues ?

    Posted Sep 21, 2021 09:07 PM
    I am trying to test WAN redundancy (uplink sharing), single site with two BGWs. I followed most of this guide (https://www.arubanetworks.com/assets/tg/AVD_SD-Branch-Design.pdf) and it works initially.

    Main Gateway = Internet connection
    Backup Gateway = MPLS connection

    I see both uplinks on the Main Gateway, but then to test failover, I reboot the main gateway:
    VRRP does it's thing on the LAN side, eventually I get connectivity back to the DC via the MPLS circuit on the backup gateway (loose quite a bit of pings though)
    Main gateway comes back online eventually, builds the Internet overlay and takes over Master for VRRP on the LAN side, but then it never builds the GRE tunnel again between the two gateways for the MPLS uplink

    Anyone with experience configuring dual gateway at one site with uplink sharing ?


  • 2.  RE: 2 x BGWs at one site (WAN HA) issues ?

    EMPLOYEE
    Posted Sep 25, 2021 08:49 PM
    If you have configured the WAN redundancy correctly then you should see the "virtual tunnel" in the output of the "show uplink" running on each of the BGWs.
    Assuming thats the case and you also have configured VRRP for the LAN side VLANs then the general behaviour is that BGWs will treat both uplink interfaces equally, leaving it to PBR, load-balancing and DPS to determine which link is to be used for each traffic flow. so look at the those policies/configuration.

    here is the online doco of what is involved.
    https://help.central.arubanetworks.com/2.5.3/documentation/online_help/content/gateways/cfg/high_availability/workflow-steps.htm

    ------------------------------
    Any opinions expressed here are solely my own and not necessarily that of Hewlett Packard Enterprise or Aruba.
    ------------------------------



  • 3.  RE: 2 x BGWs at one site (WAN HA) issues ?

    Posted Sep 27, 2021 09:22 AM
    Yeah, I see the tunnel between the gateways initially, both gateways see both uplinks, but restarting one gateway, when it comes back online, it never builds that tunnel again between them


  • 4.  RE: 2 x BGWs at one site (WAN HA) issues ?

    EMPLOYEE
    Posted Sep 27, 2021 07:48 PM
    ok thats strange because the last time i checked it worked flawlessly, I suggest to reach out to TAC so you can resolve it quickly.

    regards
    Ariya

    ------------------------------
    Any opinions expressed here are solely my own and not necessarily that of Hewlett Packard Enterprise or Aruba.
    ------------------------------



  • 5.  RE: 2 x BGWs at one site (WAN HA) issues ?

    Posted Sep 28, 2021 01:12 AM
    Is the BGW uplink ip the same subnet?

    ------------------------------
    MinSu Song
    ------------------------------