View Only
last person joined: yesterday 

Forum to discuss Silver Peak EdgeConnect SD-WAN and Aruba SD- Branch. This includes SD-WAN Orchestration WAN edge network functions including routing, security, zone-based firewall, segmentation and WAN optimization, micro-branch solutions, best practices, third party integrations, All things SD-WAN!
Expand all | Collapse all

BGW 9004 Problem vLAN Trunk - Aruba Central

This thread has been viewed 13 times
  • 1.  BGW 9004 Problem vLAN Trunk - Aruba Central

    Posted Dec 10, 2021 10:16 AM

    I am first time user of Aruba Central but have decent understanding of networking in general but I am at  a loss as to what is causing the issue I am having currently.

    I have a 9004 Gateway connected to an Older 5406R zl1 switch.  For the purposes here lets say I am connected to GE0/0/0 on the Gateway, and A23 on the 5406,  vLAN 50. 

    When I set the Gateway port to access mode on vLAN 50, and assign A23 on the switch as vlan50 untagged,  everything works as expected. 

    However when I change GE0/0/0 to be a Trunk Port,  set Allowed vlans to 50, and Update the switch for vlan50 to be tagged nothing works.  I have also set the vLAN to trusted, with a security policy under Apply Security in central (I tried both ways) 

    In Trunk Mode I do not get any communication to the vlan,  pinging directly from the switch does not return anything. 

    I am sure I am missing something simple but I am not sure what else to try?

    Any help would be appreciated.  If I have to I can run in Access Mode but it will limit me in the future.


  • 2.  RE: BGW 9004 Problem vLAN Trunk - Aruba Central

    Posted Dec 10, 2021 05:15 PM
    Trunk port in AOS-S switches does not mean VLAN Trunking (802.1Q), it means link aggregation.
    If you want to enable 802.1Q VLAN trunk between 5406 switch  and 9006 gateway then you need to
    on the 5406 switch
    - remove trunk port configuration
    - for VLAN 50, have it tagged for that port that connects to 9004 gateway

    this means that the native VLAN on the 802.1q VLAN trunking is VLAN1 (by default, but you can change that by having some VLAN to be untagged for that port)

    on the 9004 for say port 0/0/0, you need to
    - configure the relevant VLANs ( in our example VLAN50)
    - set the mode to Trunk
    - set the native VLAN to match the untagged VLAN of the 5406 switch
    - allow VLANs = 1  and 50 (for our example) 

    Any opinions expressed here are solely my own and not necessarily that of Hewlett Packard Enterprise or Aruba.